FOG Snapin Task Never Clears



  • Well, I finally had a small success and got a snapin to work. :-) I used a program to convert my batch file to an exe and it seems to have worked successfully to install the software I was after but the snapin task in task manager never seems to clear…

    I’m using RC-8. I have the latest version of the clients on the host computers in question. Let me know what, if any, log files you’d like to see and I’ll post them.

    When I ran this snapin, I did so via basic tasks / advanced / single snapin. Like I said this snapin is an EXE file that was created from a working BAT file…

    Thanks!

    Cheers,

    Joe



  • @Wayne-Workman Sounds good. I appreciate the advice! I’m just glad it installed. :-)


  • Moderator

    @Joe-Gill If you can’t somehow prevent the EXE from causing a reboot, then we can’t help. Often times, EXEs and MSIs have arguments you can pass, sometimes these can specify a reboot or not. I don’t know anything about Sophos, so you will need to look into arguments if any, or a way to have it not reboot. If the snapin needs a reboot to complete successfully, you have to use FOG’s integrated shutdown/reboot for snapins.



  • @Wayne-Workman Any suggestions? I know the Sophos install does cause the machine to reboot… It is built in into their installer.


  • Moderator

    @Joe-Gill It would appear the EXE is causing a reboot, thus preventing the FOG Client from ever reporting in that the snapin finished.



  • @Wayne-Workman

    Here is the section of the log file that relates to the program installed…

    ------------------------------------------------------------------------------
    ---------------------------------SnapinClient---------------------------------
    ------------------------------------------------------------------------------
     8/9/2016 5:55 PM Client-Info Client Version: 0.11.5
     8/9/2016 5:55 PM Client-Info Client OS:      Windows
     8/9/2016 5:55 PM Client-Info Server Version: 16
     8/9/2016 5:55 PM Middleware::Response Success
     8/9/2016 5:55 PM SnapinClient Snapin Found:
     8/9/2016 5:55 PM SnapinClient     ID: 654
     8/9/2016 5:55 PM SnapinClient     Name: Sophos_11.3.1
     8/9/2016 5:55 PM SnapinClient     Created: 2016-08-09 17:54:00
     8/9/2016 5:55 PM SnapinClient     Action: 
     8/9/2016 5:55 PM SnapinClient     Pack: False
     8/9/2016 5:55 PM SnapinClient     Hide: False
     8/9/2016 5:55 PM SnapinClient     Server: http://172.16.1.22/fog
     8/9/2016 5:55 PM SnapinClient     TimeOut: 0
     8/9/2016 5:55 PM SnapinClient     RunWith: 
     8/9/2016 5:55 PM SnapinClient     RunWithArgs: 
     8/9/2016 5:55 PM SnapinClient     Args: 
     8/9/2016 5:55 PM SnapinClient     File: sophosinstall_11.3.1.exe
     8/9/2016 5:55 PM Middleware::Communication Download: http://172.16.1.22/fog/service/snapins.file.php?mac=B8:AC:6F:36:B7:04||00:00:00:00:00:00:00:E0&taskid=654
     8/9/2016 5:55 PM SnapinClient C:\Program Files (x86)\FOG\tmp\sophosinstall_11.3.1.exe
     8/9/2016 5:55 PM Bus {
      "self": true,
      "channel": "Notification",
      "data": "{\r\n  \"title\": \"Installing Sophos_11.3.1\",\r\n  \"message\": \"Please do not shutdown until this is completed\"\r\n}"
    }
     8/9/2016 5:55 PM Bus Emmiting message on channel: Notification
     8/9/2016 5:55 PM SnapinClient Starting snapin...
     8/9/2016 6:46 PM Bus Emmiting message on channel: Power
    

  • Moderator

    @Tom-Elliott He’s on the working-RC8 branch, I am too.



  • @Tom-Elliott I’m assuming it must be the working branch. I downloaded it last night using @Wayne-Workman’s instructions.

    I’m on:

    Wed Aug 10, 2016 7:35 am
    Running Version 16
    SVN Revision: 5948


  • Senior Developer

    RC-8 hasn’t released yet, so are you sure you’re on RC-8? Or are you running the working branch?


  • Moderator

    The fog client log is the first and only place to start troubleshooting.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.