boot error after deplying linux image



  • hello :)
    finally got fog on centos 7, captured and deployed some win 7 images, sucssessfuly.
    we have some users who are using linux-based os, which i can capture, and deploy.
    although, when i boot a pc after the deploy task is finished, i have a black screen says “boot error”.
    i have tried a lot of combinations at the “image management” for this image.
    i didnt try sector by sector image type, its just not a solution for me, cause it too slow.
    the os im trying to deploy called “thinstation” (linux-based), which i insatlled on the hardrive with a script using syslinux.exe

    any help?

    regards,
    niv.



  • well,
    i tried another way and solved it.
    installed grab4dos on the hard drive and set up a menu that will grab and boot thinstation.iso.
    captured it as a linux image, and deployed with no problems!



  • @george1421
    hey George

    i installed the os using DOS partition, through computer management in winpe.
    so the thing is that i need to install it with another way?
    maybe can u guide me how to install thinstation using the “linux way” ? :)
    a link will do just fine, i just dont really know what to search for this…


  • Moderator

    I agree with George. If it’s linux, why not use Ext4 ? FOG isn’t setup to handle Linux operating on NTFS, and that setup is pretty abnormal as well.


  • Moderator

    I have to think how to ask this…

    Did you install thinstation on the target computer using a DOS partition or a linux partition? Because I think what is happening is that FOG is getting confused if you say the image type is win95 vs linux. The boot loader is not getting set right.

    If you did this on the linux side (i.e. formatted and created the system using pure linux) then uploaded that image to FOG for deployment.

    I know (as I said) our thinstation image fits on a 4GB flash drive so you really don’t need a very big partition on your target systems. So even if you had to do a RAW image it should only take 30 seconds or so.



  • hey george,
    tnx for the quick reply.

    first of all ill answer question 4:
    im trying to deploy compiled os.
    i know that installing it on a local hard drive is not the best way to do it.
    i already set up pxe boot for this image (with some help from fog project) , but i still want a backup plan, so the users can work if the tftp/httpd services will fail.

    1. i cant tell the version cause its just saying “You are not running the most current version of FOG!”, at the web management, without telling me the current running version.
      i can tell the svn version which is 5892.
    2. as i already told, the os is the the comnpiled thinstation.
      3.the partition style is MBR.
      the way i installed the os on hard drive until now:
      booted up a pc with winpe through usb device, and used this script through cmd (installing syslinux on the hard drive and copying the thinstation files to the correct location):
    format c: /q /fs:NTFS /v:Thinstation
    syslinux64.exe -i -f c:
    md c:\boot
    xcopy boot c:\boot /s
    pause
    
    

    no need for a screen shot here, its just a dos ‘like’ screen says “boot error”.

    I hope i gave you enough information about whats going on here :)
    regards,
    niv.

    edit!
    i just want to say that using the old way with this script is working good, no problems at all, its just a slow and uncomfortable way to work, thats why i use fog.


  • Moderator

    I guess the first thing is we need to collect a bit of information before we can begin to help you.

    1. What version of FOG are you using?
    2. What target OS are you deploying that is stating boot error?
    3. What does the partition table look like for this linux host (are you using LVM or native partitions?)
    4. As for thinstation (I know of this and use it) are you trying to deploy the devstation or the compiled target OS? (we use a micro usb flash drive and don’t mess with any local hard drive, we also pxe boot some thinstation computers and that works really well too).

    [edit] having a screen shot of the exact error would also be helpful to see what is going on.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.