Lenovo Z70-80 freezes booting Windows after imaging.



  • Trying to deploy a Windows 7 x64 EFI image to a set of Lenovo Z70-80s. The image deployment appears to go successfully, up until the reboot, at which point Windows will, without fail, completely freeze at the “Setup is updating registry settings” stage. Having left the computer running over night, without progress, I am fairly certain that it is entirely stuck.
    However, as it has not yet entered the OOBE, there is very little logging that I can find of any use. Additionally, if I attempt to boot the device into safe mode, it freezes when loading disk.sys.
    Other research I have done has indicated that a BIOS update might potentially remedy the issue, but, conveniently, Lenovo appears to only provide an update utility which runs from within Windows. This means that I cannot update the BIOS on this machine, as Windows simply won’t boot.
    It’s most certainly not an issue with the image, as I have successfully deployed it to multiple other machines
    I’m pretty much lost here. Any suggestions as to how to diagnose this issue would be much appreciated.



  • Sorry for the prolonged absence. I’ve created a new legacy image, using the same driver deployment process. This image deploys successfully to the Z70-80. There are some other machines that we absolutely do need the legacy image for, so it’s not too much overhead to just use that image for the Z70-80.



  • @Wayne-Workman We’ve had success in using the universal image on several other kinds of devices.

    @george1421 We don’t have any spare drives lying around to do a replacement. Currently capturing a legacy image to determine whether UEFI/GPT might be related to the issue.


  • Moderator

    Another good question is, does this universal image work on any model?


  • Moderator

    @3541 Well this is an interesting (but more annoying issue). So its probably not an install driver issue, that still doesn’t rule out an absence of a required driver.

    Have you tried to replace that hard drive to rule that part out?

    What happens if you try to load the OS from DVD? If it loads do a quick sysprep capture (we only want a quick process to check the workflow and not create a finished product) and then deploy to a second computer. I realize that is a lot of work, but that process should tell us a bit more than we know right now.



  • @george1421
    With no drivers it behaves exactly the same.
    Yes it is a traditional hard drive (Samsung ST1000L, I believe).
    It’s a UEFI/GPT image and the system is in UEFI mode.


  • Moderator

    @3541 If you inject no drivers what happens? Can you get past this part?

    Just for clarity when you say “is a hard drive” you are talking about a device that uses spinning rust (what we might think of as a traditional hard disk drive)?

    Also are you deploying a UEFI/GPT image to this system that is in uefi mode, or are you trying to deploy a BIOS/MBR image to this system that is in uefi mode? AFAIK you have to deploy the right image format to the mode the device is in (i.e. uefi vs bios(legacy).



  • @george1421
    Yes we’re using a single image which is being deployed to multiple machines.
    We’re using a similar procedure to that which is described here: https://wiki.fogproject.org/wiki/index.php?title=Auto_driver_Install

    Once it gets to that screen, it’s completely frozen. No command window, not even a caps lock light. I did manage to look at those files by just booting into Ubuntu and copying them off, and I didn’t see anything indicative of such an error.

    The storage device is a hard drive.
    Thanks for the help


  • Moderator

    First of all, since the image is getting to the target system this is not a FOG issue.

    I’m going to suspect a driver issue either with the sata controller or with the storage device. Reading between the lines it sounds like you might have a single image you are deploying to all computers on your campus. How are you injecting the model specific drivers into your image?

    At the screen where its updating the registry, can you press Shift-F10 to open a command window? Can you inspect the log files in c:\windows\panther and c:\windows\panther\UG<something>? Does these log files give you any hint to what went wrong?

    What is your storage device on this Lenovo? Is it a HDD, SSD, or NVMe drive?


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.