RC4 Failed to Install - CentOS 7



  • I’m having an issue with the installer for RC4 not working correctly on CentOS 7 that appears to be a bug. I followed the wiki steps for installing on a fresh install of CentOS 7 using git but the installer script fails out at “* Copying new files to web folder” with the error message “cp: cannot overwrite non-directory ‘/var/www/html/fog/fog’ with directory ‘…/packages/web/fog’”.

    When I took a look at ‘/var/www/html/fog/fog’ I noticed that it looks to be a symlink back to ‘/var/www/html/fog’ which is why cp is failing out. Deleting the symlink before rerunning the install script doesn’t correct the issue and neither does manually running the failing cp command sans the final /fog so it seem like the installer is creating the symlink that’s causing the issue. Any help would be appreciated. Please let me know what log files, if any, are needed to track this down.


  • Senior Developer

    Issue confirmed. I was tryign to fix a bad status update in the repo earlier and apparently one of my links ended up in the mix.

    I deleted the entire repo and readded what was requried back.

    This should be fixed now.

    Please re-pull your repo (this only affected git users).



  • M2CW, I have just successfully installed “1.3.0-RC-4” on a CentOS 7.2.1511 Minimal Install that I compiled on 2016/07/15.

    I then reverted that VM and updated the OS:

    yum clean all
    yum makecache
    yum update -y
    

    Pulled these updates:

    libwbclient.x86_64 0:4.2.10-7.el7_2
    samba-client-libs.x86_64 0:4.2.10-7.el7_2
    samba-common.noarch 0:4.2.10-7.el7_2
    samba-common-libs.x86_64 0:4.2.10-7.el7_2
    samba-common-tools.x86_64 0:4.2.10-7.el7_2
    samba-libs.x86_64 0:4.2.10-7.el7_2
    

    “1.3.0-RC-4” still installed without issue.



  • I’m seeing the same error today on CentOS7. This was working properly when I tried it Wednesday 7/27, so it’s something that was added within the past couple days.



  • I only see an empty ‘fog’ directory in the /home location. I removed it and re-ran the installer but got the same result.


  • Senior Developer

    please remove the backup directory.

    should be located in:

    /home/fog_web_1.3.0-RC-4.BACKUP

    THen try again.



  • Ran both of those and verified directory removal. Re-ran installer; fails out with the same message.


  • Moderator

    Try

    sudo rm -rf /var/www/html/fog
    sudo rm -rf /var/www/fog
    

    Then rerun installer


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.