FOG Beta with external unmodifiable DHCP server



  • Hey there,

    We’re have a Cento 7 machine running FOG beta because we need to support windows 10 in my environment. However the quirk of the network is that my boss has us use an old router the DHCP server and doesn’t want to move off it. However the router is so old that it doesn’t support option 66 or 67 so I need to run Fog as a proxy server. We had it running fine in Fog 1.2.0 but are unable to get it working in fog BETA. Thanks in advance for any help you can provide

    Sincerely,
    Artur


  • Developer

    @Wayne-Workman Sorry but I’ve never heard of anyone netbooting an ARM platform. Not saying that this is not possible but I just have no clue. Seems like the ipxe devs don’t either. At least not back in 2013: http://forum.ipxe.org/showthread.php?tid=6808



  • @Tom-Elliott @Sebastian-Roth Do we have a boot ROM in fog for ARM x32 and ARM x64 ? If not, can we try to include some? Hmm… what about kernels for ARM?



  • @george1421

    Maybe something like this. I’ve not tested it. And yes, the latest binary of dnsmasq must be downloaded. I’m pretty sure that most linux distro’s rpm managers and most repos will currently give the older dnsmasq that doesn’t have proxy uefi support.

    Also, I think the same old .0 stuff applies with UEFI, so copies or symbolic links to take care of that.

    port=0
    log-dhcp
    tftp-root=/tftpboot
    
    dhcp-option=vendor:PXEClient,6,2b
    
    dhcp-range=x.x.x.x,proxy
    pxe-prompt="Press F8 for the Menu.", 5
    
    #BIOS
    pxe-service=X86PC, “Boot from network”, undionly
    pxe-service=X86PC, "Boot from local hard disk", 0
    
    #x86-64
    pxe-service=X86-64_EFI, "Boot From Network, (UEFI)", ipxe
    pxe-service=X86-64_EFI, "Boot from local hard disk", 0
    
    #BC-EFI
    pxe-service=BC_EFI, "Boot From Network, (UEFI)", ipxe
    pxe-service=BC_EFI, "Boot from local hard disk", 0
    
    #IA64_efi
    pxe-service=IA64_EFI, "Boot From Network, (UEFI)", ipxe
    pxe-service=IA64_EFI, "Boot from local hard disk", 0
    
    #IA32_EFI
    pxe-service=IA32_EFI, "Boot From Network, (UEFI)", i386-efi/ipxe
    pxe-service=IA32_EFI, "Boot from local hard disk", 0
    
    #Xscale_EFI
    pxe-service=Xscale_EFI, "Boot From Network, (UEFI)", ipxe
    pxe-service=Xscale_EFI, "Boot from local hard disk", 0
    
    
    #ARM 32   - don't know what file to use for fog.
    #pxe-service=ARM32_EFI, "Boot From Network, (UEFI)", i386-efi/ipxe
    #pxe-service=ARM32_EFI, "Boot from local hard disk", 0
    
    #ARM 64   - don't know what file to use for fog.
    #pxe-service=ARM64_EFI, "Boot From Network, (UEFI)", ipxe
    #pxe-service=ARM64_EFI, "Boot from local hard disk", 0
    
    

  • Moderator

    @Wayne-Workman said in FOG Beta with external unmodifiable DHCP server:

    https://wiki.fogproject.org
    Also, a greatly simplified version that will work fine with CentOS:
    https://wiki.fogproject.org/wiki/index.php?title=Fedora_21_Server#dnsmasq_.28if_using_ProxyDHCP.29_setup

    Slightly off topic, any guidance or getting support for both undionly and ipxe.efi in dnsmasq? The current settings support undionly. Is that part of the distros or do we (collectively) have to download and build the latest dnsmasq to get efi support.




  • Moderator

    @Artur You can remove dhcpd and disable the relevant dhcp options in /opt/fog/.fogsettings

    Then run

    yum install dnsmasq -y
    

    if I’m not mistaken and follow the dnsmasq instructions. I don’t believe DHCPD has proxy support.



  • Sorry Wayne, I meant trunk, my bad.

    Here’s the information you wanted. figured I’d throw in the SVN to be on the safe side.

    Running Version 1.3.0-RC-4
    SVN Revision: 5942

    I didn’t upgrade until I knew it would work since I didn’t want to risk the production system. I’m currently on a spare blade we had with the 1.2.0 fog server disconnected when I need to run a test.

    I tried installing it on a clean Centos7 server core so to not risk our production system. (after following the steps at https://wiki.fogproject.org/wiki/index.php?title=CentOS_7 ) I am unable to get the proxy boot working. I can verify that the machine booting into pxe boot does receive an IP address from our DHCP server, but it’s not getting the PXE boot information from the fog server. (There’s still a use for hubs. If only as line sniffers.)

    When I tried doing the having FOG install DHCP thinking I could then convert it to proxy I found that you guys no longer use dnsmaq but have moved to dhcpd and I have been unable to find any directions on how to setup proxy with dhcpd either from Fog project’s wiki or via google. Figured I’d ask here before slogging through the man pages seeing if there was anything there. Curious if I’m to close to problem or what it is I’m missing. Thanks for your help.



  • It’s just a simple dnsmasq configuration. Search the wiki for dnsmasq.


  • Moderator

    Just for clarity, you upgraded this centos 7 server from 1.2.0 to 1.3.0-rc4? Is this what you mean by beta (beta is not a term that is currently used by the fog project).


 

481
Online

41.5k
Users

12.0k
Topics

113.4k
Posts