Snapin Questions



  • Thu Jul 28, 2016 12:18 pm
    Running Version 1.3.0-RC-4
    SVN Revision: 5941
    Client-Info Version: 0.11.4

    I noticed that when I deploy a single snapin as a deployment task that the active task never clears. I do have the client installed on all of my hosts.

    Below is a the FOG.log file from one of the hosts where the active single snapin deployment task hangs.

    Please let me know which other log files you might be interested in. Thanks!

    -----------------------------------------------------------------------------
    ---------------------------------SnapinClient---------------------------------
    ------------------------------------------------------------------------------
     7/28/2016 8:37 AM Client-Info Client Version: 0.11.4
     7/28/2016 8:37 AM Client-Info Client OS:      Windows
     7/28/2016 8:37 AM Client-Info Server Version: 1.3.0-RC-4
     7/28/2016 8:37 AM Middleware::Response Success
     7/28/2016 8:37 AM SnapinClient Snapin Found:
     7/28/2016 8:37 AM SnapinClient     ID: 578
     7/28/2016 8:37 AM SnapinClient     Name: Windows KMS Activation
     7/28/2016 8:37 AM SnapinClient     Created: 2016-07-28 08:37:06
     7/28/2016 8:37 AM SnapinClient     Action: 
     7/28/2016 8:37 AM SnapinClient     Pack: False
     7/28/2016 8:37 AM SnapinClient     Hide: False
     7/28/2016 8:37 AM SnapinClient     Server: http://172.16.1.22/fog
     7/28/2016 8:37 AM SnapinClient     TimeOut: 0
     7/28/2016 8:37 AM SnapinClient     RunWith: cmd.exe
     7/28/2016 8:37 AM SnapinClient     RunWithArgs: 
     7/28/2016 8:37 AM SnapinClient     Args: 
     7/28/2016 8:37 AM SnapinClient     File: activation_script_cmd
     7/28/2016 8:37 AM Middleware::Communication Download: http://172.16.1.22/fog/service/snapins.file.php?mac=00:24:E8:28:B7:0C||00:00:00:00:00:00:00:E0&taskid=578
     7/28/2016 8:37 AM SnapinClient C:\Program Files (x86)\FOG\tmp\activation_script_cmd
     7/28/2016 8:37 AM Bus {
      "self": true,
      "channel": "Notification",
      "data": "{\r\n  \"title\": \"Installing Windows KMS Activation\",\r\n  \"message\": \"Please do not shutdown until this is completed\"\r\n}"
    }
     7/28/2016 8:37 AM Bus Emmiting message on channel: Notification
     7/28/2016 8:37 AM SnapinClient Starting snapin...
     7/28/2016 9:24 AM Bus Emmiting message on channel: Power
    

    Cheers,

    Joe



  • @Wayne-Workman I have done this with the MAK key. That works fine. We just wanted to switch over to KMS. Which with our script snap-in it seems to be activating just fine now. I still need to refine it though. I think I’m going to add @Mentaloid’s suggestions to my existing script. I do believe that will finalize automation. :-)



  • @Wayne-Workman Not yet. It’s on my list. LOL!



  • @Mentaloid I’m very green on a lot of this stuff so bear with me. I would think what you have right there should work just fine.

    I’ll be working on all of this stuff a little later this week. I’ll give that a try.


  • Moderator

    @Joe-Gill Have you tried putting in your key for a single host in the Product Key field, and seeing if the fog client will activate windows that way?



  • @Wayne-Workman Interesting… It just doesn’t ever seem to run. I can run the script aside from fog using “run as admin” and it does just fine. If I run it without elevated privileges it does not seem to do the command right.



  • @Joe-Gill

    W10_edu_act.cmd

    c:
    cd \windows\system32
    c:\windows\system32\cscript.exe //B c:\windows\system32\slmgr.vbs -skms kms7:1688 >> c:\SnapinLogs\W10Activate.log
    c:\windows\system32\cscript.exe //B c:\windows\system32\slmgr.vbs -ato >> c:\SnapinLogs\W10Activate.log
    

    .cmd files are handled by the fog client without any run with parms, and you wont have any local permissions issue.
    0_1469808607007_w10eduact.png

    I don’t use a KMS server, so I am unaware of if it would require domain credentials. I would think the machine would have to be domain joined though. I also was under the impression that you can set the KMS details as part of the domain policy.


  • Moderator

    @Joe-Gill all snapins run as SYSTEM, which has the highest authority over the local system, more than the admin account has.

    What part of the script needs admin?



  • @Joe-Schmitt Alright, I searched and searched and tried and tried but I cannot for the life of me figure out the how to get a script to run with elevated privileges. The command structure works, it just won’t run unless you are an admin. Any ideas are appreciated. Thanks!

    Cheers,

    Joe



  • @Joe-Schmitt Thanks Joe! I’ll give that a go!


  • Senior Developer

    Use the template feature and select batch script.



  • @Joe-Schmitt No problem. I would add that to the end of the script or just leave it in the parameters within FOG?


  • Senior Developer

    I would try the /c as I suggested.



  • @Joe-Schmitt Any ideas of what to try? Will powershell handle that any better?


  • Senior Developer

    It could also be because of the messed up filetype not existing. Cmd is weird sometimes.



  • @Joe-Schmitt Thanks! I’ll check it out. I’m still trying to learn this stuff.


  • Senior Developer



  • @Joe-Schmitt What does the /c parameter do?


  • Senior Developer

    If you select a batch script template you will notice you are missing the /c parameter.



  • @Wayne-Workman This is the script…

    cscript C:\Windows\System32\slmgr.vbs /skms kms7:1688
    
    

    KMS7 is just a DNS name for the “server”. And no you don’t have to do anything except put in admin credentials to run as admin.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.