Boot menu configuration



  • Question regarding trying to get “WHDD” setup for the boot menu so that I can test hard drives as needed from the server. I’ve current got a directory shared off of /var/www/html/whdd with

    whdd.bzi
    initramfs
    

    in that directory and my FOG Boot menu entry looks as follows.

    0_1469467163844_upload-07065851-ae9e-42dd-bdfd-d082dc37fbdc

    Can anyone point me in the direction I need to go to make this work? Thanks in advance.



  • @Quazz
    OK!!! Houston we have liftoff…

    I was able to get this working by completely ignoring mounting the iso at all and instead doing what I had found in another forum with directly using memdisk and the raw iso. My working config for this is as follows

    0_1469802843514_upload-365ae328-e013-4ad9-b6cc-2f6183ce8087



  • @Quazz
    the folder hdt is simply the mount point for the iso. It houses only the subfolder isolinux which contains the folder contents listed above. I will delve into the isolinux.cfg file to see where I can tweak it.Will report back with anything I can find.


  • Moderator

    @BedCruncher Alright, so essentially, isolinux.bin is the correct one to use, but you need to edit isolinux.cfg so that it can boot over the network and doesn’t get stuck looking for the CD.

    Unfortunately, I’m not entirely sure how to do that properly, if it’s even possible at all.

    Also, I notice you shared hdt/isolinux folder contents, but what’s in hdt itself?



  • @Quazz
    Tried both, menu.c32 gives same blinking cursor. isolinux.bin provides the following.
    0_1469801003596_upload-718e181a-5129-4d44-a653-add20c4c0847


  • Moderator

    @BedCruncher Try chaining the menu file. Or maybe isolinux.bin



  • @Tom-Elliott
    set fog-ip 192.168.240.10
    set fog-webroot fog
    set boot-url http://${fog-ip}/${fog-webroot}


  • Senior Developer

    @BedCruncher said in Boot menu configuration:

    URL Directory Listing
    backgnd.png
    boot.cat
    chain.c32
    display.png
    hdt.c32
    isolinux.bin
    isolinux.cfg
    memtest.bin
    menu.c32
    modules.ali
    pci.ids
    red.png

    What’s the variable for ${boot_url} set to?



  • @Quazz
    Just changed. Will have to wait a bit before I can test that. I’m also upgrading that laptop to W10 to beat the deadline. Will post back once I can try again.

    EDIT:
    After modifying the menu entry as you wanted me to do, I simply get a black screen with blinking cursor.


  • Moderator

    @BedCruncher Try changing kernel to chain

    Could be enough, not sure.



  • @Quazz
    Do you have a link showing how to do that with the new FOG 1.3 boot menus?


  • Moderator

    @BedCruncher c32 is pxelinux files as far as I know.

    You’ll probably need to chain it or something.



  • Don’t know why it isn’t putting the images in the reply correctly. to clarify the above.

    Boot Menu Entry

    Menu Item: 
    HDT
    
    Description: 
    Hardware Detection Tool
    
    Parameters: 
    kernel ${boot_url}/hdt/isolinux/hdt.c32
    boot
    

    URL Directory Listing

    backgnd.png
    boot.cat
    chain.c32
    display.png
    hdt.c32
    isolinux.bin
    isolinux.cfg
    memtest.bin
    menu.c32
    modules.ali
    pci.ids
    red.png
    


  • Ran across another issue with a different piece of software that I was trying to add to the boot menu. It’s the HDT Tool project. What I currently have done is attempted to use an old config and files from a previous PXE server while modifying the relevant boot menu options.

    I’ve also downloaded a bootable iso from the HDT site directly and mounted it in the same way as was done with the DBAN instructions. My current HDT boot configuration looks like.
    !(/uploads/files/1469718747285-upload-19c1aab6-dd48-46df-b832-599354fd1f0c.png)

    Can anyone offer advice/help on this?



  • This post is deleted!


  • I had simply modeled it after the entry that I put in above for DBAN.


  • Moderator

    You should remove the :WHDD

    It’s not necessary since the Menu item is already taking care of that and it might cause issues if you add any other items later on.



  • going to close this out now… helps when you specify

    boot
    

    as the last option.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.