1.3.0 RC-1 Snapin spaces


  • Testers

    Ubuntu 14.04
    FOG 1.3.0 rc-1
    Windows 7
    Client 0.11.4

    I just updated to RC-1 today and deployed my first machine. After updating the client on the image(for some reason 0.9.10 client won’t update to a newer version automatically). The machine joined the domain and then started to deploy snapins, after a little while I realized that I wasn’t getting notifications of the snapins completing so I checked and all snapins (except the first one) showed canceled. I tried redeploying all snapins and the same thing happened. So I checked the client log and the second snapin showed:

    ERROR: Snapin has does not exist
    So I skipped it and the rest would all complete fine. I then tried re-doing that snapin and it kept giving the same error. After I realized that it had spaces, I removed the spaces and re-uploaded the file to FOG and the snapin now works.

    Can we either correct the issue to allow spaces, or just have a check that will display an error if the snapin file name contains spaces?

    Not sure when this started to happen as I was still on 7961 and upgraded from there.



  • This post is deleted!

  • Senior Developer

    I’ve solved this thread so I don’t go nuts thinking I have keep finding and fixing this issue. Filenames with spaces (as well as other special characters) will be replaced with _ and this will be available to the next RC release.


  • Senior Developer

    So I’ve basically not failed to create a snapin due to spaces in the filename, rather i’ve told it to change all special characters in the filename to become underscores. This should prevent all the issues of delete/filenaming issue, etc…

    Thanks for reporting.


  • Senior Developer

    I removed the last posting as I realize I’m trying to test the RC-1 and get a good review. The working side, while viewable and usable as needed, should not be pushed by me. Please continue testing and reporting on the RC-1 side.


  • Testers

    @Tom-Elliott Why not just have a check for spaces and not allow spaces in the filename? I don’t see the issue with just giving an error message “Filename contains spaces, remove spaces and try again”. This seems like a better way to go anyway. As filename spaces can cause headaches in other ways too, especially in automated processes.

    The only reason I had spaces was due the file pre-existing and I was too lazy to rename before now. lol


  • Senior Developer

    @ITSolutions I’m aware of the snapin space filename issue. I have a solve for the hash getting, but getting it for the deletion of files has been a PITA for me currently.

    (PITA = Pain In the rearend.)


Log in to reply
 

434
Online

39001
Users

10717
Topics

101759
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.