Setting keymap does not update boot.php


  • Moderator

    So, I was trying to mess around in debug mode and noticed the keymap appeared to not working. I checked the list on the wiki and be-latin1 is listed, so it should work.

    I decided to check out boot.php and noticed the keymap argument is empty, even though the value is filled in under FOG General Settings.

    :fog.local
    sanboot --no-describe --drive 0x80 || goto MENU
    kernel bzImage32 loglevel=4 initrd=init_32.xz root=/dev/ram0 rw ramdisk_size=127000 keymap= web=192.168.1.154/fog/ consoleblank=0 rootfstype=ext4 nolapic_timer loglevel=4
    imgfetch init_32.xz
    boot || goto MENU
    :fog.memtest
    kernel memdisk iso raw
    initrd memtest.bin
    boot || goto MENU
    kernel bzImage32 loglevel=4 initrd=init_32.xz root=/dev/ram0 rw ramdisk_size=127000 keymap= web=192.168.1.154/fog/ consoleblank=0 rootfstype=ext4 nolapic_timer loglevel=4
    imgfetch init_32.xz
    boot || goto MENU
    :fog.reginput
    kernel bzImage32 loglevel=4 initrd=init_32.xz root=/dev/ram0 rw ramdisk_size=127000 keymap= web=192.168.1.154/fog/ consoleblank=0 rootfstype=ext4 nolapic_timer loglevel=4 mode=manreg
    imgfetch init_32.xz
    boot || goto MENU
    :fog.reg
    kernel bzImage32 loglevel=4 initrd=init_32.xz root=/dev/ram0 rw ramdisk_size=127000 keymap= web=192.168.1.154/fog/ consoleblank=0 rootfstype=ext4 nolapic_timer loglevel=4 mode=autoreg
    

    This of course means I can’t use my designated keymap in those items.
    Running Centos 7, FOG revision 8601


  • Moderator

    @Tom-Elliott Thanks, that would be really helpful to a lot of people I feel. It’s of course possible to setup a putty session or something, but having keymaps in debug mode sounds awesome.


  • Senior Developer

    I can take a look at that, it would seem odd to want keymap for non-debug considering you don’t have access to the keyboard normally.


  • Senior Developer

    @Quazz I don’t know how linux enables the keymap, but I think the keymap= portion requires a special layout. This would need to be reflected in the definition as well.


  • Moderator

    @Tom-Elliott Thanks for the quick response, I can confirm boot.php being filled in properly now.

    Unfortunately the keymap seems to still not take effect (I’ve currently only tested in debug mode), I’ve tried the azerty keymap instead and the result is the same.

    Any idea on what might be the cause of this?

    edit: Derp, after taking a closer look, debug mode does not load the keymap at all so of course that won’t work!


  • Senior Developer

    Found and confirmed the issue. Thanks for reporting. It’s been patched and is currently pushed.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.