FOS Capabilities


  • Moderator

    I’m interested in utilizing postdownloadscripts, but in order to do so I would like to know what exactly is possible on the bzImage kernel of FOG.

    For example, can I mount a nfs share? (my limited testing seems to say no)

    Can I use FTP? (I would assume so since it uses FTP) and if so which brand of FTP does it use?

    Perhaps it would be helpful to compile a list of built-in functionality people can always return to so it will be a lot easier to create great postdownloadscripts.


  • Moderator

    @george1421 I was simplying using mount -t nfs, no other modifiers, so yeah, specifying the protocol is probably what does it.

    Still much to learn about Linux and such, heh.


  • Moderator

    @Quazz With the FOS engine, mount (an a lot of other FOS linux commands) are actually managed by Busybox. So mount isn’t the traditional linux mount command. That may explain some of the minor differences between what you expect and what it really does.

    It would be interesting to know what bit of the original mount command actually was the bit you needed to make it work. My bet is the proto=tcp setting.

    Either way I’m glad you have it worked out.


  • Moderator

    @george1421 Using the command under item 1. I was able to mount the NFS share successfully, I guess it needs a bit more guidance in FOS than in full fledged Linux.


  • Moderator

    @Wayne-Workman As far as I know NFS v4 supports such things as well. At least, you could designate authenticated users and as such connect.

    @george1421 I’ll look into this tomorrow if I have some time. I don’t know why it’s timing out, but it’s not permission issues since I’ve used it as a storage node in the past and I can mount it on other installs just fine, I was looking into nfs mounting options before I went home, but ran out of time.


  • Moderator

    @george1421 said in FOS Capabilities:

    The same would also be true if you wanted to mount a windows share, cifs would need to be enabled in busybox.

    CIFS is enabled already - I’ve been working on imaging with Samba instead of NFS for the password protection it offers. NFS is the last big hole in fog.


  • Moderator

    I don’t have an answer for you since I haven’t tried to do crazy things with the post install script but I can give you a few hints maybe they will get you started on a solution.

    1. This is the command the FOS engine uses to connect to the fog server
      mount -o nolock,proto=tcp,rsize=32768,intr,noatime "$storage" /images
    2. I created a tutorial to create a windows storage node for FOG. I had an issue getting the nfs share permissions right on the windows server (NFS not NTFS). This is the command I used (on windows to create the NFS share). The keys were to allow root user to map to the share (FOS engine runs as root user), and to allow unmapped users to connect. You might want to check to see what access levels are defined for that nas.
      nfsshare images=c:\share\images -o rw sec=sys root unmapped=yes
      https://forums.fogproject.org/topic/6941/windows-server-as-fog-storage-node-proof-of-concept-blog/10

    Other random stuff
    the ftp client is not in the FOS linux. Tom would have to enable the ftp client to be built when busybox was recompiled. (speaking as a user) Its not that big of a deal to turn it on, its only one line in the config file then recompile.

    The same would also be true if you wanted to mount a windows share, cifs would need to be enabled in busybox.

    wget and tftp (client) can be used to move files if needed. wget can also be used to get/post data to websites or make api calls.

    I’m sure you already know this, but if your target computer is booted into debug mode. Give the root user a password, then you can connect to the FOS linux via putty or ssh from another computer. It helps with debugging since you can copy/paste/get screen captures much easier with putty running on windows.

    Also you can build a FOS usb boot drive. So you can boot directly into the debug mode right from usb. It helps with debugging and it boots really fast.
    https://forums.fogproject.org/topic/7727/building-usb-booting-fos-image/4

    Lastly I did “start” documenting some post install bits for managing a windows install in this document.
    https://forums.fogproject.org/topic/7740/the-magical-mystical-fog-post-download-script-under-construction


  • Moderator

    @Wayne-Workman Using your suggestion of using debug mode, I’ve learned that it hangs on trying to mount the NFS share and times out.

    This does not occur when I try to mount this (NAS) share on the FOG Server itself, though, there it mounts instantly and perfectly.

    Trying to mount an incorrect path shows up in the logs on the NAS so it’s definitely able to communicate properly, it just doesn’t seem able to mount the NFS share properly for whatever reason.

    I’ll investigate more tomorrow


  • Moderator

    It can do a lot, it’s Linux.

    You can always modify the inits - but then you would spend a lot of time rebuilding them with all the changes that happen.

    Develop your scripts in debug mode, use scp or some other transfer utility to copy your work to a server somewhere before shutting down.


  • Moderator

    @Tom-Elliott That makes sense.

    I’ve not been able to mount nfs shares in postdownload scenarios, not sure why though. I’ll investigate some more.

    Alternatively, commands like wget and the like should work, right?


  • Senior Developer

    Kernels are kernels man. I know that seems odd, but all kernels do is create the interfaces between the environment and the OS. Functionality is not on the kernel in any way. Primarily, the kernel just contains the drivers needed to operate your hardware and allows the OS to interface with those elements. (This is very basic I understand).

    I think the question should be rephrased to FOS Capabilities.

    For that, yes you can use NFS. No FTP is not in the FOS environment. Installing a client is possible, but the FTP that does occur happens at the server, not on the FOS side of things.

    In FOS you can do basically anything a very minimal Linux OS can do. I have a few extras, but for the most part you must remember FOS is not intended to be a “primary” OS. Instead it’s designed to be an “embedded” os that allows the functionality FOG needs to get the work done.

    I don’t know what else to put in for now.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.