FOG NODE - Access Denied



  • Just updated to latest SVN and noticed access denied in out put.
    Is this an issue?

    0_1468493564713_upload-2e4f1e43-35a7-4a41-96ca-11b6d0cfdf74


  • Moderator

    @ITCC You need to run installfog.sh again after updating .fogsettings



  • @Tom-Elliott

    I have updated the /opt/fog/.fogsettings file on the NODE to use the username / password found in:
    Web Interface -> FOG Configuration -> FOG Settings -> FOG Storage Nodes -> FOG_STORAGENODE_MYSQLPASS and FOG_STORAGENODE_MYSQLUSER

    is there a way to test it’s working as when you took a look the other day, it seemed OK and then i found this only after.
    When we looked at location setup, it seemed to be working fine.


  • Senior Developer

    @ITCC correct. Root access to a database is very typically blocked except for coming from the localhost (ipv4 localhost = localhost or 127.0.0.1, ipv6 = ::1).

    You can fix it, but seeing as this is a node, FOG creates the “fogstorage” user you see, which is done on a “wildcard” or the %. This enables any host to connect to that user. That user is restricted to ONLY the FOG Database, and the password is generated during the first install.

    If you need help with this, please let us know, but as @Wayne-Workman, @Quazz, and I have already stated, just update the node’s snmysqluser, snmysqlpass, and snmysqlhost to match that of what is stored in your database. The snmysqlhost will be set to whatever your FOG Server’s primary GUI access IP address will be.



  • Thanks for the reply, sorry for the delay (holiday).

    Looking at MySQL, looks like root can’t be used (if i’m reading it right) unless i make a change.
    Although, should i not be using fogstorage?? what would the password be.

    0_1470038717588_upload-c97bde50-ae0b-4f5f-b2f2-9b37267481f0


  • Moderator

    Tom and Quazz are correct.

    The storage node installation now checks to see if the machine it’s running on exists as a storage node in the fog DB on the main server. If it does not exist, it tries to register itself.

    In this case, because it couldn’t contact the main server’s database due to incorrect snmysqluser, snmysqlpass, and snmysqlhost being set inside of /opt/fog/.fogsettings on that storage node.

    Additionally, because that one part failed due to credentials, that storage node isn’t functioning correctly, won’t be able to report progress, won’t be able to host boot roms at all, and probably other things won’t work either.

    You can find the correct credentials in the web interface here:
    Web Interface -> FOG Configuration -> FOG Settings -> FOG Storage Nodes -> FOG_STORAGENODE_MYSQLPASS
    And set those inside of /opt/fog/.fogsettings correctly.


  • Moderator


  • Moderator

    This post is deleted!

  • Senior Developer

    As this is a node you installed, most likely there’s two things causing this.

    First, you’re logging in with the mysql root user. This will not work (Redhat, Fedora, Debian, Ubuntu, etc…) unless you create the wildcard to enable users to login with that.

    Second, if it is of the debian variants (Ubuntu, Debian, etc…) you likely need to disable bind-address to enable the wildcard users access.

    Third, why are you using the root mysql user on a node? The installation points you at exactly where you need to get this information during the initial install.



  • this is the storage node.
    V 1.2.0 (8581) (Debian)

    IP in the error relates to itself, not the FOG Master


  • Moderator

    Could we have some more details such as OS, FOG version, do you have storage nodes, etc


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.