Fog .032 and HP8000 elite



  • Fog .032 and HP 8000 elite. I cannot seem to get our HP 8000 elite PC’s to image or do any task in fog. When I run the compatibility from fog menu it does state that network drivers are incompatible. but I am also receiving errors like this one “acpi lnxcpu 00 invalid pblk length”. Any help would be appreciated.


  • Moderator

    @george1421 said in Fog .032 and HP8000 elite:

    you are on 1.3.0-rc1we should not be talking about pxe.krn at all. For bios you should have undionly.kpxe or undionly.kkpxe and for uefi systems ipxe.efi.

    +1,000

    That’s what I was thinking since it was first mentioned.


  • Moderator

    @Troye-Johnson Two points then.

    1. You might want to refresh you svn/git and then install 1.3.0-rc4 (or 5). There was about 20 things that where fixed in RC3 alone.

    2. If you are on 1.3.0-rc1we should not be talking about pxe.krn at all. For bios you should have undionly.kpxe or undionly.kkpxe and for uefi systems ipxe.efi. If you are using some legacy iPXE driver or iPXE that doesn’t come from FOG you WILL have issues sooner or later.



  • @george1421 I did have to upgrade to the latest version of fog for this all to work. i am currently on Running Version 1.3.0-RC-1
    SVN Revision: 5936. Thanks you all for your help.


  • Moderator

    @Troye-Johnson I’m glad you have it worked out.

    It would be in your best interest, when you have time, to spin up a new fog 1.3.0 server if you plan on supporting new hardware/operating systems. 0.3X is past end of life for support from the developers and others who use fog. You can do what you like, but just know you will be better served with the latest enhancements in FOG / hardware / and Operating Systems by using FOG 1.3.0.



  • So i figured out that ipxe.krn was causing my “enter tftpboot” issues for some reason with the old ipxe.krn the issue did not happen but also did not contain the drivers I needed for the nic of the HP8000 Elite desktops I was working on. The new ipxe.krn had the correct drivers but refused to pass the tftpboot server information.So I tried the ipxe.krn from ipxe.iso located on the site http://ipxe.org/download and it worked for me. I no longer need to enter the address and i was able to inventory the pc.


  • Moderator

    @Troye-Johnson said in Fog .032 and HP8000 elite:

    When trying preboot into fog it starts to ask me to input the tftp server.

    This is typically caused by having two or more DHCP servers serving that broadcast domain, and one or more of them not being configured correctly for fog.


  • Moderator

    @Troye-Johnson How ever it is setup, what the issue is… the target computer is not getting dhcp option 66. How you get that value to the target is up to you. Once dhcp option 66 (and 67) are sent to the client it should boot into the iPXE FOG menu.



  • @george1421 the thing is it is the only server that is used currently for pre-boot dhcp (the only one turned on in the list). Maybe if I give more details the fog server is on the .1 subnet so 192.168.1.x and the client pc is on the 192.168.11.x subnet the dnsmasq proxy dhcp is configured to allow it to work across any 192.168.x.x subnet so the machine gets an ipaddress then loads the to Ipxe and after it gets to ipxe it configures the nix and says ok and then ask to enter the tftp server.


  • Moderator

    @Troye-Johnson Since the target system and proxyDHCP server are not on the same subnet, the proxyDHCP server will never hear the dhcp request since it is broadcast based within the broadcast domain. Since you are using a dhcp-helper/dhcp-relay service the easy fix is to add the proxyDHCP server as the last dhcp server in the dhcp-helper service. You don’t want the proxyDHCP server to answer an address, but you want it to be aware of the dhcp request and where to send the proxy reply.

    It sounds complicated, and it is a little. But you also have a bit of a complicated setup too.



  • dnsmasq (proxyDHCP) is installed on the fog server. The switch is using IP-helper-Addresses to delver and ip address for pre-boot. dnsmasq only serves as a proxydhcp server not the actual dhcp server it is the switch that actually gives out the preboot ipaddress. no they are not on the same subnet, but in dnsmasq config i placed the x.x.x.x,proxy,255.255.0.0 in order for it to work across subnets.


  • Moderator

    @Troye-Johnson Just so I’m clear you are running dnsmasq (proxyDHCP) on your switch?

    Is the fog server in the same subnet as the target computers?



  • @george1421 We have a windows dhcp server but my boss uses iphelper with dnsmasq to do proxydhcp from the switch. He gave it to me to get it to work I would much rather use dhcp from the windows servers with options 66 and 67.


  • Moderator

    @Troye-Johnson If iPXE asks for the fog server then proxyDHCP is not sending out dhcp option 66 correctly. Ensure that dnsmasq is running if you need proxyDHCP support.

    I do have to ask why do you need proxyDHCP? Doesn’t your dhcp server support providing options 66 and 67 directly? Also with the dnsmasq that ships with centos 6 there is no way to automatically support uefi systems in your environment. What system are you using for your dhcp server?



  • Ok So i got the latest version working on centos 6 with proxydhcp. When trying preboot into fog it starts to ask me to input the tftp server. If i manually put in the server I can get to the fog screen and it seems to work fine, but I am trying to figure out why it is asking me to put in the fog server.


  • Moderator

    @Troye-Johnson said in Fog .032 and HP8000 elite:

    Ok thanks I will try a newer version of fog.

    That is probably your best choice to get support for the newest hardware, WIn10, gpt disks, and uefi firmware. As a suggestion I would install the trunk (development) version of FOG 1.2.0. That way you can be sure that your hardware is supported.



  • Ok thanks I will try a newer version of fog.


  • Moderator

    To put it bluntly with 0.32 you are S.O.L. when it comes to that HP 8000, the kernels are too old to support the newer hardware.

    Hardware reference: NIC is Intel 82567LM (it looks like you need kernel 3.19 or newer)


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.