Router does not have PXE support



  • Hello,
    Configuring a home network; D-link router with DHCP turned on but does not have the options of PXE forwarding to my FOG server. I’ve tried configuring my FOG server with MAC filtration (1 machine to test with) and get some results…until my other machines on the network (the wife’s and kid’s computers) can no longer connect to the internet.

    I’m thinking, could I turn off my D-link DHCP option and allow my FOG server handle all the IP request, even the Wi-Fi?



  • Thanks for the reply, I’m using my home environment for testing since i’m pretty new with Ubuntu, but I’ll look into Clonezilla afterwards. As for the router I just bought a new one from D-link…I’ve never had a bad one in the past and didn’t realize the one I got can not use DD-WRT without risk.



  • Here are some options for you - I did the DD-WRT version for a linksys router.

    ~$40 4 Port Router Wireless MIXED Linksys WRT54GS V7.2 DD-WRT – This one is 10/100
    ~$80 4 Port Router Wireless-N MIXED Linksys WRT160NL DD-WRT – This one is gigabit ready.

    You’ll need to install the DD-WRT onto these devices and then set it up as found here for FOG.
    DD-WRT ->[url]http://www.dd-wrt.com/site/support/router-database[/url]
    FOG Setup for Above ->[url]http://fogproject.org/wiki/index.php?title=FOG_with_DD-WRT_firmware[/url]

    Hope this help!


  • Developer

    FOG really is overkill for a home network. Clonezilla or something similar would be much more practical.

    You could use gPXE [url]http://rom-o-matic.net/[/url] to PXE boot from your FOG server. Manually enter the FOG servers IP Address and filename (filename is ‘pxelinux.0’)

    As you suggest, FOG could run your DHCP. Wi-Fi can still be handled by your D-Link as FOGs DHCP will work for Wi-Fi clients


Log in to reply
 

386
Online

39.4k
Users

11.1k
Topics

105.3k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.