.fogsettings was blank



  • So, this is wild. Trunk 8359.

    I’m in the middle of updating 15 nodes on our big fog system, and one of the node’s installer kept failing. Saying answer not recognized, it can’t run, must move to another directory, and so on.

    I check the /opt/fog/.fogsettings file. It’s totally empty! ???

    I sure didn’t delete everything in it, nobody else did either. It’s pretty crazy.

    I made a copy of the file, then deleted it and that allowed me to update albeit I had to plug in settings.

    
    
       +------------------------------------------+
       |     ..#######:.    ..,#,..     .::##::.  |
       |.:######          .:;####:......;#;..     |
       |...##...        ...##;,;##::::.##...      |
       |   ,#          ...##.....##:::##     ..:: |
       |   ##    .::###,,##.   . ##.::#.:######::.|
       |...##:::###::....#. ..  .#...#. #...#:::. |
       |..:####:..    ..##......##::##  ..  #     |
       |    #  .      ...##:,;##;:::#: ... ##..   |
       |   .#  .       .:;####;::::.##:::;#:..    |
       |    #                     ..:;###..       |
       |                                          |
       +------------------------------------------+
       |      Free Computer Imaging Solution      |
       +------------------------------------------+
       |  Credits: http://fogproject.org/Credits  |
       |       http://fogproject.org/Credits      |
       |       Released under GPL Version 3       |
       +------------------------------------------+
    
    
       Version: 8359 Installer/Updater
    
    
     * Found FOG Settings from previous install at: /opt/fog/.fogsettings
    
     * Performing upgrade using these settings
      Sorry, answer not recognized
    
    
    Please change installation directory.
    Running from here will fail.
    You are in /root/git/fogproject/bin which is a folder that will
    be moved during installation.
    [root@aifog bin]# vim /opt/fog/.fogsettings 
    [root@aifog bin]# cp /opt/fog/.fogsettings /opt/fog/.fogsettings.old
    [root@aifog bin]# rm -f /opt/fog/.fogsettings
    [root@aifog bin]# ./installfog.sh
    


  • @Sebastian-Roth doubtful. I have no idea what happened.


  • Developer

    @Wayne-Workman Can we reproduce this?


  • Senior Developer

    @Wayne-Workman I’m only saying what I’m seeing. I’ve never heard of an instance where fog settings was just blank. Only thing I might believe would be something like disk space, which I doubt was your issue here.



  • But I’m almost sure that the last update didn’t fail? I’m pretty good about knowing if that happens lol.


  • Senior Developer

    This sounds to me like that node failed or was cancelled before it wrote the .fogsettings file.


 

588
Online

5.4k
Users

12.6k
Topics

118.7k
Posts