Disparities Between Config file for release and trunk



  • Hello,

    Just wanted to let you guys know that you have some syntactical differences between the config files for 1.2.0 and the SVN that caused me no small amount of grief. After wasting hours uninstalling and reinstalling both versions, I finally decided to make a backup copy of the working Config.class.php file in the 1.2.0 version and compare it to the config.class.php file in the SVN.

    There you will note the first issue, the capital “C” in the 1.2.0 file name and the lowercase “c” in the trunk file name. It’s largely irrelevant but could cause some grief when making backups.

    The next issue (which is probably also largely irrelevant) is that in the 1.2.0 file you refer to the HOST as localhost and in the trunk file you refer to it as 127.0.0.1. Now that should not be an issue, unless someone is using some other local host IP such as 127.0.1.1 somehow. I think you had it right the first time as any system should be able to resolve the name “localhost”.

    Now here’s the whammy, and what was probably the actual cause of grief all this time. In the SVN file, the field for ‘DATABASE_PASSWORD’ uses double quotes " " instead of single quotes ’ ’ ! Please resolve this as soon as possible to prevent other new users from questioning their competency as I have the last couple of days.

    Thank you.



  • @Wayne-Workman I did. I think I’m good for now, I just deployed an image and it worked quickly and perfectly on SVN vs when I tried with 1.2.0 earlier. Thank you guys for your help and building this wonderful tool.



  • @Tom-Elliott Ignore the last sentence in my last post my supervisor was testing something. But the apache2 part was an issue I ran into.


  • Moderator

    @Sijmister did you delete the /opt/fog/.fogsettings file? Settings in there would cause the installer to not ask you about anything, except if you wanted to install or not.

    Normally - we don’t tell people to “uninstall”, we tell them to nuke and repave. It’s very, very, very difficult to uninstall fog completely. Just deleting web files isn’t enough. FOG touches a large number of OS configuration files, Service configuration files, export files, the list goes on… To effectively uninstall fog in the shortest time and getting it right every time - you format the server.



  • @Tom-Elliott OK, that worked. I uninstalled everything and reinstalled everything from scratch.
    Although I did run into issues when unistalling with the files in /etc/apache2/sites-available/ and ./sites-enabled/ named 001-fog.conf needing to be deleted before I could restart the apache2 service, which isn’t in the unistall guide in the wiki. After I installed I the manually added the “” to the password which worked even with the double quotes. But it didn’t ask me to input the IP for the DHCP server and can’t find that setting anymore, and I’m not able to direct the computer I’m testing to boot to PXE correctly.



  • @Wayne-Workman https://wiki.fogproject.org/wiki/index.php?tit=Installation
    https://wiki.fogproject.org/wiki/index.php/Upgrade_to_trunk

    I read these two pages before starting the process.

    Looking at it now I suppose I could have surmised that it’s possible to install using SVN without installing the release version, but the fact that it said upgrade to trunk on the dedicated trunk page made me assume otherwise. That’s clearly on me.


  • Senior Developer

    @Sijmister Can you set your /opt/fog/.fogsettings with the password, but simply add a \ before the $ so it will become:

    somepasword\$



  • @Tom-Elliott It’s a dollar sign “$”. It’s the only special character.


  • Moderator

    @Sijmister said in Disparities Between Config file for release and trunk:

    From the instructions on the wiki, I was under the impression that you had to install 1.2.0 before installing the trunk.

    If you can give me a link to the article you were looking at, I’ll see if I can make that page better.


  • Senior Developer

    @Sijmister what special character are you using?



  • Thanks for clearing things up for me, I’ll change the localhost back to 127. From the instructions on the wiki, I was under the impression that you had to install 1.2.0 before installing the trunk. I have a symbol in the password, so maybe that’s why the quotes were affecting it. I’m not a programmer, but I assume it can’t hurt to make it single quotes for future releases. I can copy paste or upload an image of the section of the config file that I’m referring to when I get in to work tomorrow.


  • Moderator

    I imagine there are a lot of changes between 1.2.0’s config file and current fog trunk. 1.2.0 was trunk 2,000 something or another. Current Trunk is somewhere north of 8200. That would be 6,000+ changes to the fog solution. I wouldn’t recommend using files from 1.2.0 at all in fog trunk.


  • Senior Developer

    I don’t know what you mean. The double/single quotes? The define doesn’t matter, the field might matter if you happen to have single quotes in the actual password.

    Capitol C vs lowercase is intentional to allow a much simpler autoloader for the fog system. Local host only refers to 127.0.0.1 local domain only refers to 127.0.1.1, the reason to use 127 vs local host is for persistent connections.


Log in to reply
 

518
Online

39.4k
Users

11.1k
Topics

105.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.