UserTracker not working in 0.11.2



  • UserTracker does not seem to be working. I see the entries in the fog.log file, but nothing appears on the Red Hat server via the reports or my own program.

    ------------------------------------------------------------------------------
    ----------------------------------UserTracker---------------------------------
    ------------------------------------------------------------------------------
     6/24/2016 8:41 AM Client-Info Client Version: 0.11.2
     6/24/2016 8:41 AM Client-Info Client OS:      Windows
     6/24/2016 8:41 AM Client-Info Server Version: 8241
     6/24/2016 8:41 AM Middleware::Response Success
     6/24/2016 8:41 AM Middleware::Communication URL: http://10.3.64.58/fog/service/usertracking.report.php?action=login&user=CI347-04\tmerrick&mac=18:66:DA:09:24:6C||00:00:00:00:00:00:00:E0&newService&json
    ------------------------------------------------------------------------------
    
     6/24/2016 8:41 AM Middleware::Communication URL: http://10.3.64.58/fog/management/index.php?sub=requestClientInfo&configure&newService&json
     6/24/2016 8:41 AM Middleware::Response Success
     6/24/2016 8:41 AM Service Sleeping for 239 seconds
     6/24/2016 8:45 AM Middleware::Communication URL: http://10.3.64.58/fog/management/index.php?sub=requestClientInfo&mac=18:66:DA:09:24:6C||00:00:00:00:00:00:00:E0&newService&json
     6/24/2016 8:45 AM Middleware::Response Success
     6/24/2016 8:45 AM Middleware::Communication URL: http://10.3.64.58/fog/service/getversion.php?clientver&newService&json
     6/24/2016 8:45 AM Middleware::Communication URL: http://10.3.64.58/fog/service/getversion.php?newService&json
    
     6/24/2016 8:45 AM Service Creating user agent cache
     6/24/2016 8:45 AM Middleware::Response Success
     6/24/2016 8:45 AM Middleware::Response Module is disabled globally on the FOG server
     6/24/2016 8:45 AM Middleware::Response Module is disabled globally on the FOG server
    

    I am not sure about the last two entries. I think that everything is enabled for UserTracker as in the first part but there is never a middleware success response to the actual reporting of the logon.



  • Confirm that it works in GIT 8259.


  • Senior Developer

    said in UserTracker not working in 0.11.2:

    service/usertracking.report.php?action=login&user=CI347-04\tmerrick&mac=18:66:DA:09:24:6C||00:00:00:00:00:00:00:E0&newService&json

    Should be fixed in latest.

    Issue was when we started making things a bit more secure. The file was returning an error, but due to how this action is sent to the server, there was no notice of there being a problem.

    If you update, this should be fixed.


  • Senior Developer

    This is a server issue. @Tom-Elliott.



  • Any idea if this is a client or server problem? The client seems to be forming the URL with the information in it. BTW this is not a new problem with 0.11.2.


  • Moderator

    Informing the @Senior-Developers


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.