Unable to connect to Web Interface. Git trunk(8245)



  • * Installation Started
    
     * Installing required packages, if this fails
     | make sure you have an active internet connection.
    
     * Adding needed repository....................................OK
     * Preparing Package Manager...................................OK
     * Packages to be installed:
    
    	apache2 php5 php5-json php5-gd php5-cli php5-curl mysql-server mysql-client tftpd-hpa tftp-hpa nfs-kernel-server vsftpd net-tools wget xinetd sysv-rc-conf tar gzip build-essential cpp gcc g++ m4 htmldoc lftp openssh-server php-gettext php5-mcrypt php5-mysqlnd curl libc6 libcurl3 zlib1g php5-fpm libapache2-mod-php5
    
    
     * Skipping package: apache2...................................(Already Installed)
     * Skipping package: php5......................................(Already Installed)
     * Skipping package: php5-json.................................(Already Installed)
     * Skipping package: php5-gd...................................(Already Installed)
     * Skipping package: php5-cli..................................(Already Installed)
     * Skipping package: php5-curl.................................(Already Installed)
     * Skipping package: mysql-server..............................(Already Installed)
     * Skipping package: mysql-client..............................(Already Installed)
     * Skipping package: tftpd-hpa.................................(Already Installed)
     * Skipping package: tftp-hpa..................................(Already Installed)
     * Skipping package: nfs-kernel-server.........................(Already Installed)
     * Skipping package: vsftpd....................................(Already Installed)
     * Skipping package: net-tools.................................(Already Installed)
     * Skipping package: wget......................................(Already Installed)
     * Skipping package: xinetd....................................(Already Installed)
     * Skipping package: sysv-rc-conf..............................(Already Installed)
     * Skipping package: tar.......................................(Already Installed)
     * Skipping package: gzip......................................(Already Installed)
     * Skipping package: build-essential...........................(Already Installed)
     * Skipping package: cpp.......................................(Already Installed)
     * Skipping package: gcc.......................................(Already Installed)
     * Skipping package: g++.......................................(Already Installed)
     * Skipping package: m4........................................(Already Installed)
     * Skipping package: htmldoc...................................(Already Installed)
     * Skipping package: lftp......................................(Already Installed)
     * Skipping package: openssh-server............................(Already Installed)
     * Skipping package: php-gettext...............................(Already Installed)
     * Skipping package: php5-mcrypt...............................(Already Installed)
     * Skipping package: php5-mysqlnd..............................(Already Installed)
     * Skipping package: curl......................................(Already Installed)
     * Skipping package: libc6.....................................(Already Installed)
     * Skipping package: libcurl3..................................(Already Installed)
     * Skipping package: zlib1g....................................(Already Installed)
     * Skipping package: php5-fpm..................................(Already Installed)
     * Skipping package: libapache2-mod-php5.......................(Already Installed)
     * Updating packages as needed.................................OK
    
     * Confirming package installation
    
     * Checking package: apache2...................................OK
     * Checking package: php5......................................OK
     * Checking package: php5-json.................................OK
     * Checking package: php5-gd...................................OK
     * Checking package: php5-cli..................................OK
     * Checking package: php5-curl.................................OK
     * Checking package: mysql-server..............................OK
     * Checking package: mysql-client..............................OK
     * Checking package: tftpd-hpa.................................OK
     * Checking package: tftp-hpa..................................OK
     * Checking package: nfs-kernel-server.........................OK
     * Checking package: vsftpd....................................OK
     * Checking package: net-tools.................................OK
     * Checking package: wget......................................OK
     * Checking package: xinetd....................................OK
     * Checking package: sysv-rc-conf..............................OK
     * Checking package: tar.......................................OK
     * Checking package: gzip......................................OK
     * Checking package: build-essential...........................OK
     * Checking package: cpp.......................................OK
     * Checking package: gcc.......................................OK
     * Checking package: g++.......................................OK
     * Checking package: m4........................................OK
     * Checking package: htmldoc...................................OK
     * Checking package: lftp......................................OK
     * Checking package: openssh-server............................OK
     * Checking package: php-gettext...............................OK
     * Checking package: php5-mcrypt...............................OK
     * Checking package: php5-mysqlnd..............................OK
     * Checking package: curl......................................OK
     * Checking package: libc6.....................................OK
     * Checking package: libcurl3..................................OK
     * Checking package: zlib1g....................................OK
     * Checking package: php5-fpm..................................OK
     * Checking package: libapache2-mod-php5.......................OK
    
     * Configuring services
    
     * Setting up fog user.........................................Already setup
     * Setting up fog password.....................................OK
     * Stopping FOGMulticastManager Service........................OK
     * Stopping FOGImageReplicator Service.........................OK
     * Stopping FOGSnapinReplicator Service........................OK
     * Stopping FOGScheduler Service...............................OK
     * Stopping FOGPingHosts Service...............................OK
     * Setting up and starting MySQL...............................OK
     * Backing up user reports.....................................Done
     * Stopping web service........................................OK
     * Removing vhost file.........................................OK
     * Setting up Apache and PHP files.............................OK
     * Testing and removing symbolic links if found................OK
     * Backing up old data.........................................OK
     * Copying back old web folder as is...........................OK
     * Ensuring all classes are lowercased.........................OK
     * Copying new files to web folder.............................OK
     * Creating config file........................................OK
     * Getting checksum files for kernels and inits................OK
     * Downloading inits, kernels, and the fog client..............OK
     * Comparing checksums of kernels and inits....................Done
     * Enabling apache and fpm services on boot....................OK
     * Creating SSL Certificate....................................OK
     * Creating auth pub key and cert..............................OK
     * Resetting SSL Permissions...................................OK
     * Setting up SSL FOG Server...................................OK
     * Restarting Apache2 for fog vhost............................OK
     * Changing permissions on apache log files....................OK
    
     ########################################################################################
       FOG has adjusted to using a login system to protect what can/cannot be downloaded
       We have detected that you don't have credentials defined to perform the backup
       If you would like the database to be backed up during install please define
       in your /opt/fog/.fogsettings file
    
       fogguiuser='usernameOfFOGGUI'
       fogguipass='passwordOfFOGGUIUser'
    
       You can also re-run this installer as:
    
       fogguiuser='usernameOfFOGGUI' fogguipass='passwordOfFOGGUIUser' ././installfog.sh 
     ########################################################################################
    
    
     * You still need to install/update your database schema.
     * This can be done by opening a web browser and going to:
    
       http://172.16.0.27/fog/management
    
     * Press [Enter] key when database is updated/installed.
    

    Hello all

    Long time lurker(3months), first time poster. Hope you guys can point me in the right direction.

    We have two fogservers. One of the FogServer is running on a Mac (Ubuntu 12.04 with fog version 1.2.0), and the other is a test server running on VMWare(Ubuntu 14).

    I’m having troubling updating the test server to the latest trunk, and as you can see above everything ran and installed without any errors. However, for the life of me I CANNOT get the web interface to open!
    Where it says Press [Enter] to update database, I cannot get past it because the web management would not open.

    Steps I took:
    Update via Git
    Firewall is disabled
    Completely removed Apache and reinstall
    Completely removed Fog and reinstall

    I’m lost and stuck at this point, hope you guys can shed some light.

    Best,

    EDIT: When I try to start apache2, this is what I get. Could this be the reason why I cannot access the web interface?

    root@FogServer:~/git/fogproject/bin# sudo service apache2 stop
     * Stopping web server apache2                                                  * 
    root@FogServer:~/git/fogproject/bin# sudo service apache2 start
     * Starting web server apache2                                                  * 
     * The apache2 configtest failed.
    Output of config test was:
    apache2: Syntax error on line 140 of /etc/apache2/apache2.conf: Could not open configuration file /etc/apache2/mods-enabled/authz_default.load: No such file or directory
    Action 'configtest' failed.
    The Apache error log may have more information.
    

  • Moderator

    @foggee There are mixed thoughts about the best version of Ubuntu. IMO, I’d go with 16. There are special steps that need included (search the forums for “Ubuntu 16”), but after that it’s good to go. Ubuntu 14 will work without modification.

    You do not need to install 1.2.0. You can go straight to trunk.



  • @Wayne-Workman

    Some quick questions regarding that.

    If I rebuild the VM session, which is the best version of Ubuntu to be on? And when I start installing FOG, do I go straight to trunk or should I install 1.2.0 first then trunk it.


  • Moderator

    @foggee If it were me, and I couldn’t figure it out, I’d have just rebuilt the server.



  • @Wayne-Workman

    Unfortunately being at work will not allow me to do so, even when this is work related. I sent you an email for the FOG session tomorrow, hoping that it will get me out of this hole…


  • Moderator

    @foggee If you have time at 4:00 Central Standard, I can try to help via Team Viewer with you.



  • @Wayne-Workman

    Hmm…yeah
    I’m getting the “unable to connect” page, same as below.

    Can I ask for your expertise to help me troubleshoot Apache2? I feel like this is where should start but I have no idea how to, as I already uninstalled, deleted .conf file.


  • Moderator

    @foggee type the IP of the server into a browser, you should get an Apache test page if it’s working.



  • @Wayne-Workman

    Gotcha.

    I just ran ./installfog.sh -y

    Updating Database...................................Failed!
    
    

    How can I verify that Apache2 is running correctly and that it’s doing what its suppose to do?


  • Moderator

    @foggee Right, but it needs updated one way or another.



  • @Wayne-Workman

    But the database isn’t the reason why I cannot see the web interface, right?


  • Moderator

    @foggee You can try to tell the installer to update the DB, instead of using the web interface. idk if it will work or not.
    just add the -y argument.
    ./installfog.sh -y



  • @Wayne-Workman

    I did delete the .conf file.

    As of right now, the fog installer is asking me to update database schema by entering fog management. And I cannot access the web interface to do so.

    Any other ideas? I’d be more the willing to try anything you throw at me…

    I wish I know which are the main components that allow me to access the web interface to the fogserver so I can dig in there and dissect each component.


  • Moderator

    @foggee But did you delete that file?



  • @Wayne-Workman

    Have tried removing Apache2, uninstalled FOG as a whole, then retrying the installations but I’m still back to the “Unable to Connect” page.

    Does this mean anything to you? Could this be the reason why I cannot access web interface?

    root@FogServer:~/git/fogproject/bin# sudo service apache2 stop
     * Stopping web server apache2                                                  * 
    root@FogServer:~/git/fogproject/bin# sudo service apache2 start
     * Starting web server apache2                                                  * 
     * The apache2 configtest failed.
    Output of config test was:
    apache2: Syntax error on line 140 of /etc/apache2/apache2.conf: Could not open configuration file /etc/apache2/mods-enabled/authz_default.load: No such file or directory
    Action 'configtest' failed.
    The Apache error log may have more information.
    

  • Moderator

    @foggee What if you uninstall apache, then delete that file, then reinstall?

    apt-get remove apache2 -y;rm -f /etc/apache2/apache2.conf;apt-get install apache2 -y

    I feel you are wanting to fix it rather than rebuild it, but keep in mind that you could probably have already rebuilt the server with the time you’ve spent on this.



  • @Tom-Elliott

    Filesystem     1K-blocks    Used Available Use% Mounted on
    udev             2055700       4   2055696   1% /dev
    tmpfs             413064    1072    411992   1% /run
    /dev/sda1      119594212 6673176 106822964   6% /
    none                   4       0         4   0% /sys/fs/cgroup
    none                5120       0      5120   0% /run/lock
    none             2065316      76   2065240   1% /run/shm
    none              102400      72    102328   1% /run/user
    

    0_1466725925947_upload-66ce7109-dd49-49cc-a760-4ffbe1238766
    I know that Apache is the main component for accessing web interface, correct me if I’m wrong. I also have a feeling that log I posted is wrong because of the timestamp dated back to June 6th. I’m trying to find a log for today but could not find it anywhere…


  • Senior Developer

    This appears to be indicating it can’t write session data. Maybe your root filesystem is full?

    What’s the output of df -b /?



  • @Tom-Elliott

    Hi Tom

    First of all, thank you for your time.

    When I access the web interface from server (firefox) to update database schema, I get… 0_1466724378406_upload-0c087c46-1ced-4774-bd74-f3168adf26f8
    When I try to access the web interface from client machines(chrome), i get…
    0_1466724448210_upload-38274610-3c7c-4a48-8014-0d035cb13214

    Lastly, I have tried looking at the Apache log but it doesn’t seem right to me because of the timestamp. If this log is not the one, please tell me where to find the correct one.

    [Mon Jun 06 17:32:42 2016] [error] [client 172.16.1.122] PHP Fatal error:  Call to a member function query() on a non-object in /var/www/fog/lib/db/MySQL.class.php on line 89
    [Mon Jun 06 17:32:42 2016] [error] [client 172.16.1.122] PHP Warning:  Unknown: open(/var/lib/php5/sess_9hf0lmul0f53sfblcoeqpf5486, O_RDWR) failed: Permission denied (13) in Unknown on line 0
    [Mon Jun 06 17:32:42 2016] [error] [client 172.16.1.122] PHP Warning:  Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/var/lib/php5) in Unknown on line 0
    [Mon Jun 06 17:32:42 2016] [error] [client 172.16.1.122] PHP Fatal error:  Call to a member function query() on a non-object in /var/www/fog/lib/db/MySQL.class.php on line 89
    [Mon Jun 06 17:32:42 2016] [error] [client 172.16.1.122] PHP Warning:  Unknown: open(/var/lib/php5/sess_nt2jq0pgilceskr3mjgr57m266, O_RDWR) failed: Permission denied (13) in Unknown on line 0
    [Mon Jun 06 17:32:42 2016] [error] [client 172.16.1.122] PHP Warning:  Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/var/lib/php5) in Unknown on line 0
    [Mon Jun 06 17:32:42 2016] [error] [client 172.16.1.122] PHP Fatal error:  Call to a member function query() on a non-object in /var/www/fog/lib/db/MySQL.class.php on line 89
    [Mon Jun 06 17:32:42 2016] [error] [client 172.16.1.122] PHP Warning:  Unknown: open(/var/lib/php5/sess_ohmbj4sed09ejtnquk10pdle34, O_RDWR) failed: Permission denied (13) in Unknown on line 0
    [Mon Jun 06 17:32:42 2016] [error] [client 172.16.1.122] PHP Warning:  Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/var/lib/php5) in Unknown on line 0
    [Mon Jun 06 17:32:42 2016] [error] [client 172.16.1.122] PHP Fatal error:  Call to a member function query() on a non-object in /var/www/fog/lib/db/MySQL.class.php on line 89
    [Mon Jun 06 17:32:42 2016] [error] [client 172.16.1.122] PHP Warning:  Unknown: open(/var/lib/php5/sess_s7ip113c7c6j166kkm4glkndt0, O_RDWR) failed: Permission denied (13) in Unknown on line 0
    [Mon Jun 06 17:32:42 2016] [error] [client 172.16.1.122] PHP Warning:  Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/var/lib/php5) in Unknown on line 0
    [Mon Jun 06 17:32:44 2016] [notice] caught SIGTERM, shutting down```

  • Senior Developer

    You gave us a bit of information, but not really anything we can help you with.

    What happens when you try to go to the browser? What does it say? Is it a blank page, or is there a message? Can you provide your apache error logs?


Log in to reply
 

452
Online

38746
Users

10572
Topics

100071
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.