Bitrate Questions



  • I searched high and dry on the man pages on here and boy did I have a hard time locating anything specific to the bitrate settings in the GUI under Storage Nodes.

    SO here is the deal… I have a mixed network with most things operating on GIG switches but I do still have a few connections that are 10/100 MBps. What is the suggested setting to limit slow connection issues? As I understand, multicasting will slow everything down to your slowest link.

    I can unicast a room and achieve speeds of 3-10 GB/Min in particlone . I’m cloning a lab (same brand/model as the unicast) right now Multicast that’s on a gig switch all the way to the server that’s going at 53 MB/min (in particlone). All of these machines are gig capable.

    Any advice here is helpful. I’m getting closer to really running with this stuff!

    If their is a link to something in the man pages related to this, let me know. Thanks!!

    Cheers,

    Joe Gill



  • @Wayne-Workman

    I did find out that the slow speed was likely from an old switch in that room. The other admin said we still have a 10/100 switch on that lab… So theirs part of the issue!



  • @Wayne-Workman

    Well I was able to get my imaaging task done finally. I had 3 hang at the partclone screen and the rest took off. I ended up with 16 on this run.

    Image Size - 48.52 GB
    Total Time - 1 HR 11 Min Multicast

    I started the download task on the remaining three when I started typing this via unicast on these 3.

    Image Size is identical.
    Total time - 7 Min

    Two of the machines finished at the same time, just at that 7 minute mark. The last one is going about half that speed. This is still much easier and quicker than the alternative!



  • @Wayne-Workman said in Bitrate Questions:

    @Joe-Gill holy cow, 10 hours for 23 machines?

    How big is your image? 37 GB

    how fast are the switches for these computers? District wide – Mixed – Mostly 10/100/1000 but their are some 10/100 switches still out there. This particular lab had 10/100/1000 all the way to the server.

    Link speed? 1000 on both ends.

    Are these hosts all the same hardware? Yes

    Same image for them all? Yes – Today’s group will be slightly larger image.


  • Moderator

    @Joe-Gill holy cow, 10 hours for 23 machines?

    How big is your image? how fast are the switches for these computers? Link speed? Are these hosts all the same hardware? Same image for them all?



  • @Tom-Elliott

    Thanks Tom!!

    I’ll try that and see what happens. It took 10 hours last night to MultiCast images to 23 machines. Everything went good otherwise. All my tasks finished nicely! I’ll try the new setting and give it a try with 23 more today. They are on the same switch as the others so it’ll be a good test. And they are the same machine type.

    Cheers!

    Joe


  • Senior Developer

    I’d recommend setting to 80m.

    Link to udp-sender manpage: http://linux.die.net/man/1/udp-sender

    –max-bitrate bitrate
    Limits bandwidth used by udpcast. Useful in asynchronous mode, or else the sender may send too fast for the switch and/or receiver to keep up. Bitrate may be expressed in bits per second (–bitrate 5000000), kilobits per second ("–bitrate 5000k") or megabits per second ("–bitrate 5m"). This is the raw bitrate, including packet headers, forward error correction, retransmissions, etc. Actual payload bitrate will be lower.


  • Moderator

    Good question, I have no earthly idea what the bitrate setting even does…

    Should probably as the @Developers

    Also, I think this is a fine time to ask for the addition of a “blue question mark” next to that setting explaining it!


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.