PXE boot hanging on HP Compaq Pro 4300 SFF PC

  • My organization has 6 HP Compaq Pro 4300 SFF PC’s. For the past several years we’ve had no problem pushing images with FOG v0.32 via PXE boot to these machines. Early this year, we updated FOG to v1.2.0 and now these machines hang on PXE boot - the process starts and then hangs on the message ‘iPXE Initializing Devices’. There is no other text accompanying this message. We’ve tried several kernels, but we’ve yet to get these machines to download/upload FOG images via PXE. I’ve seen similar issues posted in the FOG forum, but we’re unable to find a solution.

    Any advice would be greatly appreciated.

  • Moderator

    @swhite I would pull your email address out of this post just to keep the amount of spam down from web crawlers. Stick to DM messages.

  • @Sebastian-Roth I took over for dbridges on this issue. Last I heard Tom wanted me to call him but I wasn’t sure how so I sent him a chat with my info. I am available Monday - Friday 9:00 am to 6:00 pm if someone would like to chat.

  • Developer

    @dbridges Any news on this?

  • Senior Developer

    @swhite No problem.

  • Sure thing. I am about to leave the office but I will be back Tuesday at 9:00 am EST. Just let me know what time is good for you.

  • Senior Developer

    Any way I could get you to call me?

  • Moderator

    @swhite Well nuts, we’ll have to get the devs involved then. They have a few debugging versions of the iPXE kernel that may give more insight in whats hanging.

    @Developers we may need your assistance on this one.

  • I renamed my file to ipxe.pxe.old and added the new one from the link provided. When I attempted to boot the computer it hung in the same spot. Just with a little more info on the screen.

  • Moderator

    @george1421 For clarity this HP system has a Broadcom BCM 57788 network adapter and since these are in bios (legacy) mode and not uefi. I would start with the following iPXE boot kernels in this order, which is the most common first and for troubled computers then the ipxe.pxe.


  • Moderator

    @swhite OK, these devices are in bios (legacy) mode and you are sending the full ipxe driver file.

    It would be interesting to know what happens if you rename the ipxe.pxe file to something (as a test) and download the current ipxe.pxe file from this link from the trunk build: https://github.com/FOGProject/fogproject/tree/dev-branch/packages/tftp only download the ipxe.pxe file and be sure to save your original file. This iPXE kernel is the latest and greatest, where the iPXE kernel from FOG 1.2.0 stable is over 2 years old. Understand this is just a test, but if it works, there is no reason to move back.

    [edit] Just to be clear this is the iPXE boot kernel and not the actual FOG (FOS engine) kernel you can download from the sorceforge site.

  • I currently have it set to ipxe.pxe but I have tried all of the files listed below in my earlier post. I am not sure what you mean about what mode they are in unless you are asking if I am using the legacy boot options instead of UEFI. If so yes I am legacy booting. Also it is not getting past the iPXE Initializing Devices so I did not think I was at the point where the boot kernel would matter.

  • Moderator

    @swhite Right, but the question is, what is it currently set to, and what mode are these HP systems in? Since you are getting to the initializing devices I would assume you have selected the correct boot kernel.

  • Yes I have option 67 set. All of my other machines work just fine with fog. Only the HP Compaq Pro 4300 are having issues.

  • Moderator

    Can you confirm what you have configured for dhcp option 67 {boot-file}?

    Your booting process isn’t to the kernel yet, so that part is not relevant, the booting process is still in the iPXE kernel.

    Also can you tell me if these are uefi or bios configured systems?

  • Basically I tried everything under the tftpboot directory.


  • Senior Developer

    @swhite can you tell me what file or files you’ve tried?

  • Hi Tom,

    I work with the original poster and took over on this issue since he did not have the necessary rights to change the settings necessary. I took your advice and tried changing from the undionly.kpxe file, however, none of them would work. In fact the only way we could get the system to boot any further was to use the old pxelinux.0 but I get an unable to load configuration file error. Any advice on this issue?

  • Senior Developer

    Try using a different series of the pxe labeled files.

    My guess, you’re using undionly.kpxe, maybe try undionly.kkpxe. If that doesn’t work, try ipxe.pxe.

  • Thanks for your very quick response -

    The machines are legacy booting and secure boot is disabled.

Log in to reply