Imaged Laptops and Desktops not connecting to the domain.



  • Hi all,

    We are currently using Fog Trunk Version 8169. We have a lot of old Images on this fog which we’ve been using in their old form since we changed servers when we updated to 1.2.0 and therefore changed IP.

    When we’d changed IP all the old images would run just fine but then if we wanted it to connect to the domain we’d have to go into the laptop, change the IP in the Config file in Fog and then restart the Service. That would then connect the machine to the domain with no issues.

    We’re still using these old images on Fog Trunk however they’re no longer working as intended. The image installs (Software, Windows 7 etc) but it won’t connect onto the domain, even if it has the correct IP for the Fog server.

    We’ve added a new password through FogCrypt and that hasn’t solved anything and we’ve tried the same work around we where using with 1.2.0 and that also isn’t working.

    any ideas?


  • Moderator

    @dolf Perhaps this deserves a video.



  • @Zirushton I’m having the same problem. Which boxes did you tick?



  • We’ve managed to get this sorted.

    We needed to tick a few boxes and install the new client on any machines that we image. Everything working as intended now.


  • Moderator

    @Zirushton on my phone right now but, spotted a clue in the log.

    Unknown Error’ Code: 2692

    Google search:

    Domain join Unknown Error’ Code: 2692

    And you’ll probably find out the issue pretty fast.



  • Hi Wayne.

    Here is a log from one of the machines. This Machine is using an image that was made on the new sever and already has a client that directs it to the correct IP. So before our upgrade to Fog Trunk this worked fine with no issues, start the image running and when we came back it would be connected to the network with everything set up. Now, not so much.

    22/06/2016 09:27 FOG::UserCleanup Sleeping for 16 seconds.
    22/06/2016 09:27 FOG::UserTracker Starting user tracking process…
    22/06/2016 09:27 FOG::SnapinClient Starting snapin client process…
    22/06/2016 09:27 FOG::DisplayManager Attempting to connect to fog server…
    22/06/2016 09:27 FOG::SnapinClient Sleeping for 434 seconds.
    22/06/2016 09:27 FOG::PrinterManager Attempting to connect to fog server…
    22/06/2016 09:27 FOG::HostRegister Exiting because only 1 mac address was found.
    22/06/2016 09:27 FOG::UserTracker Attempting to connect to fog server…
    22/06/2016 09:27 FOG::TaskReboot Attempting to connect to fog server…
    22/06/2016 09:27 FOG::HostnameChanger Attempting to connect to fog server…
    22/06/2016 09:27 FOG::DisplayManager Failed to connect to fog server!
    22/06/2016 09:27 FOG::AutoLogOut Failed to connect to fog server!
    22/06/2016 09:27 FOG::DisplayManager The remote name could not be resolved: 'tr-fog-01’
    22/06/2016 09:27 FOG::AutoLogOut The remote name could not be resolved: 'tr-fog-01’
    22/06/2016 09:27 FOG::TaskReboot Module is active…
    22/06/2016 09:27 FOG::PrinterManager Module is disabled globally on the FOG Server, exiting.
    22/06/2016 09:27 FOG::UserTracker Module is active…
    22/06/2016 09:27 FOG::HostnameChanger Module is active…
    22/06/2016 09:27 FOG::TaskReboot No job exists for 20:47:47:27:FF:37
    22/06/2016 09:27 FOG::TaskReboot No task found for client.
    22/06/2016 09:27 FOG::AutoLogOut at System.Net.WebClient.DownloadDataInternal(Uri address, WebRequest& request)
    at System.Net.WebClient.DownloadString(Uri address)
    at FOG.AutoLogOut.doWork()
    22/06/2016 09:27 FOG::DisplayManager Sleeping for 1 minute.
    22/06/2016 09:27 FOG::HostnameChanger AD mode requested, confirming settings.
    22/06/2016 09:27 FOG::HostnameChanger Hostnames are different - USERTRI-D3LQNH6 - LAP-3340-303
    22/06/2016 09:27 FOG::HostnameChanger Attempting to unregister from domain…
    22/06/2016 09:27 FOG::HostnameChanger Domain Error! (‘Unknown Error’ Code: 2692)
    22/06/2016 09:27 FOG::HostnameChanger Using default fog method.
    22/06/2016 09:27 FOG::HostnameChanger Computer is about to restart.
    22/06/2016 09:27 FOG::GUIWatcher Message found, attempting to notify GUI!
    22/06/2016 09:27 FOG::GUIWatcher Dispatch Failed!
    22/06/2016 09:27 FOG::GUIWatcher Message found, attempting to notify GUI!
    22/06/2016 09:27 FOG::GUIWatcher Dispatch Failed!
    22/06/2016 09:27 FOG::GUIWatcher Message found, attempting to notify GUI!
    22/06/2016 09:27 FOG::GUIWatcher Dispatch Failed!
    22/06/2016 09:27 FOG::GUIWatcher Message found, attempting to notify GUI!
    22/06/2016 09:27 FOG::GUIWatcher Dispatch Failed!
    22/06/2016 09:27 FOG::UserCleanup Starting user cleanup process…
    22/06/2016 09:27 FOG::UserCleanup Attempting to connect to fog server…
    22/06/2016 09:27 FOG::GUIWatcher Message found, attempting to notify GUI!
    22/06/2016 09:27 FOG::GUIWatcher Dispatch Failed!
    22/06/2016 09:27 FOG::UserCleanup Module is disabled globally on the FOG Server, exiting.
    22/06/2016 09:27 FOG::GUIWatcher Message found, attempting to notify GUI!
    22/06/2016 09:27 FOG::GUIWatcher Dispatch Failed!
    22/06/2016 09:27 FOG::GUIWatcher Message found, attempting to notify GUI!
    22/06/2016 09:27 FOG::GUIWatcher Dispatch Failed!
    22/06/2016 09:27 FOG::GUIWatcher Message found, attempting to notify GUI!
    22/06/2016 09:27 FOG::GUIWatcher Dispatch Failed!
    22/06/2016 09:27 FOG::GUIWatcher Message found, attempting to notify GUI!
    22/06/2016 09:27 FOG::GUIWatcher Dispatch Failed!
    22/06/2016 09:28 FOG::GUIWatcher Message found, attempting to notify GUI!
    22/06/2016 09:28 FOG::GUIWatcher Dispatch Failed!
    22/06/2016 09:28 FOG Service Engine Version: 3
    22/06/2016 09:28 Starting all sub processes
    22/06/2016 09:28 14 modules loaded
    22/06/2016 09:28 * Starting FOG.AutoLogOut
    22/06/2016 09:28 * Starting FOG.SnapinClient
    22/06/2016 09:28 * Starting FOG.DirCleaner
    22/06/2016 09:28 * Starting FOG.DisplayManager
    22/06/2016 09:28 * Starting FOG.GreenFog
    22/06/2016 09:28 FOG::AutoLogOut Starting process…
    22/06/2016 09:28 FOG::DisplayManager Starting display manager process…
    22/06/2016 09:28 FOG::DirCleaner Sleeping for 39 seconds.
    22/06/2016 09:28 FOG::ClientUpdater Starting client update process…
    22/06/2016 09:28 FOG::ClientUpdater Sleeping for 198 seconds.
    22/06/2016 09:28 * Starting FOG.GUIWatcher
    22/06/2016 09:28 * Starting FOG.HostNameChanger
    22/06/2016 09:28 FOG::GUIWatcher Starting GUI Watcher…
    22/06/2016 09:28 * Starting FOG.HostRegister
    22/06/2016 09:28 * Starting FOG.MODDebug
    22/06/2016 09:28 * Starting FOG.PrinterManager
    22/06/2016 09:28 FOG::GreenFog Sleeping for 30 seconds.
    22/06/2016 09:28 FOG::HostRegister Starting host registration process…
    22/06/2016 09:28 FOG::PrinterManager Starting interprocess communication process…
    22/06/2016 09:28 * Starting FOG.SnapinClient
    22/06/2016 09:28 FOG::MODDebug Start Called
    22/06/2016 09:28 FOG::PrinterManager interprocess comm startup: OK
    22/06/2016 09:28 FOG::MODDebug Sleeping for 100 Seconds
    22/06/2016 09:28 * Starting FOG.TaskReboot
    22/06/2016 09:28 FOG::HostnameChanger Starting hostname change process…
    22/06/2016 09:28 FOG::HostnameChanger Yielding to other subservices for 1 seconds.
    22/06/2016 09:28 * Starting FOG.UserCleanup
    22/06/2016 09:28 * Starting FOG.UserTracker
    22/06/2016 09:28 FOG::TaskReboot Taskreboot in lazy mode.
    22/06/2016 09:28 FOG::TaskReboot Starting Task Reboot…
    22/06/2016 09:28 FOG::UserCleanup Sleeping for 12 seconds.
    22/06/2016 09:28 FOG::UserTracker Starting user tracking process…
    22/06/2016 09:28 FOG::SnapinClient Starting snapin client process…
    22/06/2016 09:28 FOG::SnapinClient Sleeping for 367 seconds.
    22/06/2016 09:28 FOG::PrinterManager Attempting to connect to fog server…
    22/06/2016 09:28 FOG::HostRegister Exiting because only 1 mac address was found.
    22/06/2016 09:28 FOG::DisplayManager Attempting to connect to fog server…
    22/06/2016 09:28 FOG::TaskReboot Attempting to connect to fog server…
    22/06/2016 09:28 FOG::HostnameChanger Attempting to connect to fog server…
    22/06/2016 09:28 FOG::UserTracker Attempting to connect to fog server…
    22/06/2016 09:28 FOG::AutoLogOut Module is disabled globally on the FOG Server.
    22/06/2016 09:28 FOG::PrinterManager Module is disabled globally on the FOG Server, exiting.
    22/06/2016 09:28 FOG::UserTracker Module is active…
    22/06/2016 09:28 FOG::HostnameChanger Module is active…
    22/06/2016 09:28 FOG::TaskReboot Module is active…
    22/06/2016 09:28 FOG::TaskReboot Attempting to connect to fog server…
    22/06/2016 09:28 FOG::DisplayManager Module is active…
    22/06/2016 09:28 FOG::HostnameChanger AD mode requested, confirming settings.
    22/06/2016 09:28 FOG::HostnameChanger Hostname is up to date
    22/06/2016 09:28 FOG::HostnameChanger Attempting to join domain if not already a member…
    22/06/2016 09:28 FOG::HostnameChanger Domain Error! (‘Unknown Error’ Code: 1326)
    22/06/2016 09:28 FOG::TaskReboot No job exists for 20:47:47:27:FF:37
    22/06/2016 09:28 FOG::TaskReboot No task found for client.
    22/06/2016 09:28 FOG::DisplayManager Starting display manager monitoring loop…
    22/06/2016 09:28 FOG::DisplayManager Changing Display Setting to 1366 x 768 x 60 .
    22/06/2016 09:28 FOG::DisplayManager Failed to change display settings.
    22/06/2016 09:28 FOG::UserCleanup Starting user cleanup process…
    22/06/2016 09:28 FOG::UserCleanup Attempting to connect to fog server…
    22/06/2016 09:28 FOG::UserCleanup Module is disabled globally on the FOG Server, exiting.
    22/06/2016 09:29 FOG::GreenFog Starting green fog…
    22/06/2016 09:29 FOG::GreenFog Attempting to connect to fog server…
    22/06/2016 09:29 FOG::GreenFog Module is active…
    22/06/2016 09:29 FOG::GreenFog 1 actions found, validating…
    22/06/2016 09:29 FOG::GreenFog No tasks found after validation!
    22/06/2016 09:29 FOG::DirCleaner Starting directory cleaning process…
    22/06/2016 09:29 FOG::DirCleaner Attempting to connect to fog server…
    22/06/2016 09:29 FOG::DirCleaner Module is disabled globally on the FOG Server.
    22/06/2016 09:29 FOG::UserTracker Event: LOGIN for LAP-3340-303\Administrator
    22/06/2016 09:29 FOG::UserTracker Unhandled Response from server:
    22/06/2016 09:30 FOG::MODDebug Reading config settings…
    22/06/2016 09:30 FOG::MODDebug Reading of config settings passed.
    22/06/2016 09:30 FOG::MODDebug Starting Core processing…
    22/06/2016 09:30 FOG::MODDebug Operating System ID: 6
    22/06/2016 09:30 FOG::MODDebug Operating System Minor: 1
    22/06/2016 09:30 FOG::MODDebug MAC ID 0 20:47:47:27:FF:37
    22/06/2016 09:30 FOG::MODDebug MAC POST String: 20:47:47:27:FF:37
    22/06/2016 09:30 FOG::MODDebug A user is currently logged in
    22/06/2016 09:30 FOG::MODDebug Username: LAP-3340-303\Administrator
    22/06/2016 09:30 FOG::MODDebug Hostname: LAP-3340-303
    22/06/2016 09:30 FOG::MODDebug Attempting to open connect to: http://TR-FOG-01/fog/service/debug.php
    22/06/2016 09:30 FOG::MODDebug Server responded with: Hello FOG Client
    22/06/2016 09:30 FOG::MODDebug Module has finished work and will now exit.
    22/06/2016 09:30 FOG::DisplayManager Login detected, taking action…
    22/06/2016 09:30 FOG::DisplayManager Changing Display Setting to 1366 x 768 x 60.
    22/06/2016 09:30 FOG::DisplayManager Failed to change display settings.


  • Moderator

    @Zirushton give us the log file from one of the problem hosts. It’s here: c:\fog.log



  • With Fog Trunk doing this to to config file no longer solves the issue. We used to (on 1.2.0 on our new server) be able to just change the IP and there would be no issues.

    Now if we change the IP and restart the service it does continue the service (the machine restarts) but it doesn’t connect to the domain.

    We have a couple of images that where made after the new server and even these with the correct IP in the config file do not connect properly to the domain.


  • Moderator

    Does just changing the IP address in the config file resolve all of your issues with these older images?

    If that is the case you can create a fog post install script to “patch” the config file. The basic concept is that after partclone places the image on the target computer, the fog task sequence calls an external postinstall shell script, that you could hook into to call your update fog settings script.

    The actual code would be akin to how I update the setupcomplete.cmd file as I’m developing our golden image. Understand this code snippet doesn't contain any error checking. This is the basics of what needs to be done.

    #!/bin/bash
    
    . /usr/share/fog/lib/funcs.sh
    # windows 7
    osdiskpart="/dev/sda2";
    
    mkdir /ntfs 2>/dev/null
    
    mount.ntfs-3g "${osdiskpart}" /ntfs 2>/dev/null
    
    if [ -f "/images/Patch/SetupComplete.cmd" ]; then
        cp /images/Patch/SetupComplete.cmd /ntfs/Windows/Setup/Scripts/SetupComplete.cmd;
    fi
    
    umount /ntfs
    

    The basic concept of this script would be to mount the target computer’s C: drive then to copy the new fog client configuration file to the target computer, and finally unmount the C: drive. Without error checking lines, it about 6 lines of code.

    I’m writing a tutorial on fog post install scripts.
    https://forums.fogproject.org/topic/7740/the-magical-mystical-fog-post-download-script-under-construction


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.