Could not start download: Operation not supported (http://ipxe.org/3c092003)



  • Hello,
    during first fog setting on Debian GNU/Linux 8, i get this error booting my target system

    Could not start download: Operation not supported (http://ipxe.org/3c092003)

    target is qemu/kvm guest.
    dhcp server is debian isc-dhcp-server
    bridged network’s provided by openvswitch

    Is there someone who can help me ?



  • @jide Sounds like you’re using dnsmasq? In such case, you can turn off DHCP on the fog server (if you want), and turn it back on for the ISP box (if you want) and just roll with dnsmasq.

    Glad you got it working.



  • Fog in general. I stopped my ISP dhcp box, created missing ipxe file and it finally works. One more time, thanks for your help !!


  • Moderator

    @jide said in Could not start download: Operation not supported (http://ipxe.org/3c092003):

    Yesss, it works !!! Thanks a lot for your help !!!

    Just for clarity, is “it” dnsmasq or FOG in general?



  • Yesss, it works !!! Thanks a lot for your help !!!



  • @george1421 dnsmasq with UEFI in ProxyDHCP mode now aparently works. I’m on the dnsmasq mailing list and have been keeping an eye on that topic.

    https://forums.fogproject.org/topic/7424/dnsmasq-to-support-proxydhcp-for-uefi


  • Moderator

    @jide Or turn off DHCP on your FOG server since you already have a dhcp server running (some people simply can’t disable the ISP kit). Then install dnsmasq on your FOG server. Then you can send out the proper boot file for bios target computers. I’m not sure where the devs are (for dnsmasq) with the efi functions.



  • @jide Configure the ISP box’s DHCP properly (impossible on most), or turn DHCP off of the ISP box.



  • Hello, you’re right, there’s 2 dhcp server on my network : my internet provider’s box and my linux dhcp server. When i’m asked for tftp ip adress , i set it to my linux tftp server and i got “tftp://x.x.x.x/default.ipxe” not such a file or directory (http://ipxe/2d12603b)


  • Developer

    @jide Do you have dnsmasq installed as well? Or another DHCP server on your network?



  • @Sebastian-Roth : Thanks !!! Using downloaded version solves my problem. But the 2nd ipxe now ask me “Please enter tftp server:” …


  • Developer

    @jide If I get this right your client is a qemu-kvm host. So you should see iPXE twice as qemu has iPXE as PXE ROM included. Is this screenshot with the error the first iPXE you see or the second one? I guess it’s the second one as the version number perfectly matches the one we delivered with FOG 1.2.0…

    Can you please try to use one of the current iPXE binaries just to see if that makes a difference:

    sudo -i
    cd /tftpboot
    mv undionly.kpxe undionly.kpxe.orig
    wget -O undionly.kpxe "https://github.com/FOGProject/fogproject/blob/dev-branch/packages/tftp/undionly.kpxe?raw=true"
    


  • ![alt text](1_1466366694599_fog.jpg 0_1466366694597_fog2.jpg image url)

    ovs setting and ipxe boot picture

    (sorry for my poor english …)



  • Fog version is : fog_1.2.0

    i doesn’t use dnsmask

    dhcp server conf is like :

    ddns-update-style none;
    option domain-name “srvfog.local.org”;
    option domain-name-servers srvfog.local.org;

    default-lease-time 600;
    max-lease-time 7200;
    log-facility local7;

    subnet 192.168.0.0 netmask 255.255.255.0 {
    range 192.168.0.70 192.168.0.75;
    next-server 192.168.0.100;
    filename “undionly.kpxe”;
    option subnet-mask 255.255.255.0;
    option broadcast-address 192.168.0.255;
    }

    my bridge startup script looks like that :

    #!/bin/bash
    VMPATH="/home/blabla/VM/VMFILES/FOG/FOG.img"
    MAC=“DE:AD:BE:EF:AC:87"
    SCRIPTUP=”/etc/ovs-ifup"
    SCRIPTDOWN="/etc/ovs-ifdown"
    ISO="/home/blabla/VM/ISO/debian-8.5.0-amd64-netinst.iso"
    VMPATH_snapshot="/home/blabla/VM/VMFILES/FOG/FOG_snapshot.img"
    CPU=“host”

    sudo qemu-kvm -m 1024 -net nic,macaddr=$MAC -cpu $CPU -vga vmware -net tap,script=$SCRIPTUP,downscript=$SCRIPTDOWN -drive file=$VMPATH

    undionly.kpxe can be downloaded from guest, from host and others.



  • And the FOG version, too.


  • Moderator

    I guess we need to start with an actual screen shot of the error. Pictures tell more than just words.

    Since you are using the debian dhcp server, please post the configuration here.

    Make sure you are not using dnsmasq, its not needed here.

    Please explain how the bridged network with openvswitch enters into the picture here.

    And lastly, we’ll probably need a packet capture of this dhcp process using something like tcpdump -w output.pcap port 67 or port 68 or port 69 to tell us exactly what is transferring between your dhcp server and target computer. In your case you need to run this command on your FOG server to be sure you capture off the traffic. Just start the tcpdump command and boot the target computer until you get the iPXE error and then press ctrl-C to stop tcpdump.


 

425
Online

41.8k
Users

12.3k
Topics

116.0k
Posts