FOG Multicast Problems / Partclone fails to finish



  • This was after I listened to you and ran the first command…

    root@Fog:/# service FOGMulticastManager stop; sleep 10

    • Stopping FOG Computer Imaging Solution: FOGMulticastManager [ OK ]
      root@Fog:/# ps -ef | grep ‘FOGMulti’ | grep -v grep

    As you can see nothing is running now.


  • Senior Developer

    @Joe-Gill Now this particular node IS a master node?



  • Hi Tom,

    Here is the result…

    root@Fog:/# ps -ef | grep ‘FOGMulti’ | grep -v grep
    root 25118 1 0 12:43 ? 00:00:00 /usr/bin/php -q /opt/fog/service/FOGMulticastManager/FOGMulticastManager
    root 25121 25118 0 12:43 ? 00:00:01 /usr/bin/php -q /opt/fog/service/FOGMulticastManager/FOGMulticastManager

    Joe


  • Senior Developer

    Sorry I’m an idiot.

    Please do output of ps -ef | grep 'FOGMulti' | grep -v grep


  • Senior Developer

    @Joe-Gill It appears twice though, both with different parent pids?

    Can you run:

    service FOGMulticastManager stop; sleep 10

    Post output of ps aux|grep FOGMulti again? Yes I nkow I’m asking you to stop the service, but I need to see if it thinks there’s two services running at the same time.



  • Here is the results from the ps command… It appears the service is running.

    root@Fog:/# ps aux | grep FOGMulti
    root 25118 0.0 0.2 203568 24940 ? S 12:43 0:00 /usr/bin/php -q /opt/fog/service/FOGMulticastManager/FOGMulticastManager
    root 25121 0.0 0.1 283860 19628 ? S 12:43 0:00 /usr/bin/php -q /opt/fog/service/FOGMulticastManager/FOGMulticastManager
    root 26380 0.0 0.0 15948 2244 pts/7 S+ 14:08 0:00 grep --color=auto FOGMulti



  • Thanks for the responses!

    I was able to download the latest trunk version. Yay! So now I’m up to date on my install.

    I was also able to run the debug on multicast. I can successfully run a multicast with two clients in debug mode. So it must be a setting in FOG.

    As for Clonezilla… I used it to image one of our labs. Basically I put the server edition on a USB flash drive, booted to it and pushed my images from their off of our NAS. This worked well. However, it does not provide all of the functionality of FOG.

    Also, I did check the /var/log/fog/multicast.log file out. The majority of the errors there say:

    This is not the master node.

    I checked to make sure I have our primary node set correctly in the GUI and it is correct. I have the FOG storage as Master Node.

    The only thing else that’s strange is that it says:

    Interface Ready with IP Address: 65.XXX.XX.194 address listed which is our public IP.

    Any ideas are appreciated!

    Thanks!!

    Cheers,

    Joe Gill


  • Developer

    @Joe-Gill said in FOG Multicast Problems / Partclone fails to finish:

    I know my network settings are correct because I can use Clonezilla multicast just fine.

    While this sounds like your network is setup correctly can you still give us some more details about what and how you tested with clonezilla.

    As well you want to check the log (/var/log/fog/multicast.log) and FOG services running (ps aux | grep FOGMulti).



  • when it refers to “debug”, you would just do a multicast deployment of said image to said machine, and on the confirmation window in FOG Trunk, tick the “debug” checkbox. This will cause said host to boot to a shell.



  • @Joe-Gill

    I did mange to download the latest trunk version using svn. I got it downloaded and am going to install it and see what happens. In the meantime help is appreciated. Thanks!!

    Cheers,

    Joe Gill


Log in to reply
 

470
Online

6.3k
Users

13.7k
Topics

129.9k
Posts