default.ipxe



  • I noticed a difference between versions 8088 and 8103 on the default.ipxe after an upgrade which caused my UEFI pxe booting to fail. For example…
    8088 under “:bootme” i had the following:
    chain http://addressofmyfogserver/fog/service/ipxe/boot.php##params
    8103 under “:bootme” the file reads:
    chain http://addressofmyfogserver//fog/service/ipxe/boot.php##params

    not sure if it is a bug, but the extra “/” causes an issue with pxe booting.


  • Senior Developer

    I’ve gone ahead and solved the thread, thanks for the heads up.



  • Btw…I tried version 8271 and everything is working properly and upgraded without any issues or changes to be made to any files. UEFI worked without any issue.



  • @Tom-Elliott Hello Tom, Sorry for the delay. Here is the file:

    #!ipxe
    cpuid --ext 29 && set arch x86_64 || set arch i386
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    param platform ${platform}
    param product ${product}
    param manufacturer ${product}
    param ipxever ${version}
    param filename ${filename}
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    :bootme
    chain http://10.30.40.55//fog/service/ipxe/boot.php##params

    The only difference I saw was the extra “/” as compared to the original. I seemed to have issues only with UEFI booting until I copied my old tftpboot folder over. I thought maybe the ipxe.efi file had been updated between builds. At any rate, I am running without issues at this point. Thank you.


  • Senior Developer

    Anything?


  • Senior Developer

    @Jason-Burt said in default.ipxe:

    10.30.40.55

    Can you simply post the default.ipxe file here? It’s obviously some change (beyond the double slash)



  • Hi

    Kept my 8088 snapshot and swapped my vms back and forth to verify (8088 is working without issues)…

    in 8088 here are the values for Web interface -> FOG Configuration -> FOG Settings -> Web Server ->:
    FOG_WEB_ROOT = /fog/
    FOG_WEB_HOST = 10.30.40.55

    in 8088 here is the value for Web interface -> Storage Management -> [node name] ->
    Web root = /fog

    After a git pull and install of Fog to 8103 the values remain the same, but the default.ipxe file changed again.

    I edited the default.ipxe file to try to fix by taking out the extra “/”, but the pxe boot issue continued. I decided to attempt to copy 8088’s tftpboot folder to 8103 and everything is working again. Not sure where the problem stems from though.

    Thanks,

    Jason


  • Moderator

    @Jason-Burt can you look here and see what it says?

    Web interface -> FOG Configuration -> FOG Settings -> Web Server -> FOG_WEB_ROOT and FOG_WEB_HOST

    Also check this value:
    Web interface -> Storage Management -> [node name] -> Web root

    I’m suspecting there might be an extra slash in one of those… If not, we need to do further digging.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.