Upgrading - From Fog 1.2.0 to Trunk - Possible?



  • At work we use Fog 1.2.0 to push out images and it is great. I am the main technician that troubleshoots issues and does the upgrades with Fog and just recently we got some Dell Latitude 5570 laptops in and thus far they will not check into Fog so I’m guessing I need to update the kernel for Fog for updated drivers. So here are some questions I would like to toss out there:

    1. When hardware is not compatible, such as the Latitude 5570, does one upgrade the kernel (RedHat) for the OS or perform an upgrade from Fog 1.2.0 to Trunk (Trunk includes latest kernel?)

    2. Can you upgrade from 1.2.0 directly to trunk or is a fresh install required?

    3. If I upgrade from 1.2.0 to trunk then will the upgrade affect the database or images at all?

    I attempted to upgrade Fog with a test Fog server sitting on Ubuntu but I ran into some package install issue with php5 I believe. Therefore, our main server is RedHat so I’m hoping that goes better.

    Thanks in advance!

    Motech09


  • Moderator

    @Motech09 I would very strongly dis-advise “upgrading”. Do a clean install of 16 - either on the existing box, or on a new box.



  • Guys,

    I went ahead and pulled down the 4.1 kernel and tossed it at the E5570 for now and it is working (can’t afford to spin wheels too long since people are waiting to image these laptops) which is great but I do plan on upgrading Ubuntu from 12.04 to 16 and then Fog over to Trunk version.

    Strangely, when trying to download the 4.1 kernel and save it as the default it would never work so I had to rename it to E5570 then it downloaded and worked — that’s odd.

    Anyways, thanks for the help everyone! Knowledge is power.



  • @Tom-Elliott

    I got the same result, Tom.



  • @Wayne-Workman

    I totally agree and might just end up doing that. I think I am going to attempt to upgrade the kernel for these new Dell laptops just to get the imaging going and then circle back with the trunk upgrade later.


  • Moderator

    @Motech09 To check for held broken packages do

    dpkg --get-selections | grep hold
    

    Then remove the installed packages.


  • Moderator

    @Motech09 It does make a difference. So in that case, you just need to get php 5 working.

    Many folks have said FOG Trunk works on Ubuntu 12, but I don’t have experience with that.

    But, I’d suggest building a new server using Ubuntu 16 if you want to run trunk, only because it’ll have a far longer support lifespan.



  • @Wayne-Workman

    That makes sense but It’s not Ubuntu 16 though, it is Ubuntu 12.04. Does that make a difference?

    Thanks for your assistance.


  • Moderator

    @Motech09 said in Upgrading - From Fog 1.2.0 to Trunk - Possible?:

    Why delete the .fogsettings file?

    If it is existing already, it’ll have php5 packages defined - which will not work on Ubuntu 16. Deleting it (or renaming it to .fogsettings.old) will cause the installer to re-write the file, and using the commands I pointed to earlier will cause it to write php 7 values in the file.


  • Senior Developer

    What if you run:

    sudo rm -rf /etc/php*
    sudo rm -rf /etc/apache2*
    sudo apt-get purge lib*php* apache2
    


  • @Wayne-Workman

    Why delete the .fogsettings file?



  • @george1421

    The following packages have unmet dependencies:
    libapache2-mod-php5 : Depends: apache2-api-20120211 but it is not installable
    Depends: apache2 (>= 2.4)
    E: Unable to correct problems, you have held broken packages.


  • Moderator

    @Motech09 said in Upgrading - From Fog 1.2.0 to Trunk - Possible?:

    @george1421

    Well, turns out that our Fog main server is using Ubuntu 12.04. I ran the install per instructions in the below link and all goes well until the last line “Installing package: libapache2-mod-php5…Failed!”

    What happens when you key in sudo apt-get install libapache2-mod-php5 from the command line? Do you get an error, if so what?


  • Moderator

    @Motech09 Ubuntu 16 requires php 7. Instructions on the two additional steps are here:
    https://forums.fogproject.org/topic/7131/fog-on-ubuntu-16-04-php7/26

    If you’ve attempted to run the installer without those using Ubuntu 16 and FOG Trunk, you’ll need to purge all php packages with sudo apt-get purge php5* lib*php* -yq as Tom says in that thread, then delete the /opt/fog/.fogsettings file and give it another go per those instructions.



  • @Wayne-Workman said in Upgrading - From Fog 1.2.0 to Trunk - Possible?:

    Ubuntu 16 works just fine. There are literally only two extra tiny steps.

    Wayne,

    Did you have trouble with the package libapache2-mod-php5 installing with your Ubuntu?



  • @george1421

    Well, turns out that our Fog main server is using Ubuntu 12.04. I ran the install per instructions in the below link and all goes well until the last line “Installing package: libapache2-mod-php5…Failed!”

    I researched this some earlier today after it happened to my test server but was unable to resolve.

    After this, the web page no longer displays and is broken.


  • Moderator

    Ubuntu 16 works just fine. There are literally only two extra tiny steps.



  • @george1421

    Thanks-a-million for the in-depth response, george1421, I definitely feel more confident in moving forward with the upgrade now.


  • Moderator

    To answer your questions in order

    1. The kernel upgrade is in regards to FOG and not the FOG host OS. The software that gets loaded onto the target computer (known as Fog OS or FOS) is a specialized version of linux just for FOG imaging. This is the kernel that needs to be upgraded to support the newer hardware. Upgrading to the trunk version of FOG itself will enable managing uefi systems, gpt disks, and Windows 10. That is a combination of upgrades done to the FOG server code, FOS and the latest kernel drivers. For your case, you may be able to just download and install the latest bzImage and bzImage32 files (these are the kernels). Do not replace the inits (FOS virtual hard drives) with the trunk version or you will break deployment. The trunk version of the kernels will work on 1.2.0 stable, no problem. This will give you access to newer hardware drivers only.
    2. Sure there is a direct upgrade path with little issues (almost none). Upgrading from 0.30 error is prone to cause more problems.
    3. Upgrading form 1.2.0 stable to the latest trunk version will update the database schema since additional capabilities are added to 1.2.0 trunk that require more information storage in the database. The images are not impacted at all. If you were upgrading from images captured before 1.2.0 then you will need to make a few adjustments to the image definitions in FOG.

    If you attempted to upgrade / test a new install of FOG and you tried to deploy it on Ubuntu 16.04 I can understand if you had issues. If you stick with 14.04 then your test install would have worked without issue. Ubuntu made some major internal changes with 16.04 that causes issues with FOG. I’m a RHEL/CentOS person and I have had great success with FOG. I know FOG works well with Ubuntu, I just done personally like all that sudo stuff. ;-)


  • Moderator

    The short answer is there is a direct upgrade path from 1.2.0 stable to 1.2.0 trunk. Understand that the trunk version is a dev version that is sometimes not as stable as stable is. But reported issues get top attention with the devs.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.