Uploading image breaks source machine, 7, Win10



  • this is hard diag but it seems that if i upload an image with old fog agent it works.
    If i install 10.6 (agent) we get an error about hardware (trying to get screenshot now) and then a a reboot to this error.
    0_1465212390985_2.png

    The source machine also get this message when it tries to complete the process?

    I have found that if i sysprep and boot without uploading to FOG it doesn’t error.
    any idea’s?


  • Moderator

    @george1421 said in Uploading image breaks source machine, 7, Win10:

    Just had an idea, what if the developers could put a command line switch in to install it but set the service to disabled.

    Great idea, asking @joe-schmitt to read this.


  • Moderator

    @ITCC said in Uploading image breaks source machine, 7, Win10:

    THANKS TO ALL FOR THE REPLIES. indeed you are all correct.
    I would like to add that i like the idea of installing the service at the end of sysprep.

    If you want to do this, you will just need to include the msi in your reference image then install the MSI with the proper command line switches in your setupcompleted.cmd script. This will work too. You just don’t want the fogclient running during the OOBE installer, after that its OK.


  • Moderator

    @Wayne-Workman

    Installing inside setupcomplete.cmd. That may be an option but then the MSI must be reachable during the execution of the setupcomplete.cmd script. This script executes as SYSTEM user so that msi must be on the target computer so it can be installed by setupcomplete.cmd.

    From a practical standpoint there is no need for the fog client on the reference image (other than not having to install it later). In my case I install it in the reference image and then stop and disable it right away. I would think if you had an automated process to install the client you can do that, or if the client is installed during audit mode, they will have to take the steps to disable it manually.

    Just had an idea, what if the developers could put a command line switch in to install it but set the service to disabled. Then through one action of installing the msi the environment would be setup. Leave the default setting as it is now to install and run, but then create a command line switch to install, not run, and set the service to disabled.



  • @Wayne-Workman said in Uploading image breaks source machine, 7, Win10:

    @george1421 Looking at that second script you posted, I wonder if we should just recommend to install the fog client inside the setupcomplete.cmd script itself?

    THANKS TO ALL FOR THE REPLIES. indeed you are all correct.
    I would like to add that i like the idea of installing the service at the end of sysprep.


  • Moderator

    @george1421 Looking at that second script you posted, I wonder if we should just recommend to install the fog client inside the setupcomplete.cmd script itself?


  • Moderator

    @Wayne-Workman I wonder if we should add in this section.

    https://wiki.fogproject.org/wiki/index.php?title=FOG_Client#FOG_Client_with_Sysprep

    If you intended to install the FOG client and then sysprep the image, you must disable the FOG client service before syspreping with

    net stop FOGService
    sc config FOGService start= disabled
    

    Or offer the complete script of:

    msiexec /i FOGService.msi /quiet USETRAY="0" HTTPS="0" WEBADDRESS="192.168.1.X" WEBROOT="/fog" ROOTLOG="0"
    net stop FOGService >nul
    sc config FOGService start= disabled
    

    People may be getting lost or overlooking the words. I’m not sure of the right answer here, but when I looked at that section the answer didn’t jump right out at me, I actually had to read what it said. ;-)


  • Moderator

    @ITCC More information about the sys-prep-preparation can be found here: https://wiki.fogproject.org/wiki/index.php?title=FOG_Client


  • Moderator

    @URfog has it correct.

    What is happening is the FOG Client is starting to do its job too early in the setup process and it reboots the computer when setup isn’t expecting it that is why you get this error. This is not something that FOG Server is “doing” specifically but just bad timing.

    It is recommended that you (on your reference image) set the fog service to start manually and then implement a setupcomplete.cmd file that starts the fog service and sets the service to run automatically. In my setup I have MDT install the fog service then issue this command in the same batch file that installs MDT. net stop FOGService and then sc config FOGService start= manual That keeps the FOG client from messing with my reference image too.

    sc config FOGService start= auto
    net start FOGService



  • What about this?
    https://wiki.fogproject.org/wiki/index.php?title=FOG_Client

    Last paragraph.

    In my installation it worked.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.