no reboot after image, rename, add to AD



  • I’ve noticed our workstations are not rebooting after they are imaged. Seems hit and miss. The fog.log show its wants to but doesn’t happen. After a manual the changes take effect. I’ve only tested this with Win10x32 PCs, SVN 7845.

    Another question, does the rename and adding to active directory take place at the same reboot or does FOG do a rename, reboot, add to AD, then reboot.

    ------------------------------------------------------------------------------
    --------------------------------HostnameChanger-------------------------------
    ------------------------------------------------------------------------------
     5/25/2016 6:04 PM Client-Info Client Version: 0.10.6
     5/25/2016 6:04 PM Client-Info Client OS:      Windows
     5/25/2016 6:04 PM Client-Info Server Version: 7845
     5/25/2016 6:04 PM Middleware::Response Success
     5/25/2016 6:04 PM HostnameChanger Checking Hostname
     5/25/2016 6:04 PM HostnameChanger Removing host from active directory
     5/25/2016 6:04 PM HostnameChanger The machine is not currently joined to a domain, code =  2692
     5/25/2016 6:04 PM HostnameChanger Renaming host to 4000-064-010
     5/25/2016 6:04 PM Power Creating shutdown command in 60 seconds
     5/25/2016 6:04 PM Bus {
      "self": true,
      "channel": "Power",
      "data": "{\r\n  \"action\": \"request\",\r\n  \"period\": 60,\r\n  \"options\": 2,\r\n  \"command\": \"/r /c \\\"FOG needs to rename your computer\\\" /t 0\",\r\n  \"message\": \"This computer needs to perform maintenance.\"\r\n}"
    }
     5/25/2016 6:04 PM Bus Emmiting message on channel: Power
    ------------------------------------------------------------------------------
    


  • @Jbob said in no reboot after image, rename, add to AD:

    Well I am confused. According to that log everything worked perefectly…

    I’m about to pull down a few other images. I’ll post back.


  • Senior Developer

    Well I am confused. According to that log everything worked perefectly…



  • Here is a fog log from one of our hosts. I did need to manually reboot it each time.

     5/26/2016 12:03 PM Main Overriding exception handling
     5/26/2016 12:03 PM Main Bootstrapping Zazzles
     5/26/2016 12:03 PM Controller Initialize
     5/26/2016 12:03 PM Entry Creating obj
     5/26/2016 12:03 PM Controller Start
    
     5/26/2016 12:03 PM Service Starting service
     5/26/2016 12:03 PM Bus Became bus server
     5/26/2016 12:03 PM Bus {
      "self": true,
      "channel": "Status",
      "data": "{\r\n  \"action\": \"load\"\r\n}"
    }
     5/26/2016 12:03 PM Bus Emmiting message on channel: Status
    
    ------------------------------------------------------------------------------
    --------------------------------Authentication--------------------------------
    ------------------------------------------------------------------------------
     5/26/2016 12:03 PM Client-Info Version: 0.10.6
     5/26/2016 12:03 PM Client-Info OS:      Windows
     5/26/2016 12:03 PM Middleware::Authentication Waiting for authentication timeout to pass
     5/26/2016 12:03 PM Middleware::Communication Download: http://ServerIPAddress/fog/management/other/ssl/srvpublic.crt
     5/26/2016 12:03 PM Data::RSA FOG Server CA cert found
     5/26/2016 12:03 PM Middleware::Authentication Cert OK
     5/26/2016 12:03 PM Middleware::Authentication ERROR: Could not get security token
     5/26/2016 12:03 PM Middleware::Authentication ERROR: Could not find file 'C:\Program Files\FOG\token.dat'.
     5/26/2016 12:03 PM Middleware::Communication POST URL: http://ServerIPAddress/fog/management/index.php?sub=requestClientInfo&authorize&newService
     5/26/2016 12:03 PM Middleware::Response Success
     5/26/2016 12:03 PM Middleware::Authentication Authenticated
    
    
     5/26/2016 12:03 PM Bus Registering ParseBus in channel Power
     5/26/2016 12:03 PM Middleware::Communication URL: http://ServerIPAddress/fog/management/index.php?sub=requestClientInfo&mac=18:A9:05:1B:09:B8||00:00:00:00:00:00:00:E0|00:00:00:00:00:00:00:E0&newService&json
     5/26/2016 12:03 PM Middleware::Response Success
     5/26/2016 12:03 PM Middleware::Communication URL: http://ServerIPAddress/fog/service/getversion.php?clientver&newService&json
     5/26/2016 12:03 PM Middleware::Communication URL: http://ServerIPAddress/fog/service/getversion.php?newService&json
    
     5/26/2016 12:03 PM Service Creating user agent cache
     5/26/2016 12:03 PM Middleware::Response Module is disabled globally on the FOG server
     5/26/2016 12:03 PM Middleware::Response No Printers
    
    ------------------------------------------------------------------------------
    ---------------------------------ClientUpdater--------------------------------
    ------------------------------------------------------------------------------
     5/26/2016 12:03 PM Client-Info Client Version: 0.10.6
     5/26/2016 12:03 PM Client-Info Client OS:      Windows
     5/26/2016 12:03 PM Client-Info Server Version: 7845
     5/26/2016 12:03 PM Middleware::Response Success
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    ----------------------------------TaskReboot----------------------------------
    ------------------------------------------------------------------------------
     5/26/2016 12:03 PM Client-Info Client Version: 0.10.6
     5/26/2016 12:03 PM Client-Info Client OS:      Windows
     5/26/2016 12:03 PM Client-Info Server Version: 7845
     5/26/2016 12:03 PM Middleware::Response Success
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    --------------------------------HostnameChanger-------------------------------
    ------------------------------------------------------------------------------
     5/26/2016 12:03 PM Client-Info Client Version: 0.10.6
     5/26/2016 12:03 PM Client-Info Client OS:      Windows
     5/26/2016 12:03 PM Client-Info Server Version: 7845
     5/26/2016 12:03 PM Middleware::Response Success
     5/26/2016 12:03 PM HostnameChanger Checking Hostname
     5/26/2016 12:03 PM HostnameChanger Removing host from active directory
     5/26/2016 12:03 PM HostnameChanger The machine is not currently joined to a domain, code =  2692
     5/26/2016 12:03 PM HostnameChanger Renaming host to 5800-066-023
     5/26/2016 12:03 PM Power Creating shutdown command in 60 seconds
     5/26/2016 12:03 PM Bus {
      "self": true,
      "channel": "Power",
      "data": "{\r\n  \"action\": \"request\",\r\n  \"period\": 60,\r\n  \"options\": 2,\r\n  \"command\": \"/r /c \\\"FOG needs to rename your computer\\\" /t 0\",\r\n  \"message\": \"This computer needs to perform maintenance.\"\r\n}"
    }
     5/26/2016 12:03 PM Bus Emmiting message on channel: Power
    ------------------------------------------------------------------------------
    
     5/26/2016 12:03 PM Service Power operation being requested, checking back in 30 seconds
     5/26/2016 12:04 PM Service Power operation being requested, checking back in 30 seconds
     5/26/2016 12:04 PM Power Creating shutdown request
     5/26/2016 12:04 PM Power Parameters: /r /c "FOG needs to rename your computer" /t 0
     5/26/2016 12:04 PM Service Power operation being requested, checking back in 30 seconds
     5/26/2016 12:04 PM Bus {
      "self": true,
      "channel": "Power",
      "data": "{\r\n  \"action\": \"shuttingdown\"\r\n}"
    }
     5/26/2016 12:04 PM Bus Emmiting message on channel: Power
    

  • Moderator

    @Scott-B said in no reboot after image, rename, add to AD:

    Does one have to reset the encryption on a host each time its imaged or should the imaging process get around that?

    You shouldn’t have to do that when you image - but if there are pre-existing issues due to past complications, it doesn’t hurt to put all hosts into one big group and use the group to just reset them all.

    Also, it should be noted that the time on your FOG server and the clients need to match in order for the encryption mechanisms to work properly. I think that people neglecting to set the appropriate time zone and an NTP server on their fog servers causes most of the issues we are seeing with the encryption scheme. Incorrect time will also make scheduled tasks pretty much useless.



  • @Jbob said in no reboot after image, rename, add to AD:

    I’ll get a full fog.log. Does one have to reset the encryption on a host each time its imaged or should the imaging process get around that?


  • Senior Developer

    @Scott-B The client requires multiple reboots to fully apply AD integration and renaming. I also need to see the whole fog.log file.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.