Cannot PXE boot



  • We have been using Fog 1.2 for quite some time and recently ran into an issue with the newer gen 2 HP laptops and desktops. We saw some posts that people were able to get around the issue by moving ahead of the stable builds. We started fresh with ubuntu 14.04 and fog 1.2 then used SVN to update to 7843. The new setup cannot PXE boot new or old system currently and we are seeing an error we have not seen previously. Any help is really appreciated!

    screenshot of error


  • Moderator

    @george1421 said in Cannot PXE boot:

    I have also seen that some projects actually have a service page that lists if the services are running or not, and gives the admin a choice to stop or start a service.

    I’ve got a DHCP plugin ready to be integrated into fog… just having a lot of trouble understanding the plugin system for such a large plugin.

    But, I can easily create a two-file + small DB change plugin that will detect the status of services and offer the ability to restart on a click.

    Again though, the one thing holding me back from going wild is a lack of understanding of the plugin system. People have attempted to explain it to me many times but it just doesn’t click. I need to be shown.


  • Moderator

    @Wayne-Workman I think where @jpmtg is coming from is that in some opensource projects there is a supervisory service that makes sure everything is running and if its not attempts to start it X times. If it fails X times then it send out an alert or email the admin. I have also seen that some projects actually have a service page that lists if the services are running or not, and gives the admin a choice to stop or start a service.


  • Moderator

    @jpmtg You could disable services on boot, and then modify the /etc/rc.local file on Ubuntu systems, or I think /etc/rc.d/rc.local on Fedora/CentOS and then call each service you disabled manually. This file will run on each boot. The idea is just to create a delay, which is what (increasingly seems like) very fast systems need.

    Make sure the file has the executable bit set, for whatever path:
    chmod +x /etc/rc.d/rc.local

    Make sure this line is at the very top of the script:
    #!/bin/bash

    Then you can insert a sleep command:

    sleep 30

    Then you can start all the services you want, in whatever order. You can have more than one sleep statement if you want. This is OS specific. Here’s an example for Fedora:

    systemctl start nfs-server
    systemctl start rpcbind
    systemctl start dhcpd
    systemctl start tftpd-hpa
    systemctl start FOGMulticastManager
    systemctl start FOGScheduler
    systemctl start FOGSnapinReplicator
    systemctl start FOGImageReplicator
    

    The file should always end with this line:
    exit 0

    If you do this, don’t forget to disable each of these items. Otherwise you might run into issues with two of them running, or crashing, or some other crazy stuff.



  • @Wayne-Workman Maybe I should clarify my question a bit. Is there a method to check if the services are not running or possibly restarting them all after a reboot via an automated script? I have been told that the tftpd-hpa has to be stopped then started after most reboots to work properly and today after a reboot the DHCP service decided to not start. Thanks for the help and comments for sure!


  • Moderator

    @jpmtg Yes.

    Ubuntu/debian:

    service thing status

    Red Hat/Fedora/CentOS:

    systemctl status thing

    so for example, service dhcpd status



  • All my issues are now resolved after moving to the newest release and making sure all the services were started. Is there a way to make sure everything fog uses is always running after boot (tftpd-hpa and dhcp)?



  • @Sebastian-Roth And with that said, I will say although I am very new to FOG and Linux, I will try to help if I can. Wayne has been great and I had a good talk with George as well. The community here is great and full of knowledge.

    So far FOG is great and I am trying to learn/understand as much as i can about it.


  • Developer

    Sorry for this off topic post but I need to thank @Wayne-Workman for his comment and feel like I want to add something to it.

    But I’m still light-years behind some of these other guys.

    I guess you already know this but better to say it out load - for others to hear/read as well. We are all light-years behind someone else. But that’s not the point. Everyone can learn, everyone can help. So I can just repeat Wayne’s suggestion on helping us in the forums. Don’t feel like you might not know enough or could give a wrong answer. As I said everyone does know something and wrong answers can still help to learn (for you and others).



  • Turns out the DHCP service was stopped. IT is now trying to pull an image again. Cross fingers!



  • I updated to 7861 this morning and that resolved the error in the screenshot. We were then able to get it to start trying to capture an image but it failed on the last step with a failed ftp login. After reading a bit this seemed to be because of passwords not matching. We set the passwords in fog to match ubuntu/storage/ftp so that they were all the same username and passwords. We tried again and ftp still failed. We walked away from it for a few to address some other issues and when we came back the screen was locked but the password we had set failed to unlock the computer. We rebooted into recovery and reset the fog user password back to what it was and pressed on. The next attempt failed to pull an IP address from the fog server. We restarted the service like this:

    sudo service tftpd-hpa stop
    sudo service tftpd-hpa start

    It still fails to pull an IP address. Thanks again for the continued support!


  • Moderator

    @jpmtg said in Cannot PXE boot:

    Some of the other open source software I use has paid support/configuration and I was curious if that is something that is available for Fog?

    No, sir.

    FOG is open source, so too is support. Meaning all support is openly conducted on the forums by volunteers in order to benefit everyone.

    That said, nothing is stopping anyone from creating a business for supporting fog, because it’s open source anyone can do this. Although I think that if said business is run by anyone other than our current volunteer team, it’d probably suck pretty bad. And I am not interested in contributing to closed-source minded support. Others may feel differently.

    We do need more help though. It’d be appreciated if you or anyone could assist others in the forums where you can. This is how I started, and slowly learned more over time. But I’m still light-years behind some of these other guys.



  • No worries on the bugs! I understand that comes with traveling off the beaten path. Thanks for letting me know that I was not alone in my issue. I will be onsite tomorrow to try again and I will be sure to report back. Some of the other open source software I use has paid support/configuration and I was curious if that is something that is available for Fog?


  • Senior Developer

    @jpmtg Usually by the time you install, the version you installed is already out of date (on trunk).

    It’s not something I “try” to do, but I’m constantly making improvements and fixing issues as they come along.


  • Moderator

    @adukes40 I agree I updated my dev environment first thing this AM (6a EDT) and then tried to deploy around 1p EDT and received the same exact error. I checked a few things and saw some errors in the apache log and the ipxe boot menu (construction) was messed up, so I updated again and they the image pxe booted correctly. This is life with the trunk build, you have to tolerate a little instability but the benefits are well worth it.

    Please update your installer to the latest release and then run the bin/installfog.sh script again.



  • It should have been fixed this morning. try updating to the latest version. i had this exact issue this morning.


Log in to reply
 

324
Online

38729
Users

10555
Topics

99937
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.