Only can image one pc at a time.



  • Hi. I have been using fog for quite a while and all of a sudden I am only able to image one computer at a time. I use to be able to image 7 or 8 at a time.

    Is there a setting I am missing or what?

    It just says waiting in the Que and once the first one is done the next kicks in but I am doing labs this summer and would like to get them done quicker.

    Any suggestions would be appreciated.

    Thank you in advance. James


  • Senior Developer

    @jpaul 0.32 is VERY old, but I’m glad you got it working.

    @Wayne-Workman I don’t know when the global max size stopped being used, but I’m fairly certain it was removed when 1.0.0 released. (more or less).

    I’ll look through the code to verify if anything is using it anymore.



  • When I changed the max number of clients in the default group for all storage nodes. That fixed it… Now I can image multiple machines at the same time. The number was 10 and I set it to 12 … Must of done something because now it works…

    Thanks Wayne and for all who replied…

    James


  • Moderator

    @jpaul On your FOG Server, at CLI, you can clear out all old/current tasks, that might fix it.

    mysql
    use fog
    truncate table tasks;

    I’m not sure how 0.32’s multicast tables are setup but they may be the same still. Here are the commands to clear those out as well:

    truncate table multicastSessions;
    truncate table multicastSessionsAssoc;

    Also - it’s probably wise to figure this issue out before attempting an upgrade to a newer version of FOG - or - just starting fresh. Starting fresh isn’t as daunting as it sounds, if you update to fog trunk. The new fog client - if pushed out via group policy - will register all hosts it’s installed on, they will appear in your “pending hosts” list and you just would approve them as they come in.



  • There are no queued tasks . and the activity pie on the main dashboard says 0 for activity count.

    fog version 0.32


  • Moderator

    @jpaul What shows in task management? Any queued tasks? What does the activity pie on the main dashboard say for activity count?

    Sounds sort of like you have some tasks stuck in task management that are taking up your open slots.

    Also - as George said, we need to know what version of FOG you are using.



  • My que size is set for 25.


  • Moderator

    @george1421 I wonder if that is used anymore? Maybe it’s a global maximum ? @Tom-Elliott could you let us know?


  • Moderator

    @Wayne-Workman Good catch, not the one I was thinking about but that is also one that has an impact based on storage node availability.

    Web Interface -> FOG Settings -> General Settings -> FOG_QUEUESIZE defines how many unicast sessions are allowed at one time.


  • Moderator

    Check this area here: Web interface -> Storage Management -> [node name] -> Max Clients

    This setting is how you limit how many can image at one time. On my network I find that I get a shorter overall imaging time with many hosts if I limit this to two. Your case may be different though.

    If multicast works in your environment I would suggest using that instead for the same image being pushed to many hosts.


  • Moderator

    Lets start with some basics.

    What version of fog are you using (i.e. post the numbers on the cloud from the management gui web page).

    Nothing has changed in your configuration but now image deployment is serial instead of big bang? (If I remember right there is a max concurrent deploy settings [not the right words but the right concept]).

    Depending on your network infrastructure setup you could look into multicasting to do an entire lab in one shot.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.