php7 not recognized



  • I am trying to install the newest “stable release” of FOG onto a 16.40 Ubuntu machine (running lubuntu). The install seems to go just fine at first, but when I get to the point where it checks the packages it fails at php5-json:

    • Checking Package: php5-json…Failed!

    I have installed the php packages in terminal and if I check the packages I have installed, php7.0-json shows up. I have tried to install php5, but it says that it is referred to by another package (I would assume php7.0). I also just installed the “php-json” package and that had no effect either.

    Any idea how I can get around this error?



  • @Tumulus You’re fine, FOG runs on Ubuntu 16 just fine. You simply run the installer as tom said, and everything is just-fine.



  • Well, I tried @Tom Elliott’s suggestion to no avail. I did know about the wiki, and I understand that there are issues with the newest version and that it will not be the most stable or reliable. I configured the php according to the wiki. It just wasn’t working really well so I wondered if there was a quick solution.

    For now I think we’ll just go back to a previous version of Ubuntu.


  • Senior Developer

    Try running the installer but as:
    php_ver='7.0' php_verAdds='-7.0' ./installfog.sh -y


  • Developer

    Please check the FOG installer log in fogproject/bin/error_log/fog_<version>…

    I am wondering if you are aware of the wiki article on 16.04?


 

513
Online

41.8k
Users

12.3k
Topics

116.0k
Posts