7703 - Groups Bugged



  • When I add a host to a group, it works. When I try to add a second host to a group, it removes the first. If I select two hosts at once to add to a group, it will only add the last one.

    Ex. HOST-01 -> added to group, stays.

    Attempt to add HOST-02 -> removes 01, adds and keeps 02 in group.



  • @Tom-Elliott Can also confirm groups are working againg.
    Thank you Tom!


  • Developer

    Great stuff. Thanks guys for insisting on this not working properly. Thanks Tom for fixing it!



  • Thanks to everybody. The groups are working as they should now with the latest revision 7881. Case closed.



  • @Tom-Elliott Can confirm working on latest release, thank you again!


  • Senior Developer

    Found and confirmed. The auto increment part broke this. I’m sorry I missed the _ in AUTO_INCREMENT so the table failed to create.

    I’ve pushed a fix for this. If you lost db, please use one of the sql files from before this change and you should be able to recover.


  • Moderator

    I wanted to see this for myself and I am experiencing the same issue of not being able to add members to groups.

    Apache error when attempting this is :

    [Thu May 26 14:01:46.904843 2016] [:error] [pid 16610] [client 192.168.1.154:60082] client denied by server configuration: /var/www/html/fog/status/getfiles.php
    


  • @michael_f The schema update is broken,the table groupMembers is missing in my DB



  • Same problem here



  • @Wayne-Workman Same problem here: since I upgraded to 7853 all groups are empty and no client can be added.
    Also existing groups with members have been emptied.
    Apache error log doesn’t shown any errors when attempting to add clients.
    Updating to lastest trunk didn’t solve the problem.
    Tried to delete all groups and set DB-Schema as Tom Elliot suggested. When doing a schema update i get the error message

    PHP Strict Standards: Only variables should be passed by reference in /var/www/fog/lib/pages/schemaupdaterpage.class.php on line 48, referer: http://172.16.0.231/fog/management/?node=schema
    

  • Moderator

    @mclapper68 Immediately after reproducing the problem, can you check for apache errors?
    Web interface -> FOG Configuration -> Log Viewer -> Apache error log

    Look at the timestamps on the entries and post any relevant ones.



  • I click on the Host Manager in the Fog gui. Then I select List All Hosts then check the ones I want to add to a goup then I choose Create New Group then enter the name. When I go to the Group Managemnet and List All Groups my group is membership is zero. I ran the db schema update to 218 and I did not receive any errors in the gui. I believe my problem maybe related to FogProject Topic 7360.


  • Senior Developer

    Yeah, I need more information if possible.

    If it’s any help, I’ve now added two bits of information to update and help maintain and keep this from happening. If you’re doing the schema updates, and these aren’t happening properly. Is there any error’s reported in the gui when you ran the schema update?

    What happens if you change the DB schema to 218?

    mysql -u root fog
    UPDATE schemaVersion SET vValue=218 where vID=1;
    exit

  • Moderator

    Just tested this on 7853 with Fedora 23, all seems fine for me.

    Since that’s the same version you tried, there is probably something wrong in the DB.

    Can you describe, click-for-click, how you are adding them to the group?



  • I updated to the latest revision 7853 then updated the database scheme. Deleted all my groups. Created a new test group and tried to add some hosts, but now it will not add any hosts to the groups.



  • It’s just a revision update @mclapper68



  • Thanks to the both of you (Tom and URfog) for the help. But I am not sure what I am to do to correct the problem. Do I need to update fog again or make a change to my fog database?


  • Senior Developer

    @URfog,

    Thanks for posting this.

    I’ve added this as a schema update as I think you’re correct in what the issue is.

    Hopefully this will help both of the users and it’s in the base code so no more “tricks” to try to get it to work.



  • Are you trying it on a Debian 8.4? If so I had to touch the groupMembers

    UNIQUE KEY gmHostID (gmHostID,gmGroupID),

    because it was originally UNIQUE KEY gmHostID (gmGroupID),

    Hope it helps



  • I deleted all of my groups. Created a new test group then selected the dozen hosts I wanted. Unfortunately, only one host is in my list. If I add a new host to the group it replaces the one that is in the list.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.