upgrading to SVN failed :(



  • Failed to upgrade to SVN trunk.

    Followed the wiki instructions and recieved no errors - https://wiki.fogproject.org/wiki/index.php?title=Upgrade_to_trunk

    Now the FOG reports still on version 1.2 and the dashboard reports in disk information :- no error but no data was returned.
    In Hardware information the kernel reports :- Error communicating with the database

    Before i revert my snapshot and try again - anything i can attempt to resolve or investigate further ?


  • Moderator

    @craigcoulson For you and future readers, it’s not necessary to uninstall old versions of FOG, nor is it necessary to move the images. Of course, I will always advise to take backups of the DB and hosts and images - not just when updating but on a regular basis.



  • well after a couple of rollbacks and failed SVN installs (still not sure why) i finally got the server running on the latest trunk
    I actually used GIT this time and it went well.
    the steps i took (in case they may be useful)

    • backup mysql
    • export hosts
    • removed 1.2 version of fog using the uninstall instructions
    • renamed \images to \images_old
    • install GIT
    • followed instructions to install from trunk
    • import sql
    • import hosts
    • move my image from \images_old to \images
    • profit !

  • Senior Developer

    By the way, that screen is dynamic too (the error you’re seeing there.)

    If it is indeed a problem with the config.class.php and you fix it. It should present you the form buttons automatically.


  • Senior Developer

    @craigcoulson I added that screen yesterday to try to help people more on the fly. If it can’t connect to the database, the main gui (and everything else) will fail as well. That message is an attempt to help lead you to the solution (though I have no idea what is the problem currently.)

    My only guess, if I had to have one. What’s the settings in the /var/www/html/fog/lib/fog/config.class.php file for the Database values? If you have a password, please block it, but post the contents of these values so we can see more what’s going on.



  • it all went well - till i went to check/update the schema and was greeted with this :- 0_1463728628049_fog2.JPG

    the version looks good at least !


  • Developer

    @craigcoulson said:

    If i revert my snapshot - move things back - then apply SVN it should all go normally then right ?

    I’d say so!



  • Ahh, i now recall moving the original installation out of the HTML folder to shorten the overall url - my bad :/

    If i revert my snapshot - move things back - then apply SVN it should all go normally then right ?


  • Developer

    @craigcoulson Sorry, my fault. I just typed that second command from the top of my head without actually testing it on my machine… try this: find /etc/ -name "001-fog*" -exec grep DocumentRoot {} /dev/null \; (was only missing one important character).

    From what the directory listings look like you have two FOG web interfaces installed now. The one on /var/www/fog looks like version 1.2.0 while /var/www/html/fog probably is the FOG trunk one. Better move both out of the way and re-run the installer. Just to make sure you have a clean one and no confusion later on:

    sudo mkdir /var/www/backup_old
    sudo mv /var/www/fog /var/www/backup_old
    sudo mv /var/www/html /var/www/backup_old
    cd /path/to/fogproject
    git pull
    cd bin
    sudo ./installfog.sh
    ...
    


  • root@FOGServer:~/fogproject/bin# ls -al /var/www /var/www/fog /var/www/html
    /var/www:
    total 16
    drwxr-xr-x  4 root     root     4096 Apr 14 12:47 .
    drwxr-xr-x 14 root     root     4096 Apr 14 14:30 ..
    drwxr-xr-x 12 www-data www-data 4096 Apr 14 12:47 fog
    drwxr-xr-x  3 root     root     4096 May 18 11:36 html
    
    /var/www/fog:
    total 56
    drwxr-xr-x 12 www-data www-data 4096 Apr 14 12:47 .
    drwxr-xr-x  4 root     root     4096 Apr 14 12:47 ..
    drwxr-xr-x  2 www-data root     4096 Apr 14 12:47 av
    drwxr-xr-x  2 www-data www-data 4096 Apr 14 12:47 client
    drwxr-xr-x  3 www-data www-data 4096 Apr 14 12:47 commons
    -rw-r--r--  1 www-data www-data 1406 Apr 14 12:47 favicon.ico
    -rw-r--r--  1 www-data www-data   50 Apr 14 12:47 index.php
    drwxr-xr-x  7 www-data www-data 4096 Apr 14 12:47 lib
    drwxr-xr-x 12 www-data www-data 4096 Apr 14 12:47 management
    drwxr-xr-x  4 www-data www-data 4096 Apr 14 12:47 mobile
    drwxr-xr-x  3 www-data www-data 4096 Apr 14 12:47 public
    drwxr-xr-x  3 www-data www-data 4096 Apr 14 12:47 service
    drwxr-xr-x  2 www-data www-data 4096 Apr 14 12:47 status
    drwxr-xr-x  2 www-data www-data 4096 Apr 14 12:47 wol
    
    /var/www/html:
    total 28
    drwxr-xr-x  3 root     root      4096 May 18 11:36 .
    drwxr-xr-x  4 root     root      4096 Apr 14 12:47 ..
    drwxr-xr-x 10 www-data www-data  4096 May 18 11:36 fog
    -rw-r--r--  1 root     root     11321 Apr 14 11:59 index.html
    -rw-r--r--  1 root     root       151 Apr 14 13:02 index.php
    

    no response to the second command at all ?


  • Developer

    Tom Elliott said:

    My guess is it failed at updating database?

    Either that or the www directory is a bit screwed. Please run ls -al /var/www /var/www/fog /var/www/html and find /etc/ -name "001-fog" -exec grep DocumentRoot {} /dev/null \; and take a picture to show us exactly what you see. Copy&paste would also be ok!


  • Senior Developer

    What were you installing? If it’s from 4 hours ago, then I’m assuming the latest at that time. What you see on the “login” screen is not the same as the version you’re attempting to install. That is found in the Cloud icon on the top left portion of the page.

    Please rerun the svn up/git pull portion of the folder and retry installing. My guess is it failed at updating database?


  • Moderator

    @craigcoulson Apache error log ?



  • nothing to speak of in the mysql log
    mysql still running

    hmmm…



  • Just delving in there now :)


  • Moderator

    @craigcoulson Hi, have you check mysql log ?


Log in to reply
 

439
Online

38952
Users

10703
Topics

101543
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.