Apache2 for fog vhost.



  • Hi, im upgrading from fog 1.2.0 to trunk and geting error when installfog.sh is restarting apache.

    Here is the error of systemctl status -l httpd:
    httpd[4635]: httpd: Syntax error on line 353 of /etc/httpd/conf/httpd.conf: Syntax error on line 12 of /etc/httpd/conf.d/fastcgi.conf: Cannot load modules/mod_fastcgi.so into server: /etc/httpd/modules/mod_fastcgi.so: undefined symbol: unixd_config

    And the second thing is in /var/www/html/fog. The installer creates a symbolic link like html/fog/fog/fog/fog… and i have removed it but it still shows up when runing the installer.

    I tried to uncomment the line on 353 but got no webinterface after, so did not work.

    I tried to remove all php files and programs and run installerfog.sh again but nothing.

    Edit: using svn
    Edit: There is something wrong whit the apache module, i tested to remove them and run installfog.sh again but it install old modules that gives errors


  • Developer

    @scheffman said:

    Im more of a FreeBSD person, i would love to see fog working for FreeBSD some day.

    While I think that it should be possible to do (requirements: PHP 5/6/7, MySql, Apache, FTP, NFS, (DHCP, TFTP)) it will be a hugh effort to get the installer to fully run on a BSD system - package system being very different!

    I’d still love to see if it’d work. Are you happy to give it a try? Start by installing the mentioned packages/services on FreeBSD, then checkout fogproject via GIT and copy fogproject/packages/web folder to apache web root. See what you get. Looking forward to hear from you!



  • @scheffman said in Apache2 for fog vhost.:

    Im more of a FreeBSD person, i would love to see fog working for FreeBSD some day.

    I’m sure it could easily work, I’m also sure I have my hands quite full with Fedora, CentOS , Debian, and Ubuntu at the moment lol. Why don’t you give it a try?



  • @Wayne-Workman @Sebastian-Roth Okey so sorry for being afk, i hade some stuff to do in school. It did work too remove /etc/yum.repos.d/rpmforge. I did get some errors from the schemaupdaterpahe.php but did a pull from git and updated and every thing works now. Now i hope ill get the realtek card to work with fog, I have another post about that and will post in that one if it dont work. Thanks for the awesome support. Im more of a FreeBSD person, i would love to see fog working for FreeBSD some day. Still awesome work, keep it up!!!



  • @scheffman George’s recommendation was a good one, it’s what I would have suggested. Only I would have advised to nuke, re-pave, and go straight to FOG Trunk.



  • @Wayne-Workman I cant find it on the wiki, It was for CentOS 7 and fog 1.2.0, I did the first install september 2015 i think. I maybe have the installation guid writen down some where if needed.

    It workt great, but not for the laptops that the fog server was going to work for, so i posted another tread on the forum about that, and george1421 told me that they maybe working beter with trunk so i tried to upgrade, and got where i am now.

    @Sebastian-Roth Thank ill try it, ill get back with my results.


  • Developer

    @scheffman You should be able to prevent the installer from pulling mod_fastcgi by either removing the repository from /etc/yum.repos.d/… (possibly named something like ‘rpmforge…’) or by editing the installer script in fogproject/lib/redhat/config.sh:

    ...
    packages="httpd ... mod_fastcgi"
    ...
    

    Simplay remove mod_fastcgi from that line (keep the quote at the end!) and you should be fine.



  • @scheffman What guide did you follow?



  • @Sebastian-Roth Maybe when i installer fog 1.2.0 6 months ago, sorry about that. But i removed mod_fastcgi then when i install with the new installfog.sh it gets installed again. So if i install a newer one it works? or remove the older repositorie?

    I did just follow the old installation guid for CentOS when installing 1.2.0

    Ill try to make a fresh install. this week if i cant fix it, i did only have access trough ssh so didnt have the possibility.

    btw, thanks for greate support and great program.


  • Developer

    said in Apache2 for fog vhost.:

    systemctl status -l httpd

    @Tom-Elliott Haha, turns out that mod_fastcgi does not exist in CentOS 7 (and is actually really outdated…). Do we really need this???

    @scheffman I was able to replicate your problem by running the following commands:

    wget http://pkgs.repoforge.org/mod_fastcgi/mod_fastcgi-2.4.6-2.el6.rf.x86_64.rpm
    rpm -i mod_fastcgi-2.4.6-2.el6.rf.x86_64.rpm
    systemctl status -l httpd
    ...
    Apr 24 17:33:30 fog120.localdomain systemd[1]: Starting The Apache HTTP Server...
    Apr 24 17:33:30 fog120.localdomain httpd[6094]: httpd: Syntax error on line 353 of /etc/httpd/conf/httpd.conf: Syntax error on line 12 of /etc/httpd/conf.d/fastcgi.conf: Cannot load modules/mod_fastcgi.so into server: /etc/httpd/modules/mod_fastcgi.so: undefined symbol: unixd_config
    ...
    

    PS: I wish you would have told us if you installed old packages or added package repositories by hand. Would have saved me a couple of hours…



  • Ok I just finished building a CentOS 7 minimal, following the exacto-o instructions for CentOS 7 in our Wiki and it worked overall just fine.

    I modified one part of the article about firewalld, because I just found out that minimal doesn’t come with firewalld installed by default.

    But other than that everything appears to be working as far as the web interface is concerned, not one hiccup, worked on the 1st try.

    My suggestion to you for the moment is to install CentOS 7 from scratch again, and go straight to FOG Trunk, do not bother with 1.2.0.

    However, I’m still very concerned that updating from 1.2.0 on CentOS 7 is not working for some reason.


  • Developer

    @scheffman My auto installer is running (cent os 7 this time) and I will post back in a minute…

    [edit]Haha, just found this… https://github.com/FOGProject/fogproject/commit/bb34c3774d736883124c7dd4fcd3b07a8de111f7#diff-744d8c9d766acc0c419b6d9a72183c63 [/edit]

    Possibly something to do with the newly added mod_evasive?!?



  • Okej, I did a ‘yum update’ and got the latest fog from the git and svn. And the same thing happend.

    Im trying to update a CentOS 7 fog 1.2.0 to trunk. becuse i dont have access to the server, but i might get access to it this week and do a fresh install, if i cant fix it.



  • I just noticed Tom added an “Evasive” thing to the fog installer list for red-hat… Don’t remember the exact name, but maybe you should update and try again?

    I’m still in the process of building CentOS 7, got side tracked for a hot minute.



  • @scheffman This is very interesting.

    Let me re-confirm. Heading to the basement now lol.



  • Hi, i am on a CentOS 7.2.1511

    uname -r
    3.10.0-327.13.1.el7.x86_64
    
    rpm -qa | grep -e fastcgi -e httpd
    httpd-tools-2.4.6-40.el7.centos.x86_64
    httpd-2.4.6-40.el7.centos.x86_64
    mod_fastcgi-2.4.6-2.el6.rf.x86_64
    

    I am running installer from the latest version from git now.
    I tested to remove mod_fastcgi still same thing. I removed the httpd configs and removed httpd and php-fpm mod_fastcgi but did nothing and i did a system update before i tried to install trunk like it says in the wiki.


  • Developer

    said in Apache2 for fog vhost.:

    /etc/httpd/modules/mod_fastcgi.so: undefined symbol: unixd_config

    Wow, that’s an interesting one! Something we never had before it seems. The error is due to the fact that Apache 2.4 renamed an internal data structure from unixd_config to ap_unixd_config! But why on earth is mod_fastcgi.so still referencing the old data structure?? From the paths I would guess this is a redhat based system (not debian/ubuntu). Please see if versions are matching on your system:

    rpm -qa | grep -e fastcgi -e httpd
    ...
    httpd...
    ...
    mod_fastcgi...
    ...
    

    im upgrading from fog 1.2.0 to trunk and geting error

    Most probably the error was not caused by something the FOG installer did to the httpd config but from upgrading system packages (which is done by the FOG installer). Modern systems use php-fpm instead of mod_fastcgi to run PHP. If you don’t actually need mod_fastcgi for other web apps on your server you might be able to simply solve this by removing the mod_fastcgi package…

    @Tom-Elliott Should we warn people that system is going to be fully updated when running the (new) FOG installer? I am sure a lot of old (outdated) system are going to break by running the FOG installer.



  • I know you’re using Ubuntu or Debian because you refer to apache as “apache2”, but you didn’t let us know what version. We need to know that. Also, when you ran the installer, what version did it say it was?


 

385
Online

41.6k
Users

12.1k
Topics

114.2k
Posts