Cannot enter fog management screen after localized install



  • I am trying to setup a fog server on a localized network using this guide, https://wiki.fogproject.org/wiki/index.php/FOG_on_an_Isolated_Network with Ubuntu 12.04 LTS and Fog 1.2.0. After completing the steps I attempt to open the fog management page it goes to a blank screen. I tried restarting several services such as mysql and apache, but they aren’t starting until after I hit enter to complete the install (without updated databases) and am still unable to get to the management screen. The Fog server needs to be completely off of my network, and am planning on using it to mass DBAN old computers.



  • Ok, finally got a localized install working on Ubuntu 14! I had to do the install off of my work site to get the packages downloaded correctly. To get computers to PXE boot I had a sysadmin friend walk me through making 2 ethernet interfaces in my virtual machine and used the machine hosting the VM to access the web interface.



  • @cemicolin I’ve installed FOG Trunk on Ubuntu 15 Server one time - it was quite simple. In fact, probably the easiest FOG installation I’ve ever done.

    Alas, though, contrary to experience, I will stick to my guns, and stay with Red Hat based distributions.



  • Unfortunately that threw even more errors, it couldn’t halt the server. When I did manage to halt the server processes and try the install I got a bunch of other apache errors. I took your advice and started over with a Ubuntu 15 install. However, the network panel went missing which is causing problems getting the NIC setup correctly and causing the fog install to fail. I’ve never had so many issues configuring a Ubuntu machine, so I’m going to try this at home on the off chance that something in my work environment is causing issues.



  • @cemicolin then install what it says it needs.
    sudo apt-get install apache2.2-common -y



  • @Wayne-Workman See attached, thanks0_1461356306905_fog log.rtf

    The following packages have unmet dependencies:
    libapache2-mod-fastcgi : Depends: apache2.2-common (>= 2.2.4) but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.



  • Also - you might want to go with Ubuntu 14 or 15, since there is nothing to lose by reinstalling in your specific scenario.



  • @cemicolin if you go to where you put your FOG Trunk install files, go into bin/error_logs you will see some files in there, named fog_error_xxxx.log

    The xxxx should be the revision number your on. Can you supply us with that file?



  • I went ahead and upgraded to trunk which broke Apache, libapache2-mod-fastcgi fails to install. I’m not sure where to look for the log to look closer at the “Installing package: libapache2-mod-fastcqi…Failed!” message



  • If you’re setting up FOG just to use it with DBAN, why not use fog trunk? After all, our DBAN wiki article was written for FOG Trunk.



  • I can see the web management console and it says my server IP is 192.168.1.1, but still cannot use that address to login to that console from other computers or the Fog server computer. I cannot ping it from other computers on the same network switch. The PCs cannot boot to PXE, it just times out and boots into Windows.



  • No errors. However, I did find a solution to updating the schema/database. Instead of typing in the direct IP address I use //localhost/fog/management. Does this mean that my server isn’t broadcasting at 192.168.1.1?


  • Developer

    @cemicolin Any errors in /var/log/apache2/error.log when you try the web interface URL…?


 

557
Online

41.6k
Users

12.1k
Topics

114.3k
Posts