Fog Imaging Dell XPS 13



  • Has anyone successfully imaged Windows 10 to a Dell XPS 13? I can PXE boot, register, and upload an image but when I deploy the image back to the XPS, I get a Status: 0xc0000225 boot selection failed error and it appears there is no Windows installation.



  • I also wouldn’t call a RAW image a success. It’s more of a stalemate.


  • Moderator

    @paused Hey its great you got this worked out.

    From the FOG Project standpoint, I don’t think this is a success since you had to jump through many hoops to get a so-so results. But, since you are using fog 1.2.0 stable, I can understand why you are having issues. It would be interesting to see if you could spin up a new vm with fog 1.2.0 trunk on it and test again. My guess is that it will work correctly in efi mode, with gpt disks and win10.

    But anyway good going with your capture.



  • @george1421
    Re: Fog Imaging Dell XPS 13
    Thanks for everyone’s input. I managed to image this particular model.

    I had to put the laptop into legacy mode and create a RAW image to capture the GPT partitions properly. It took six hours to upload do but it imaged successfully.



  • @Sebastian-Roth
    The NIC is a Realtek RTL8153
    0_1460736259425_Screen Shot 2016-04-15 at 9.03.11 AM.png


  • Moderator

    @Tom-Elliott Interesting. bios boot to lay down a uefi image. Then I would have to ask what happened to the uefi boot files that were restored with bcdboot (open question)?
    The error code 0xc0000225 basically means it (the firmware) can’t hand of the booting process to the uefi boot files on the hard drive.

    Would this be a image capture or image deployment issue? Its too bad we don’t have a tool like ghost explorer or some way of mounting the image files to see what’s inside…


  • Developer

    @paused I tried to find out which NIC chip is in that USB NIC dongle but it seems impossible to get any detailed information. While you are in the debug shell, could you please run lsusb as well. Maybe we can find out more if we have the USB IDs. Thanks in advance!


  • Senior Developer

    @george1421 Network booting legacy mode while still using hdd boot in UEFI is 100% feasible. It’s probably simpler (at least from my programming mindset currently) that it actually DOES do this as I can much more simply program around the MBR methods than I can for UEFI methods.


  • Moderator

    Observation:

    I had to use the legacy boot to get it to PXE boot to undionly.kpxe.

    AND

    bcdboot C:\WINDOWS /s Z: /f UEFI.

    While I didn’t lookup this exact command but doesn’t it appear you are fixing the UEFI boot files, yet you imaged the system in bios mode? Not sure if this could be the issue where images in bios mode but the deployed image is uefi??


  • Developer

    @paused Your post made me read about the error code again. Possibly the BCD file we use is not working with your Dell XPS 13 device. Would you mind testing a full deploy again but use debug mode this time (schedule a deploy task as usual but just before creating the task tick “Schedule task as a debug task”). Start the deploy with the command fog and step through. When it’s done please run lsblk to show the partitions (take a picture and upload here) and see if you can find the windows boot partition - usually either a 100 MB primary partition or the boot files are within the windows system partition. Mount the partition like this and see if you can find the backup BCD file:

    mkdir -p /mnt
    ntfs-3g -o force,rw /dev/sda1 /mnt
    cd /mnt/Boot/
    ls -al BCD*
    mv BCD BCD.fog
    mv BCD.bak BCD
    cd /
    umount /mnt
    ...
    reboot
    

    Not sure if this will fix it for you but it’s a good try and we might learn from it. Is this a vendor pre-installed system or did you install windows from scratch? Just wondering why our BCD file would not work for you…



  • @Sebastian-Roth
    I used this USB type C NIC: https://www.cdwg.com/shop/products/Dell-network-adapter/3977707.aspx?enkwrd=470-ABND&pfm=srh

    I had to use the legacy boot to get it to PXE boot to undionly.kpxe.

    I was able to image a XPS with a Multiple Partition Image - All Disks but the device was reporting the error code 0xc0000225. I did manage to recover this by booting into a recovery disk and running bcdboot C:\WINDOWS /s Z: /f UEFI.


  • Moderator

    While I haven’t imaged any XPS 13 yet, I can say that if these are uefi firmware with gpt disks and deploying Win10 (more or less) you have the requirement to use the trunk build, since 1.2.0 stable doesn’t support the mentioned conditions very well at all.

    The other thing missing is what capture format did you use, single disk resizeable, single disk non resizable, raw??


  • Developer

    @paused FOG trunk would most certainly be the better choice for those “new” XPS devices. See here on how to upgrade: https://wiki.fogproject.org/wiki/index.php?title=Upgrade_to_trunk

    One of the first major steps is PXE booting the device and from what you said it seems like you already took that hurdle! Well done. Would be interesting for the project (wiki) and other users to know some more details of how you achieved to PXE boot:

    • USB NIC (exact type and model, possibly PCI IDs, see here)?
    • legacy BIOS or UEFI?
    • iPXE boot file (undionly.kpxe, ipxe.efi)?
    • kernel version (run command file /var/www/fog/service/ipxe/bzImage*)?

    That all said we can still try to make it work on FOG 1.2.0 - but no promises!! Can you please schedule a debug task for this device (Host -> Basic Tasks -> Debug) and run lsblk when you get to the shell. Best if you can post a picture here in the forums. Thanks in advance!



  • @Wayne-Workman

    I have Fog 1.2.0



  • What version of FOG?


 

441
Online

41.6k
Users

12.1k
Topics

114.2k
Posts