Registration and deployment problems



  • I inherited a fog system a few years ago that was working great, but unfortunately stopped work recently. Since the old server was version 0.32 I thought I would stick with the version I knew.

    I thought everything was setup nicely, but I am having some issues. Since I’m not sure if the issues are related I will try to describe them all here first then go from there.

    I am able to access the web UI and upload images to network location.

    The first issue i noticed was when I was trying to register a machine (when the old fog server went down I lost my hosts). I get something like “hdparm: ioctl 0x304 failed: Inappropriate ioctl for device.” I also tried quick registration which seems to work, but after the hosts appears in the web UI, it never restarts on its own. I have to shut it down manually.

    So I entered a few hosts manually in the web UI to see if I could at least deploy an image to them. Everything seems to work until the host gets to “Checking the queue” which it seems to do indefinitely (the longest I have waited it 6 mins).

    This occurs on a few different makes and models of PC’s we have. Any help is appreciated and I can provide more information.

    Thanks,
    Justus



  • Sorry for so many relies, seems to be an issue with mysql, after a restart of the service I’m able to log into the web UI.



  • After the 2nd install I rebooted the VM. When I try to go the web UI now it asks me update the schema, but when I do it fails. I think the database was already there and now there are issues. Since I have moved beyond my original question should I just start a new thread?



  • I restarted the install the fog files were missing. Seems to be good now…not sure what happened.



  • Its a 404.


  • Senior Developer

    @jcook Is it 404 or 500? There is a significant difference.



  • I have FOG 1.2.0 installed. I use to go to “myfogservername/fog” to access the UI. Now when I navigate there I get 404 not found. if i just go to “myfogservername” it gives me the it works message. Any thoughts?


  • Moderator

    @jcook VM is no issue. I run all of my fog servers as VMs.

    You can run fog 1.2.0 if you wish, or just install the FOG trunk version directly on the ubuntu system. I would recommend that you not upgrade but start with a fresh FOG system and then import your images. You will have to reregister all of your workstations. If you have a couple of hundred systems maybe we can work on an import process to save time. Its cleaner because of the differences between the two environments to just start over with a clean system.

    Make sure you allocate enough space for all of your images in the new environment. FOG itself doesn’t use any more (real) space. But your images and snapins do.



  • Thanks for the response, just wanting to make sure I get my ducks in a row before I got started. Once I have the server up and running I will report back.

    Thanks


  • Developer

    @jcook if you have images from a 0.32 install, they can work with newer versions of fog. you’ll just need to enable a couple legacy support settings. many of us run fog servers in VMs.



  • I think the easiest way might be a new install since what I have isn’t working anyway. Do you think my old images will still work? its not a big deal to upload new ones, just curious. I’m gonna try setting up a new VM with 14.04 and 1.2.0. Being a VM shouldn’t be an issue right?


  • Moderator

    Well I can say 0.32 is pretty old, and the 3010 is pretty new. I would suspect the linux kernels for 0.32 would not support the newer hardware (which the 3010 is part of). Actually I would think you would have NIC issues before hard disk controller problems just because of the age difference.

    How its possible that someone updated the FOS kernels (the operating system that runs on the target computer to capture and deploy images) on the 0.32 version of FOG so it would work with the newer hardware that is why the original server worked and the newly built server does not. I would bet this is a likely case and a possible solution for your issue. I can say I haven’t touched the older builds for many years so I can’t provide much help other than a direction.

    1. On that 3010 make sure it is running in legacy or bios mode and not uefi.
    2. Check to see what is the latest version of kernels that are supported under 0.32 (I don’t know this)
    3. Seriously consider spinning up a new FOG server running on the trunk build on Ubuntu 14.04 or newer. If you plan on imaging new hardware, uefi systems, gpt disks, windows 10 you will need to have the latest version of fog. Not even FOG 1.2.0 stable will do these things. So if you can tolerate a little instability upgrade to the FOG 1.2.0 trunk build, it will also make it easier for the mods and developers to support your installation. Other than one or two, not many remember that old environment. The other option is to wait until 1.3.0 is released later this year (I hope).


    1. I am actually still running 0.32. I haven’t tried 1.2.0 yet, but at this rate if that would help I would probably just do a fresh install.

    2. The PC’s I am working with right now are Dell Optiplex 3010. The previous fog setup worked with all the PC’s in the district so I was surprised when I started having issues.

    3. I worked with our switching vendor to change option 67 to this " 67 ASCII pxelinux.0" . DHCP is handled by an Adtran NetVanta 3140 if that helps.

    4. I used an older guide for the install of 0.32 which used Ubuntu 10.04 LTS.

    Hope that info helps, if more is needed just let me know.


  • Moderator

    Welcome to the FOG Forums.

    Lets collect a little more information on your issue.

    1. What version of FOG are you running? Are you using FOG 1.2.0 stable or a trunk build (i.e. pre 1.3.0 stable)?
    2. What is the manufacturer and model of the target computer are you trying to register.
    3. When you upgraded from 0.32 configuration to 1.2.0 did you make any adjustments to dhcp options 66 and 67? Could you post what your current values are?
    4. Since this is a new install, what OS is the FOG server running (may not be relevent to this issue, but its good to collect the details)?

Log in to reply
 

746
Online

38975
Users

10712
Topics

101675
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.