Windows 8.1 + FOG Server 1.2 revision 7001



  • When we choose Quick image & registration
    Computer reboot and hang on ucdhcpc
    Any idea ?


  • Developer

    @GreenItSolutions Great to hear that it’s working with a dump switch. Please let us know when you find the solution and explain it here for other people who might run into the same issue… Thanks in advance!


  • Moderator

    @GreenItSolutions The key fix (patch) with these issues is to just install a dumb switch between your building switch and the target computer. This will break down the errors either in the green ethernet, spanning tree (what I suspect here), or the auto detection speed. It crazy but sometimes dumb switches work best.

    I have no concerns that you will find the right setting to change on your 2960, I know for a fact they work with FOG once setup correctly.



  • @Sebastian-Roth Thanks, It works better.
    We have change the ‘Out of the box’ new Cisco 2960 by a “basic” switch and the problem doesn’t occur anymore

    We will work on the cisco 2960 configuration to change parameters you indicate.


  • Moderator

    Also it would good to know what hardware you are trying to pxe boot? Make and model and network adapter manufacturer (i.e. intel, broadcom, realtek, etc). At some time we were planning on creating a list of known troublemakers. Your device may need to be added to that bad actor list (no offense intended).


  • Developer

    @GreenItSolutions Usually this is due to an issue in your network setup. Your description is very brief but from what I read between the lines you get the FOG menu but when selecting options like “Quick image” or “… registration” the host hangs when trying to get an IP. For this you need to understand that for the client to show the menu it needs to request an IP via DHCP twice already (PXE boot ROM and iPXE)! So this is not a general DHCP/network issue but usually caused by:

    • Faulty patch cables (don’t laugh, we have seen this)
    • spanning tree (configure your client port to ‘port fast’!)
    • ethernet energy saving (disable EEE/802.3az on your switch if it has those!)
    • auto negotiation problems (configure to 100MiB or 1GiB fixed speed for this client port)

    If non of the methods help please give detailed description of what you tried and what happened. Otherwise we need to guess and go mostly wrong. As well tell us more about your client (model, NIC (PCI IDs!), …).

    Please report back if you could make it work. What exactly did you do? This will be useful for other users in the future.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.