FOGUpdater.sh is not compatible with the latest trunk



  • Hello again guys!

    On line 10 of the mentioned file above I found the following:

    [[ ! -f ${docroot}${webroot}config.class.php && ! -f ${docroot}${webroot}Config.class.php ]] && handleError "   No config file found" 4
    

    The updater is looking for the config file on /

    but the file in the latest branch is in /lib/fog/

    I changed the lines here and it worked just fine

    Okay maybe it needs some work I’m getting an error now :/


  • Senior Developer

    The updater script was never compatible with trunk. However, (drum roll please), it is now.

    You will have to update your sources first but all should work.

    Of note, I have a check to see if you’re trying to install trunk. If this flag is not specified it assumes you want the latest stable version. To keep trunk upgraded add trunk='yes' to the /opt/fog/.fogsettings file and you should be all set.



  • @Wayne-Workman Just trying to get this working, I have a couple other bugs to report but I’m no longer at my office now, I’ll get to bug-squashing tomorrow morning :)


  • Moderator

    I’m liking this guy already.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.