no default.ipxe



  • I updated my fog installation to the dev-branch to get LDAP support but apparently the new installation doesn’t have a default.ipxe file, Can I write one or get one from the source?



  • It only shows we need a lot more testing. I plan on hopping onto the Ubuntu/Debian wagon soon to bang out some tutorials and videos, but I’m busy getting a fog-dhcp plugin / service / interface put together.


  • Developer

    @Tom-Elliott said:

    derp guessing I was in systemctl mode thinking lol.

    I guess so… :-) Funny thing is that this was wrong for months and no one noticed. In earlier versions (before NYE) we even had sysvinit and systemctl mixed up…

                chkconfig $dhcpd on >/dev/null 2>&1
                service $dhcpd restart >/dev/null 2>&1
                sleep 2
                systemctl status $dhcpd >/dev/null 2>&1
    

    :-D



  • @Sebastian-Roth yay contributing! Thanks guys! It’s working now


  • Senior Developer

    @Sebastian-Roth derp guessing I was in systemctl mode thinking lol.

    Fix coming shortly.


  • Developer

    @jdmg94 I think you found a bug which nobody has noticed for quite some time… see my patch - I guess you can add this yourself and let the installer run again!

    @Tom-Elliott (untested) patch proposal:

    diff --git a/lib/common/functions.sh b/lib/common/functions.sh
    index 7f9347f..2aaea23 100755
    --- a/lib/common/functions.sh
    +++ b/lib/common/functions.sh
    @@ -1878,7 +1878,7 @@ configureDHCP() {
                                 sleep 2
                                 service $dhcpd start >>$workingdir/error_logs/fog_error_${version}.log 2>&1
                                 sleep 2
    -                            service status $dhcpd >>$workingdir/error_logs/fog_error_${version}.log 2>&1
    +                            service $dhcpd status >>$workingdir/error_logs/fog_error_${version}.log 2>&1
                                 ;;
                             2)
                                 sysv-rc-conf $dhcpd on >>$workingdir/error_logs/fog_error_${version}.log 2>&1
    

  • Developer

    @jdmg94 Should be dhcpd for CentOS, see in lib/redhat/config.sh (second line from last).



  • @Wayne-Workman

    no worries I checked the error log, and it may have been a typo the error is the following:

    
    
    Starting dhcpd: ^[[60G[^[[0;32m  OK  ^[[0;39m]
    status: unrecognized service
    
    

    so I’m assumming someone typed

    sudo service **dhcp** status
    

    instead of

    sudo service **dhcpd** status
    
    

    I’ll check the install script and get back to you guys.



  • @Sebastian-Roth said:

    @jdmg94 From the screenshot we see that the installer did not finish properly. It failed on setting up DHCP.

    Wow how’d I miss that? lol. Today has been a very looong day.


  • Developer

    @jdmg94 said:

    I’m a developer as well and I really like this project

    You are more than welcome to join the team! There is no obligation. Start with helping to answer questions in the forums and feel free to work on the code as well if you like. Just let us know.

    Regarding your DHCP server setup problem… check the error logs. Should be in the directory you called the installer from (current working dir when running installfog.sh)!

    default.ipxe looks like this (change to match your IP!):

    #!ipxe
    cpuid --ext 29 && set arch x86_64 || set arch i386
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    param platform ${platform}
    param product ${product}
    param manufacturer ${product}
    param ipxever ${version}
    param filename ${filename}
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    :bootme
    chain http://192.168.1.1/fog/service/ipxe/boot.php##params
    

    But I am sure you will see other issues as the installer is not finishing properly (still missing after the DHCP stuff: configureTFTPandPXE, configureFTP, configureSnapins, configureUDPCast, installInitScript, installFOGServices, configureFOGService, configureNFS - you don’t wanna do this all by hand…)



  • @Sebastian-Roth Hey Sebastian, Thank you for your reply, I tried setting the ip addresses as you said but dhcp keeps giving me a “Failed!” message even though when I check the service status its running and no default.ipxe yet, is there a way for me to write it by myself?

    I tried uninstalling dhcp as well with the same results

    0_1459374213425_Capturef4.PNG

    PS: I’m a developer as well and I really like this project


  • Developer

    @jdmg94 From the screenshot we see that the installer did not finish properly. It failed on setting up DHCP. TFTP (directory) and default.ipxe would be populated/generated after that.

    Check your /opt/fog/.fogsettings file (maybe you already deleted the old one that was causing the trouble) and make sure the option dnsaddress (and routeraddress) is set to a proper IP address. We sometimes see things like `dnsaddress=‘option domain-name-servers x.x.x.x’ which will cause the exact error you saw.



  • @Wayne-Workman I remember I didn’t even had a /tftpboot folder when I went from stable to dev-branch so I created it and copied the contents on the “fogproject-dev-branch/packages/tftp” folder

    edit: I followed the uninstall guide here before moving to dev-branch and did a clean install



  • @jdmg94 Shouldn’t be. I’m on Fedora 21 and the same version as you, and I have /tftpboot/default.ipxe

    Do you have SELinux turned off?



  • @Wayne-Workman I updated my installation to the newest, but I still get no default.ipxe

    maybe it’s creating a folder elsewhere?

    0_1459368204115_Capturef2.PNG



  • @jdmg94 Update again. Your 4 revisions behind at the moment.

    But, I’m not sure why the file isn’t there… @Tom-Elliott ideas?



  • @Wayne-Workman said:

    @jdmg94 You checked inside of /tftpboot ? It’s there, I promise.

    What’s the revision number you’re on? It’s the number in the cloud, top left.
    What Operating System?

    I checked in there as well but no luck, I’m using build 7001 on CentOS 6.7

    0_1459367531362_Capturef.PNG



  • @jdmg94 You checked inside of /tftpboot ? It’s there, I promise.

    What’s the revision number you’re on? It’s the number in the cloud, top left.
    What Operating System?


 

402
Online

41.8k
Users

12.3k
Topics

116.1k
Posts