Host Registration failed. (tftp://x.x.x.x/default.ipxe.. Connection timed out error)



  • 0_1458755495108_f9c1cdcb-cc58-4e74-a9eb-4ce14d177a2f.jpg

    In dhcpd.conf file I have option routers ip address 192.168.1.1, and next server as 192.168.1.159 (FOG server)

    When I am trying to register host (Win 10) I am getting this error. You can view there is conflict in DHCP addresses (Fog server ip address , option router ip address). For your info, Both systems are connected to a switch with same router.

    0_1458755546654_3ab51711-cbee-4d22-aa82-de8ff6663f98.jpg

    Please Help.


  • Senior Developer

    @Satya because this is a consumer grade router is there any special configurations on it doing special things? If not there usually is a reset button on the router that will allow you to reset to the factory defaults. What the sequence of doing so is would require the manual of the device which you can find online.



  • @Tom-Elliott I Tried those default login credentials. But no use


  • Senior Developer


  • Senior Developer

    @george1421 said:

    192.168.1.1

    Aside from the default router info, have you just tried:

    admin
    admin



  • It is the issue with DCHP address conflict, you all figured out that. I manually turned off the DHCP in my client system and try to run the FOG registration.

    This time it was taking the correct IP address, but in less than a second it swinging through FOG registration options page and rebooting.


  • Moderator

    Its a shame that he doesn’t have the password for the Asus RT-N53, because he could load DD-WRT on it and get rid of that cruddy firmware and put the power of a linux variant on his router. Then he could use the dhcp server under dd-wrt.


  • Moderator

    @Sebastian-Roth said:

    Had a long and winding chat session and turns out that he cannot disable DHCP on the router (Asus RT-N53) because he does not have login creds to it.

    It should have a reset button on the back, if you hold it in long enough while the device is powered on, the device should restart with all defaults loaded. Then, it’s a matter of using Google to find the default credentials.


  • Developer

    @Wayne-Workman you are absolutely spot on here! Good man! Had a long and winding chat session and turns out that he cannot disable DHCP on the router (Asus RT-N53) because he does not have login creds to it. I found out that when iPXE is using the “wrong” next-server info it has ‘filename’ blank. This is because those stupid home routers only send option 66! So I came up with a quick fix to check if filename is set and loop back to get DHCP info again if it’s blank. The loop is working fine for Satya but it seams to loop forever… too bad. I really hoped that this could be a solution for those home router issues.


  • Moderator

    @george1421 @Satya

    Actually, We’ve seen this before. Normally it’s because of home routers that give their own IP address for option 066. Is your home router running DHCP? If so, turn DHCP off for that and try again.


  • Moderator

    OK just for clarity here.

    1. You are using your FOG server as a dhcp server.
    2. That fog server is at 192.168.1.159
    3. Your default router is 192.168.1.1

    I can see that dhcp is working perfectly. How do I know this? Because I see the iPXE kernel and splash screen.

    As iPXE is loading it receives a dhcp address. So this is working great.

    The issue is something is giving your ipxe kernel the address of 192.168.1.1 instead of the fog server address of 192.168.1.159. That is why you are getting a connection timeout.

    Make sure you don’t have a DHCP proxy server running someplace giving out a bad next server value.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.