Image not moved from /images/dev, no errors (Ubuntu 14)



  • Hi there,

    I have the following setup:

    Ubuntu 14.04, with FOG 1.2.0 (downloaded from https://sourceforge.net/projects/freeghost/files/) on DELL Notebook
    Windows 7 32 bit running on DELL Notebook

    Machines connected via crossover cable.
    FOG controller is running on 192.168.2.1, Windows machine has 192.168.2.2

    I have created an image and a host in FOG.
    I start an image upload.
    The image gets uploaded, but stays in the folder /images/dev/{MAC}.
    There is no error message at all during or at the end of the upload.

    Image management shows size on client is 5.7 GB, 0 GB on server.
    Downloading the image fails.
    If I move the files from /images/dev/{MAC} to /images/{name of image}, the download works (but image size shown in management console is still 0 GB).

    I have tried all of the things here: https://wiki.fogproject.org/wiki/index.php/Troubleshoot_FTP#Permissions and here: https://wiki.fogproject.org/wiki/index.php/Troubleshoot_FTP#Credentials_.2F_Passwords
    I.e. I have set ownership of images recursively to fog:root and set credentials to “fog” and “password” everywhere.

    I can ftp from the Windows machine to 192.168.2.1, mkdir and rename etc. work.

    So it seems to me that the ftp mkdir and move commands are not executed by FOG at all during the upload.

    I have also tried the following: Created an XP VM in Virtualbox and uploaded image to FOG, same problem.

    Is there possibly a bug?
    Is it possibly related to Ubuntu 14?

    Here are my /opt/fog/.fogsettings by the way:

    Created by the FOG Installer
    Version: 1.2.0
    Install time: Fre 18 Mär 2016 14:28:10 CET

    ipaddress=“192.168.2.1”;
    interface=“eth0”;
    routeraddress="# option routers x.x.x.x;";
    plainrouter="";
    dnsaddress="# option domain-name-servers x.x.x.x; “;
    dnsbootimage=”";
    password="";
    osid=“2”;
    osname=“Debian”;
    dodhcp=“y”;
    bldhcp=“1”;
    installtype=“N”;
    snmysqluser="“
    snmysqlpass=”";
    snmysqlhost="";
    installlang=“0”;
    donate=“0”;
    fogupdateloaded=“1”

    Regards,
    Benjamin



  • @Sebastian-Roth thanks I figured it out .


  • Developer

    @robe2conoby Please open a new topic and post all the details of your setup there. FOG version, OS (version), related settings, things you tried, URL of instructions you followed, picture of the error screen…



  • I am having these same issues with 1.2.0 on ubuntu 12.4 lts . I followed the instructions for the ftp images stuck, added the passwords now it fails at tftp. I could get past this before adding the passwords ,but would have to move the image manually to the folder .


  • Moderator


  • Moderator

    @Sebastian-Roth said:

    Hmmm, not sure if this might still be an issue in FOG trunk. I guess we don’t test interface other than eth0 very often. Do you mean, even telling the installer to use eth1 (for example) will set eth0 in storage management interface setting??

    It’s fixed in fog trunk. And he’s talking about the interface that is stored in the DB for the default storage node that gets created at install.



  • @Sebastian-Roth No, telling the installer to set default interface to eth1 does not affect the interface in storage management.


  • Developer

    @abulhol Thanks for reporting back! I added that hint to the wiki article.

    I have also tested whether changing the interface during install process (“Would you like to change the default network interface from eth0?”), but this has no effect on the setting in storage management.

    Hmmm, not sure if this might still be an issue in FOG trunk. I guess we don’t test interface other than eth0 very often. Do you mean, even telling the installer to use eth1 (for example) will set eth0 in storage management interface setting??



  • Hi again,
    I can report the following:
    At least in my case, the whole problem lies in the “interface” setting in “Storage management”. If this is not set to the interface corresponding to the interface where FOG web console is running, the image will not be moved from dev.
    It has nothing to do with the permissions or credentials.
    In particular, permissions created by FOG are 777:

    myuser@mypc:~$ ll /images/
    total 20
    drwxrwxrwx  5 root root 4096 Mär 21 10:00 ./
    drwxr-xr-x 28 root root 4096 Mär 21 09:22 ../
    drwxrwxrwx  2 root root 4096 Mär 21 10:00 dev/
    drwxrwxrwx  2 root root 4096 Mär 21 09:48 Image1/
    -rwxrwxrwx  1 root root    0 Mär 21 09:22 .mntcheck*
    drwxrwxrwx  2 root root 4096 Mär 21 09:22 postdownloadscripts/
    

    so no need to change the linux password for fog user.

    I have also tested whether changing the interface during install process (“Would you like to change the default network interface from eth0?”), but this has no effect on the setting in storage management.

    If this is fixed in FOG 1.3, that’s fine, but please also add this troubleshoot to https://wiki.fogproject.org/wiki/index.php/Troubleshoot_FTP#Images_stuck_in_.2Fimages.2Fdev

    In any case, thanks for your help!
    Benjamin


  • Moderator

    @abulhol Normally they are set by the installer on a fresh installation of 1.2.0. That said, 1.2.0 was imperfect in many ways. Stable - but imperfect. FOG Trunk (which is what will be 1.3.0 eventually) fixes all these issues. Also, no fog installer will ever just change what you have set in the DB, fog assumes the admin knows best. and in storage management, all the stuff in there is stored in the DB.



  • @Wayne-Workman Thanks for the fast reply!
    I had really set all the passwords correctly, but as I then noticed, the Interface in “Storage Management” was set to eth0, while actually 192.168.2.1 is assigned to eth1. So after I changed “Interface” to eth1, it looks like everything works now.
    I guess I should have chosen “Yes” for “Would you like to change the default network interface from eth0?” during installation.

    Yet, regarding the permissions and password issues - why are these not set by FOG directly during installation?
    When I checked these, I noticed that the password was empty for TFTP in the FOG Settings, and the Linux fog user had a different password as well (not “password”). Is there a specific reason why these are not set to the default values as well?

    Benjamin


  • Moderator

    Well, 1.2.0 hasn’t changed since it was released. And many folks are running it on Ubuntu 14. It’s most likely credentials related. Did you actually reset the local fog user’s password in Ubuntu’s OS via CLI?

    Also, the IMAGE Size on server field is dependent on FTP as well. If your manually moving it but it STILL cannot see the size, then it’s your ftp credentials.

    Please go through the credentials and passwords area of that wiki article again.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.