All know hosts show as pending when a new host shows as pending.



  • I have a script that @Wayne-Workman wrote, that shows pending host as they come in. I noticed that when a host comes in as pending…all previously accepted/known hosts show as pending as well. When I manually add the host from the list in the log output from said script, all host disappear from pending and all looks as it should.

    18/03/2016 10:54:02
     
    Pending Hosts:
    3557	dmNew1
     
    Number of Approved Hosts:
    1756
     
    Number of Total Hosts:
    1757
     
    Number of Total MAC addresses:
    3558
     
    uptime Output:
     10:54:02 up  2:11,  2 users,  load average: 1.00, 1.26, 1.40
    

    I reset the encryption keys after deleting all hosts and adding again from the old database backup from 6549.

    the host dmnew was manually set to pending, which shows correctly; however all hosts without a key are showing back up under pending hosts. This has happened since updating to 6777 from 6549. and now I’m currently on 6815.

    When I accept the pending hosts listed from output of script, all goes back to normal



  • @Tom-Elliott thanks to you and Mr. Workman…I would have had no way to know which host was showing as pending if it wasn’t for his script.


  • Senior Developer

    @Hanz Based on my finding, everything was working fine.

    Number of MAC’s 3558 (I’m guessing there’s two macs that were added for dmNew1 host).

    Number of approved hosts = 1756.

    Number of Total hosts = 1757.

    Based on that, (1756 Approved + 1 Pending) = 1757. Is this incorrect?


  • Senior Developer

    Confirmed, Found, Fixed, and pushed (ONLY THE PART WHERE CLICKING PENDING HOSTS SHOWS ALL HOSTS).

    THey should not all show up as pending though. This was a mistake in coding. I copied a prior entry (in the search area) to the pending area and forgot to make the change as necessary.


 

458
Online

41.9k
Users

12.4k
Topics

116.7k
Posts