SOLVED Multiple disks, I only want one fogged

  • Hi all,
    First of all, I want to thank the community for the work done.
    I expose now my problem with a special configuration I have.
    I use the 1.2.0 stable version.

    I use FOG for a while with a hundred computers (single disk) whitout problem.
    For some of then I decided to put SSD disk in sda place and the old disk in sdb

    sda is the disk whith the system I want to fog.
    sdb id a disk that contain data that I dont whant to fog.
    So I choose the “multiple partion - single dist” option for the image definition.

    When I upload the host, it’s the correct disk that is uploaded (sda).
    When I download to an other host, it restores on sdb.

    In the /image/host folder I have the right d1.mbr, d1p1.img and d1p2.img files that compose my sda disk.
    Even if I restore on the same computer (same disks plugged in the same way)

    I hop the explanation was clear,
    Thank you for the help

  • Moderator

    @cortoM This might be solving it for you but it actually really just a quick hack. If you are still keen to find out why FOG is choosing the wrong device on your system we need more information. See Wayne’s and my previous post.

  • @Sebastian-Roth
    So I put explicitly /dev/sda in “Host Primary Disk” field and run a restore task on the same host.
    It seems to be ok.
    The solution seems to set this field to /dev/sda.

    Thank you Sebastian, I hadn’t notice this field (I didn’t need to date 🙂 ).
    And thank you all.

    I think I can set the post to “solved”.

  • It could also be something simple like a flash drive being plugged into the computer, or how Linux might be seeing a hybrid drive that has both SSD and Mechanical mixed. There may even be a small SSD soldered onto the board that is throwing it off.

    What model is this computer, exactly?

  • Moderator

    @cortoM said:

    What I suppose to set in it ?

    No! Just asking if you did - maybe put /dev/sdb in there? Please double check that you don’t have anything set in that field. Well, on the other hand you can try forcing FOG to use sda by setting “Host Primary Disk” to “/dev/sda” (without the quotes) - which it should by default anyway.

    If that does not work, can you please boot the client in debug (Host -> Basic Tasks -> Debug) mode and run the following command: fogpartinfo --list-devices (let us know what exactly you see - take a picture or copy&paste the text)

  • @Sebastian-Roth
    Yes right, I don’t put anything in that field…
    What I suppose to set in it ?

  • Moderator

    @Wayne-Workman Yes it does (for multiple partion - single disk)!

    @cortoM Anything in the hosts’ “Primary Disk” setting field?

  • Does 1.2.0 stable use the format d1p1 and d1p2 ?

  • @Tom-Elliott
    Yes, it appends exactly as mentioned in your last sentence.
    When I upload, partclone shows /dev/sda and when I download (on the same host) it shows /dev/sdb

    Thank you

  • Moderator

    @cortoM I think you explained well what’s going on. At least I think I get it. But I really wonder why FOG (1.2.0) would deploy to sdb?!? I had this kind of setup (two disks but only want sda) running in one of my labs and I am pretty sure it always worked with FOG 1.2.0! Please check if you have set “Host Primary Disk” for the host in question!

  • So, from what I’m gathering, FOG is imaging only one disk, it just so happens to NOT be the disk you’re expecting it to be?

    Are you sure they’re plugged in the same? Meaning it knows that /dev/sda IS the SDA on EVERY system? When partclone is putting the image back on the disk it’s showing as /dev/sdb?