Fog Installation failed. (Backing up database.. Failed!)



  • Using: OS - Ubuntu 14.04.4 & Fog Truck (GIT)

    Tried changing no_proxy=“localhost” in bashrc file. And changing in $ipaddress to localhost in installfog.sh file,
    at wget link similar to "http://localhost/$webroot… ". Still facing same issue.
    Error Log:
    http://x.x.x.x/fog//management/export.php?node=schemaupdater
    Connecting to x.x.x.x : x… connected.
    HTTP request sent, awaiting response… 500 Internal Server Error
    ERROR 500: Internal Server Error.

    Is this the issue with proxy server ? Please help !
    Thanks



  • Hey All, the issue was resolved. Its the problem with php.ini -> time zone not set. After going through same problem & solution in other thread - tried the same. Set the time zone and removed leading ;

    This successfully completed the schema update and installation.

    Thanks for your great help guys!


  • Senior Developer

    Please retry updating and running.

    I’m making many switches to use closures. Closures, in php land, are not allowed to be serialized (which is how the sql/sqldump, and reports are done. Build the class, serialize the object, send the data out.)

    I didn’t know this, but I have double checked things and all appears to be working well. The class handling the dealing out of files really didn’t/doesn’t need to extend a pre existing class as it really only does one (okay maybe two) thing at a time. There was exactly one method that FOGBase passed to the report maker.

    The fix, remove the extend and adjust that one extend needed item to still operate properly.

    TL;DR;
    I didn’t know closures couldn’t be serialized. This caused anything using a serialized form of the relevant object to fail out. It should now be fixed.


  • Moderator

    @Satya said:

    And changing in $ipaddress to localhost in installfog.sh file,

    I think that would cause issues. Have you tried just running the installer as it is without modification?


  • Developer

    From what I can read between the lines this is not a proxy settings issue! Please see if you have any messages in /var/log/apache2/error.log and let us know.


  • Moderator

    Can you please post a screen shot of the exact error. There may be important messages on either side of the error that may help finding the root of the issue.

    If your fog server has direct internet access then the no_proxy setting does not matter here.

    I do remember a current thread about a similar issue when the backup was failing. But i think that was an upgrade not a fresh install.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.