tsc : Fast TSC Calibration failed



  • I am getting this error message on machines which are newer model (6th Gen Processors) while doing Full registration and inventory. After which it gives unable to register host error. I am getting this message for FOG 1.2.0 while it works perfectly fine for FOG 1.3.0 Beta.


  • Moderator

    @Rich-C Tom has also been telling us the newer trunk kernels will work with 1.2.0 stable. So if you backup your current kernels you can download the latest trunk version using the following commands on your fog server. Just navigate to /var/www/html/fog/service/ipxe , rename the files and then execute these commands.

    sudo wget https://fogproject.org/kernels/bzImage
    sudo wget https://fogproject.org/kernels/bzImage32

    These kernels are 4.5.3 as of today.

    I do have to say my personal recommendation is to just upgrade to the trunk release to take advantage if the new features (as long as you can tolerate a little instability of the dev releases).


  • Developer

    @Rich-C As you can see here support for the 8086:156f NIC has been added to the main line kernel in version 4.1. So it should be included in Tom’s 4.1.2 kernel as he is building from the official sources.

    As we have seen really odd network issues in the last months I keep asking people to use a dumb mini switch to connect between your client and the network. This way the link will stay up even if things like spanning tree, auto-negotiation or ethernet energy saving are (miss-)configured. Please give it a try and let us now.



  • @Sebastian-Roth First - huge fan of FOG. Has been a big improvement for my organization and managing a multi-site office. I have tried the suggestion made below and selected different Kernels the one I selected as I believe it made the most sense:

    Kernel - 4.1.2 TomElliott Date : July 22, 2015 Version : 4.1.2 FOG Type: TomElliott Arch Type: (x86_64)

    While the initial message went away the machine still did not register.

    Please see the listing from the NIC cards PCI IDs:

    PCI\VEN_8086&DEV_156F&SUBSYS_223317AA&REV_21
    PCI\VEN_8086&DEV_156F&SUBSYS_223317AA
    PCI\VEN_8086&DEV_156F&CC_020000
    PCI\VEN_8086&DEV_156F&CC_0200

    The client machine type is a Lenovo T460s Ultrabook.Both CPU & OS are 64- Bit.


  • Developer

    Well then I think you need to go with FOG trunk! Why wouldn’t you anyway? The problem is that the network startup script was not very robust in FOG 1.2.0. A newer kernel is needed for some NICs but that’s not the only thing. Some NICs are kind of picky when it gets to starting it up and getting an IP. We won’t fix FOG 1.2.0 but if FOG trunk is working for you why bother using FOG 1.2.0??



  • @Sebastian-Roth In compatibility test Network Adapter - fails. It is Lenovo M800 Model with Intel Ethernet Connection I219-LM (Jacksonville). I replaced newest kernel 4.5.0 but still same error. Unable to register host for the following reasons:


  • Developer

    Is it a 64 bit CPU you are trying this on? bzImage is for 64 bit systems. Otherwise you need to replace bzImage32 as well! Tried the “compatibility check” yet??

    We need more information to be able to help you! What kind of client machine is this? Which NIC does it have? Best if you can give us the PCI IDs of the NIC (Windows device manager or Linux Live CD running the command lspci -nn | grep Ethernet).



  • I replaced the bzImage file from 1.3.0 beta to 1.2.0 but still giving Unable to register host message… Is there something I am missing?


  • Developer

    @chetansays This error is not causing any problem! I see it on my clients all the time. Check the internet if you want to know what this is about.
    The problem that clients can register in FOG trunk but not with FOG 1.2.0 is most probably related to the different kernel versions! See in the web interface (FOG Configuration -> Kernel update). Older kernels probably don’t have a driver for the NIC in your newer model machines.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.