client computer reboots in pxe while adding nic



  • I’m in a school district with five sites. I have fog imaging working across all the networks but one. In our Jr. Hi, my client computer will grab an ip, and start to boot with pxe, but fails during the network adapter configuration- ending with the machine rebooting itself. Confirmed with 3 different models of computer, and tested on all physical segments AND directly on each MC switch.

    I’m not doing the network admin here, but all I can tell you is that our aruba controller and switches are “supposed” to be configured the same as our other four sites. The only difference I can see, is that our non-DC server at the Jr. Hi has 3 nics bridged (reason unknown).


  • Developer

    @scott45426 Thanks for you answer. We are more than happy to help even if it’s not a “FOG issue”. :-) Please let us know when you (your colleges) found out what’s causing this in your setup. The information will help other users in the future. I am marking this solved for now.



  • @Sebastian-Roth Well, the spanning tree reset did not work- and I’m pretty sure this is an internal problem with us having to do with switch configuration or how our vlan structures are set up. Thanks very much for your tips, I’m confident we have fog set up and working properly- only this one remote site has a config that we need to find and fix. Cheers guys and happy Friday!


  • Developer

    @scott45426 As a quick fix you can always try to connect a small dump office switch between and see if DHCP is working then. If yes, I suppose it’s a spanning tree problem (newer versions of iPXE are better at handling this). I think you should be able to use newer iPXE binaries with your FOG 1.2.0 server. Backup your currently used iPXE binary (you use undionly.kpxe I suppose) and download the most current one here. Give it a try and let us know.



  • @Sebastian-Roth Thank you for your response- we were short handed at work yesterday and I was hopping… Our admin is going to clear the cache on the switch tonight after faculty is done, and we’ll give 'er another shot!


  • Developer

    @scott45426 Ahhh, now I see… this is version 1.2.0 and the embedded iPXE script we used back then just rebooted when it could not get an IP via DHCP.

    PXE ROM is able to get an IP but not iPXE…?! Possbily a spanning tree issue?




  • Developer

    @scott45426 said:

    but fails during the network adapter configuration- ending with the machine rebooting itself

    As Wayne already said, could you please upload a picture/video of when exactly things seam to go wrong. From what I can read between the lines it sounds like the machines’ PXE ROM is grabbing an IP properly. The next step would be downloading an iPXE binary via TFTP. Does this work. I guess you are seeing an issue when it says “iPXE initialising devices…”?! But then - reboot? On different models? Sounds really strange.



  • @Wayne-Workman I’ve tried at our Jr. Hi site on many different machines, locations (and cables).
    DHCP gets an address, opt66 / 67 are correct with server ip and boot file name.

    iPxe initializing devices…ok.
    Configuring (net0… reboot.
    our adapters are pretty generic, you know- intel, realtek. The machines are a mixture of several years old, to brand new.

    I completely realize this is probably not a “Fog” issue, but was hoping someone may have encountered the same problem as I am having.



  • Simple things first. Try a brand-new patch cable.

    Past that, can you provide us a photo (or video) of the error you’re seeing just before the machines reboot?


 

503
Online

41.6k
Users

12.1k
Topics

114.4k
Posts