ipxe issue 3c126



  • Hello all,
    I’m new in this world and I’m trying to play with fog server

    I’m on ubuntu 15.04 where I uses virtualbox 5.0.14
    Fog server is on a virtual machine centos 6 and my client aswell and they are on the same network.

    each VM have the following configuration:
    Host-only adapter ( same network)
    adapter type: intel pro/1000 mt Desktop (82540em)

    My issue is the following:
    when my client ( vm) is starting the ipxe gives me the following error: tftp://xx.xx.xx.xx./undionly.kpxe. Operation not supported( http://ipxe.org/3c126003)

    The dhcp function correctly because I can see that on the client side, the net0 receives an IP address
    that the option 66 and 67 are correctly configured because I can see that if I change the filename, the client side tries to interact with the file
    also, the /tftboot/default.ipxe contains

    #!ipxe
    cpuid --ext 29 && set arch x86_64 || set arch i386
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    :bootme
    chain http://xx.x.x.x/fog/service/ipxe/boot.php##params

    So I’m lost, I don’t understand what’s wrong.

    In advance, thank you for your feedback
    Best,


  • Developer

    @kortnor Thanks for letting us know! From what I can read between the lines you’ve changed A LOT of things and now it is all working. Unfortunately we won’t be able to find out what was casing your initial problem. Seams like you just solved it by re-installing… I am pretty sure this was some kind of permission problem (maybe tftp daemon started without the --secure optione?!? I don’t know!).

    NFS has nothing to do with FOGs PXE bootup! (Just for you to know)



  • @Sebastian-Roth

    Hello Sebastian,
    I arrive to dl the kpxe file from a remote host hereunder the information related to that

    [root@pla pla]# tftp -v 10.10.0.15 get undionly.kpxe
    Usage: tftp [-4][-6][-v][-V][-l][-m mode] [-R port:port] [host [port]] [-c command]
    [root@pla pla]# tftp -v 10.10.0.15 -c get undionly.kpxe
    Connected to 10.10.0.15 (10.10.0.15), port 69
    getting from 10.10.0.15:undionly.kpxe to undionly.kpxe [netascii]
    Received 103273 bytes in 0.1 seconds [10486699 bit/s]
    

    for you information, I’ve migrate my vm to centos 7 and arrive to interact with a distant host. meaning by that I almost fully complete the task upload an image from a laptop in my network with the fog 1.2.0 server installed in the vm which has the ip address 10.10.0.15.

    I’ve an issue related to this but I’m currently on it : https://forums.fogproject.org/topic/4540/fogftp-login-failed/24

    EDIT

    WTF, it function now, its not understandable… I had seen during the weekend that my nfs-server wasn’t up and running BUT I hardly believe that’s the reason why the pxe didn’t wanted to work.
    I’ve also changed something important I must say, during the weekend, I passed from Ubuntu 15.04 to Fedora 23. It might be the reason because they provide the newer version of virtual box which is 5.0.16

    Anyway thank you for your help. I must say I’m impressed about the reactivity of the forum.


  • Developer

    @kortnor That’s interesting! In the PCAP file I see error code 5 (permission denied). But the file listing of /tftpboot you posted looks ok! Can you please try loading that undionly.kpxe file using a tftp command line client: https://wiki.fogproject.org/wiki/index.php?title=Troubleshoot_TFTP

    And there is one thing I am wondering about. In your earlier posts the FOG server IP used to be 10.10.0.5 but now in the PCAP file it’s 10.10.0.15…?! Did you change it?



  • @Sebastian-Roth
    you’ll find in attachement the requested pcap.file document
    0_1457874891586_file.pcap


  • Developer

    @Wayne-Workman I have started writing bits and pieces about virtualizing FOG setups and I think I’ll get into virtualbox as well soon! Anyone else here who is using it actively (I am not right now) and is happy to share his knowledge - please get in contact with me!!


  • Moderator

    @Sebastian-Roth absolutely no offense to the OP but I say this as sincere as I can be, I wish someone who knows what they are doing would make a tutorial on how to use virtualbox with fog. And I only ask because we keep seeing these problematic virtualbox threads over and over.


  • Developer

    @kortnor chainloading boot.php is failing because the kind of minimalistic iPXE that comes with VirtualBox does not include things like cpuid and color that we use in our iPXE scripts. But as we can see in the displayed banner on the screenshot it should have TFTP support (I am sure it has!).

    From the iPXE source code to me this looks like the TFTP server is sending back an answer (so this is not a network connection issue) but the code sent back is what makes iPXE unhappy! Is this the TFTP server installed by the FOG install script or do you use a different one?

    Add dumping network traffic to the client VM (https://www.virtualbox.org/wiki/Network_tips) and start it up. After you see the error in the client VM shut it down. Please upload that PCAP file to the forum here and I’ll have a look what TFTP error code this is.



  • @Tom-Elliott
    Just tried and its the same exact error except he tries with the ipxe.pxe

    Edit: I also tried trough the client side and its the same
    meaning by that I do the following steps in the ipxe shell command
    dhcp
    chain tftp://10.10.0.5/ipxe.pxe
    ==> opretion not supported
    chain http://10.10.0.5/og/service/ipxe/boot.php
    ==>cpuid command not found
    ==>color : command not found
    ==>could not boot: Exec format error (http://ipxe.org/2e022001)


  • Senior Developer

    @kortnor Because this is virtual box, can you change your boot file from undionly.kpxe to use ipxe.pxe



  • Hereunder the printscreen of the vm
    0_1457700935602_vm.jpg

    ls -al /tftpboot
    drwxrwxrwx. 2 fog root 4096 11. Mär 13:51 .
    dr-xr-xr-x. 25 root root 4096 11. Mär 13:02 …
    -rwxrwxrwx. 1 fog root 840 11. Mär 08:43 boot.txt
    -rwxrwxrwx. 1 root root 291 11. Mär 08:43 default.ipxe
    -rwxrwxrwx. 1 fog root 389009 11. Mär 08:43 ipxe.kkpxe
    -rwxrwxrwx. 1 fog root 389057 11. Mär 08:43 ipxe.kpxe
    -rwxrwxrwx. 1 fog root 388044 11. Mär 08:43 ipxe.krn
    -rwxrwxrwx. 1 fog root 389073 11. Mär 08:43 ipxe.pxe
    -rwxrwxrwx. 1 fog root 25340 11. Mär 08:43 memdisk
    -rwxrwxrwx. 1 root root 16794 11. Mär 09:42 pxelinux.0
    -rwxrwxrwx. 1 fog root 16794 11. Mär 08:43 pxelinux.0.old
    -rwxrwxrwx. 1 fog root 165088 11. Mär 08:43 snponly.efi
    -rwxrwxrwx. 1 fog root 101989 11. Mär 08:43 undionly.kkpxe
    -rwxrwxrwx. 1 fog root 102037 11. Mär 08:43 undionly.kpxe
    -rwxrwxrwx. 1 fog root 382650 11. Mär 08:43 undionly.kpxe.INTEL
    -rwxrwxrwx. 1 fog root 102053 11. Mär 08:43 undionly.pxe
    -rwxrwxrwx. 1 fog root 147728 11. Mär 08:43 vesamenu.c32

    thank you for your time


  • Developer

    @kortnor Can you please post a picture/screenshot of the error (whole screen!). I am not absolutely sure at what stage this is failing. From what I can ready between the lines this is the first iPXE (as VirtualBox uses iPXE as PXE ROM) trying to load the FOG iPXE binary (undionly.kpxe). But I might be wrong.

    The error links that are printed by iPXE are sometimes quite helpful. Check it out. This one says:

    This error indicates that the operation was not supported by the TFTP server. Some TFTP servers return this error to indicate that the requested file was not found.

    What do you see when running this on your FOG server? ls -al /tftpboot



  • @Quazz
    IPV4 address: 10.10.0.1
    ipv4 Network 255.255.255.0

    DHCP disabled ( on the host-only network detail)

    I just tried and changed the client and server to bridge Adapter and it remains the same issue.
    However I can clearly see that the client receives an ip from the dhcp server located in the vm fog


  • Moderator

    @kortnor What do your host-only network settings look like?



  • the issue with the host-only adapter is that I won’t be on the same network as the server itself. the client won’t be able to see the dhcp server hosted on the virualmachine ( fog server)


  • Moderator

    Try bridged adapter instead of host-only.


Log in to reply
 

329
Online

38729
Users

10555
Topics

99937
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.