Fog 1.2 Active Directory Defaults on New Host



  • Whenever I create a new host, the active directory defaults at the bottom are always wrong. They are not what is set in the Fogsettings>Active Directory Defaults. Is there a way I can fix this so Fog grabs the correct default settings when making new hosts? I would add pictures but that feature seems to be broken right now? (at least it wasn’t working for me).


  • Moderator

    @dustindizzle11 It would be nice, and this has been asked for several times. In order to implement it, I believe a lot of code would need edited and rewritten. It would include changes in the database, the inits, the web interface - we would likely need an entire new management page just for domains.

    I would even like the feature. But I would rather put it off till 2.0 in order to get 1.3.0 out faster.

    Right now, if you want to be able to have the right domain info inserted for a host during a full-registration via the boot menu, the way to do this currently is to set your AD defaults to what you would want them to be.



  • @Wayne-Workman

    Thanks for the explanation, makes sense. If that is the functionality, It would be cool to have the “multiple domains” set in the fogsettings or something. Then fog could have a simple dropdown to select the domain that will be added upon adding the host in the web gui.


  • Moderator

    @dustindizzle11 The reason that this checkbox doesn’t change username/password/site if the info is already there is because it allows for hosts to use different usernames/passwords/sites.

    I may have 900 computers in a group that I set to Domain ABC and another 1,500 computers in another group that I want set to Domain DEF - and both domains have different usernames and passwords to join.

    if the checkbox forced the defaults - then fog can no longer support multiple domains and a lot of people would probably be pretty upset about that (including myself).

    Thread solved since the OP issue is resolved.



  • @Tom-Elliott @ch3i @Wayne-Workman

    Thanks for the responses! The “autofill” was the issue. The real issue though, is not that the browsers (Chrome and Firefox) had saved passwords, it is that when check-box is clicked for AD when creating a new host, nothing happens if any sort of “autofill” or “saved passwords” exist for the site. (picture below showing the portion I am talking about. BTW - The forums only let me upload files, the icon to insert pictures doesn’t function). Maybe this is just normal behavior, but I would expect fog to “fill in” the correct defaults once the check-box is hit regardless of any saved passwords or auto fill from the browsers. It works correctly (fills in the defaults) if autofill is turned off and if I delete my saved passwords for the site. It won’t function (fill in anything), if the autofill or saved passwords exist.

    0_1457627547436_fogdefaults3.JPG


  • Moderator

    @Tom-Elliott and @Wayne-Workman said, try to launch your web browser in private mode to ensure that you don’t have auto-fill and cache :

    • Chrome/Opera : Ctrl+Shit+N
    • Firefox/IE : Ctrl+Shift+P

  • Moderator

    @dustindizzle11 Can you give us a screen shot(s) of what your talking about?

    Also - be weary of your web browser’s auto-fill functionality.


  • Senior Developer

    At what bottom?

    Is there auto fill setup for your browser?


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.