Linux image, just boots to grub



  • Is there anything specifically special about imaging a linux based device? I have some old netbooks that are running Puppy Linux. I created an image, and a 2nd one to test, that uses part clone. The image seems to capture without a problem as well as deploy, but upon rebooting I only ever get the grub> loader. I’ve tried making and remaking the image a few times and using a different image in fog to the same result. Is there something I should do before uploading a linux image?

    0_1457456229012_PuppyImage Details.PNG

    On Ubuntu 14.04


  • Moderator

    I’ve imaged Ubuntu 15, CentOS 7, and Fedora 21-23 many times.

    Ubuntu defaults to extfs while in Fedora 21-23 you can select Ext4 as the filesystem to use.

    This is important because FOG only supports ext type file system resizing in Linux. (and only ntfs resizing in windows).

    I’m not sure what puppy uses… but it should work as non-resizable at the very least.

    Sebastian is on the right path, though. Follow his instructions.


  • Developer

    @Scott-B Which version of FOG are you currently on? See in the blue cloud on the web interface.

    Have you done capture and deploy with debug enabled yet? Any unusual things you see? While you are in debug upload mode. Please run sfdisk -d /dev/sda before you start uploading. Please take a picture and post it here.

    Usually grub> means that grub was not able to find the grub.conf file. It normaly resides in /boot/grub/grub.conf. Depending on how your partition layout looks like the /boot directory might be on the root partition or on an extra boot partition.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.