Config multicast



  • Plz, help me

    In the same vlan works multicast but in others vlan fails.

    My Dhcp Server
    0_1456877630848_upload-bcd30a23-0510-4919-a4b2-2de8cd7727af

    My config fog is:

    0_1456877391474_upload-228ab1a6-f48f-4683-bd9f-1a44ede2f196

    0_1456877315814_upload-c251de89-5165-4690-8f15-ece8a90a2cce


  • Moderator

    @george1421 /tftpboot/default.ipxe just points to the server where the boot.php web file is hosted.

    the boot.php file dynamically generates a configuration for every host that queries it.

    Also - apologies for editing your post. I’m half here today.


  • Moderator

    @Erik-Rafael Ok now that unitcast works all on all vlans (this is an accomplishment in itself). Now for the multicasting. You need to enable the mrouter and igmp snooping on the link to the fog server (i think, we need a network admin here). Once that is turned on, then multicasting should work on your 901 vlan. (This is where my knowledge gets weak) if the mrouter is setup correctly it should find the subscribers on the other vlans and then broadcast the multicast traffic to that vlan.


  • Moderator

    This post is deleted!

  • Moderator

    @george1421 I don’t think it’s hard coded, the script is dynamically generated I think… but - I think he would need a storage group and master node for EACH interface.

    All of them can live in the same /images directory, I think, but you just would need each one to be a master for multicast to work properly. Each node would have an interface and IP for each interface.

    You can set an image in FOG Trunk to be associated with many storage groups. The replicator will check and see that the files are the same across all groups (because it is THE same file), and therefore won’t do any replicating.

    Just an idea…



  • I reinstall fog with the new configuration and reboot, unicast works on all vlans but multicast does not work in any vlan (before work in vlan 901).

    I changed trunk to static on port gi1/0/12 where is connected fog, changed my fogserver /etc/networks/vlans.

    auto eth0
    iface eth0 inet static
    address 172.19.1.250
    netmask 255.255.255.0
    network 172.19.1.0
    broadcast 172.19.1.255
    gateway 172.19.1.254

    dns-* options are implemented by the resolvconf package, if installed

    dns-nameservers 172.19.1.2 172.19.1.4

    0_1456936302241_upload-f6707080-656d-44d3-90dd-6307e317112b

    0_1456936261614_upload-a4484118-4def-445a-9d3c-07bb83c6892b


  • Moderator

    @Sebastian-Roth Unless I’m reading the situation wrong, the OP has a single fog server with a network interface on each vlan. The fog ipxe default.ipxe file has a hard coded IP address in it. AFAIK, FOG is not designed to support deploying to multiple network interfaces. On its basic level the fog server will receive a pxe boot request on its primary network interface, but it will attempt to reply on the interface that is directly attached to the vlan. The device will start initiating communication to one IP fog IP address and the fog server will reply on a second IP address and the client will ignore the traffic because its from an unsolicited host.



    • I could only ping to 172.19.2.250,
    • I changed trunk to static on port gi1/0/12 where is connected fog, changed my fogserver /etc/networks/vlans, I changed 066 boot server (past 172.19.2.250) to (172.19.1.250) and now can ping to 172.19.1.250, its ok?

    My new Config
    auto eth0
    iface eth0 inet static
    address 172.19.1.250
    netmask 255.255.255.0
    network 172.19.1.0
    broadcast 172.19.1.255
    gateway 172.19.1.254
    # dns-* options are implemented by the resolvconf package, if installed
    dns-nameservers 172.19.1.2 172.19.1.4

    #auto eth0.901
    #iface eth0.901 inet static
    #. address 172.19.1.250
    #. netmask 255.255.255.0
    #. network 172.19.1.0
    #. gateway 172.19.1.10
    #. dns-nameservers 172.19.1.2 172.19.1.4
    #. dns-search ciis.xxx.edu
    #. vlan-raw-device eth0
    #.
    #auto eth0.902
    #iface eth0.902 inet static
    #. address 172.19.2.250
    #. netmask 255.255.255.0
    #. vlan-raw-device eth0
    #.
    #auto eth0.903
    #iface eth0.903 inet static
    #. address 172.19.3.250
    #. netmask 255.255.255.0
    #. vlan-raw-device eth0
    #.
    #auto eth0.904
    #iface eth0.904 inet static
    #. address 172.19.4.250
    #. netmask 255.255.255.0
    #. vlan-raw-device eth0
    #.
    #auto eth0.905
    #iface eth0.905 inet static


  • Developer

    @Erik-Rafael said:

    Mounting file system Failed
    Could not mount images folder (/bin/fog.upload)
    

    This error has nothing to do with multicast which is deploy/download!! Seams like the client cannot connect to the FOG server NFS share. So I guess it’s firewall rules somewhere on the way. Make sure NFS is allowed between the VLANs and see if upload and unicast download is working then.


  • Moderator

    @Erik-Rafael ok then that gives us new information. Lets see if we can get unicasts working first. From vlan 902 can you ping the fog server? When you pxe boot the client…

    Wait, just looked at your OP again. You have two network adapters in your FOG server, one on each vlan. This is not a currently supported configuration. At the very least you can only multicast from a single network interface. What is happening the FOG server is getting traffic on one interface and sending it out another interface.

    With your setup do you need to capture and deploy to both vlans?



  • Unicast and multicast only works in vlan 901,


  • Moderator

    You really need to get a cisco network admin involved with this. But I can see you do have an mrouter setup and you are doing igmp snooping so you have the elements in place. So you are /do use some multicasting today.

    Just looking at your configuration, I might assume that you need to do something with 1/0/12 since that is the source of your multicast traffic. You will also need do igmp snooping on the vlans for the servers and the pc network. The snooping tells the switch where a subscriber is for the multicast channel. I’m a bit out of my skill set with this, other than I know you need to speak with the networking group to get this sorted out.

    I don’t see any acl lists that would limit the PCs from communicating with the FOG server.

    Is it also safe to assume that unicast deployments work as intended?



  • Yes, in a different vlan multicasting fails, the error is :
    Mounting file system Failed
    Could not mount images folder (/bin/fog.upload)

    The scheme

    • FOG server on vlan 901 with IP address 172.19.1.250 - connected to the Switch Sw_PA403A (Cisco Catalyst 2960-x series) on port GigabitEthernet1/0/12
    • 24 PCs on vlan 902 with IP address lease from DHCP (172.19.2.x) from Windows Server - connected to the switch PA402 (Cisco 2960)
    • Switch PA402 connected to Switch Sw_PA403A on port Gi1/0/1

    Config Switch Sw_PA403A
    Sw_PA403A#show running-config
    version 15.0
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname Sw_PA403A
    !
    boot-start-marker
    boot-end-marker
    !
    no aaa new-model
    switch 1 provision ws-c2960x-24ts-l
    ip routing
    !
    ip igmp snooping vlan 903 mrouter interface Gi1/0/9
    ip igmp snooping vlan 910 mrouter interface Gi1/0/8
    ip igmp snooping vlan 909 mrouter interface Gi1/0/7
    ip igmp snooping vlan 908 mrouter interface Gi1/0/6
    ip igmp snooping vlan 907 mrouter interface Gi1/0/5
    ip igmp snooping vlan 906 mrouter interface Gi1/0/4
    ip igmp snooping vlan 905 mrouter interface Gi1/0/3
    ip igmp snooping vlan 904 mrouter interface Gi1/0/2
    ip igmp snooping vlan 902 mrouter interface Gi1/0/1
    ip igmp snooping vlan 901 mrouter interface Gi1/0/13
    ip igmp snooping vlan 901 mrouter interface Gi1/0/14
    ip igmp snooping vlan 901 mrouter interface Gi1/0/15
    ip igmp snooping vlan 901 mrouter interface Gi1/0/16
    ip igmp snooping vlan 901 mrouter interface Gi1/0/17
    ip igmp snooping vlan 901 mrouter interface Gi1/0/18
    ip igmp snooping vlan 901 mrouter interface Gi1/0/19
    ip igmp snooping vlan 901 mrouter interface Gi1/0/20
    ip igmp snooping vlan 901 mrouter interface Gi1/0/21
    ip igmp snooping vlan 901 mrouter interface Gi1/0/22
    ip igmp snooping vlan 901 mrouter interface Gi1/0/23
    ip igmp snooping vlan 901 mrouter interface Gi1/0/24
    !
    spanning-tree mode pvst
    spanning-tree extend system-id
    !
    vlan internal allocation policy ascending
    !
    ip ssh time-out 30
    ip ssh version 2

    !
    interface FastEthernet0
    no ip address
    no ip route-cache
    shutdown
    !
    interface GigabitEthernet1/0/1
    switchport mode trunk
    spanning-tree portfast trunk
    !
    interface GigabitEthernet1/0/2
    switchport mode trunk
    spanning-tree portfast trunk
    !
    interface GigabitEthernet1/0/3
    switchport mode trunk
    spanning-tree portfast trunk
    !
    interface GigabitEthernet1/0/4
    switchport mode trunk
    spanning-tree portfast trunk
    !
    interface GigabitEthernet1/0/5
    switchport mode trunk
    spanning-tree portfast trunk
    !
    interface GigabitEthernet1/0/6
    switchport mode trunk
    spanning-tree portfast trunk
    !
    interface GigabitEthernet1/0/7
    switchport mode trunk
    spanning-tree portfast trunk
    !
    interface GigabitEthernet1/0/8
    switchport mode trunk
    spanning-tree portfast trunk
    !
    interface GigabitEthernet1/0/9
    switchport access vlan 903
    switchport mode access
    spanning-tree portfast trunk
    !
    interface GigabitEthernet1/0/10
    switchport mode trunk
    spanning-tree portfast trunk
    !
    interface GigabitEthernet1/0/11
    switchport mode trunk
    spanning-tree portfast trunk
    !
    interface GigabitEthernet1/0/12
    switchport mode trunk
    spanning-tree portfast trunk
    !
    interface GigabitEthernet1/0/13
    switchport access vlan 901
    switchport mode access
    spanning-tree portfast trunk
    !
    interface GigabitEthernet1/0/14
    switchport access vlan 901
    switchport mode access
    spanning-tree portfast trunk
    !
    interface GigabitEthernet1/0/15
    switchport access vlan 901
    switchport mode access
    spanning-tree portfast trunk
    !
    interface GigabitEthernet1/0/16
    switchport access vlan 901
    switchport mode access
    spanning-tree portfast trunk
    !
    interface GigabitEthernet1/0/17
    switchport access vlan 901
    switchport mode access
    spanning-tree portfast trunk
    !
    interface GigabitEthernet1/0/18
    switchport access vlan 901
    switchport mode access
    spanning-tree portfast trunk
    !
    interface GigabitEthernet1/0/19
    switchport access vlan 901
    switchport mode access
    spanning-tree portfast trunk
    !
    interface GigabitEthernet1/0/20
    switchport access vlan 901
    switchport mode access
    spanning-tree portfast trunk
    !
    interface GigabitEthernet1/0/21
    switchport access vlan 901
    switchport mode access
    !
    interface GigabitEthernet1/0/22
    switchport access vlan 901
    switchport mode access
    !
    interface GigabitEthernet1/0/23
    switchport access vlan 901
    switchport mode access
    !
    interface GigabitEthernet1/0/24
    switchport access vlan 901
    switchport mode access
    !
    interface GigabitEthernet1/0/25
    !
    interface GigabitEthernet1/0/26
    !
    interface GigabitEthernet1/0/27
    !
    interface GigabitEthernet1/0/28
    !
    interface Vlan1
    no ip address
    shutdown
    !
    interface Vlan901
    ip address 172.19.1.10 255.255.255.0
    !
    ip http server
    ip http secure-server
    !
    !
    snmp-server community public RO
    snmp-server community private RW
    !
    !
    mac address-table aging-time 0 vlan 1
    end

    Config Switch Sw_PA402

    hostname Sw_PA402
    !
    boot-start-marker
    boot-end-marker
    !
    !
    ip igmp snooping vlan 902 mrouter interface Fa0/1
    ip igmp snooping vlan 902 mrouter interface Fa0/2
    ip igmp snooping vlan 902 mrouter interface Fa0/3
    ip igmp snooping vlan 902 mrouter interface Fa0/4
    ip igmp snooping vlan 902 mrouter interface Fa0/5
    ip igmp snooping vlan 902 mrouter interface Fa0/6
    ip igmp snooping vlan 902 mrouter interface Fa0/7
    ip igmp snooping vlan 902 mrouter interface Fa0/8
    ip igmp snooping vlan 902 mrouter interface Fa0/9
    ip igmp snooping vlan 902 mrouter interface Fa0/10
    ip igmp snooping vlan 902 mrouter interface Fa0/11
    ip igmp snooping vlan 902 mrouter interface Fa0/12
    ip igmp snooping vlan 902 mrouter interface Fa0/13
    ip igmp snooping vlan 902 mrouter interface Fa0/14
    ip igmp snooping vlan 902 mrouter interface Fa0/15
    ip igmp snooping vlan 902 mrouter interface Fa0/16
    ip igmp snooping vlan 902 mrouter interface Fa0/17
    ip igmp snooping vlan 902 mrouter interface Fa0/18
    ip igmp snooping vlan 902 mrouter interface Fa0/19
    ip igmp snooping vlan 902 mrouter interface Fa0/20
    ip igmp snooping vlan 902 mrouter interface Fa0/21
    ip igmp snooping vlan 902 mrouter interface Fa0/22
    ip igmp snooping vlan 902 mrouter interface Fa0/23
    ip igmp snooping vlan 902 mrouter interface Fa0/24
    !
    !
    spanning-tree mode pvst
    spanning-tree extend system-id
    !
    vlan internal allocation policy ascending
    !
    vlan 901
    name FIA
    !
    vlan 902
    name C1A402
    !
    vlan 904
    name C1B207
    !
    !
    !
    interface FastEthernet0/1
    switchport access vlan 902
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet0/2
    switchport access vlan 902
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet0/3
    switchport access vlan 902
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet0/4
    switchport access vlan 902
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet0/5
    switchport access vlan 902
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet0/6
    switchport access vlan 902
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet0/7
    switchport access vlan 902
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet0/8
    switchport access vlan 902
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet0/9
    switchport access vlan 902
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet0/10
    switchport access vlan 902
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet0/11
    switchport access vlan 902
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet0/12
    switchport access vlan 902
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet0/13
    switchport access vlan 902
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet0/14
    switchport access vlan 902
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet0/15
    switchport access vlan 902
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet0/16
    switchport access vlan 902
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet0/17
    switchport access vlan 902
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet0/18
    switchport access vlan 902
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet0/19
    switchport access vlan 902
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet0/20
    switchport access vlan 902
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet0/21
    switchport access vlan 902
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet0/22
    switchport access vlan 902
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet0/23
    switchport access vlan 902
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet0/24
    switchport access vlan 902
    switchport mode access
    spanning-tree portfast
    !
    interface GigabitEthernet0/1
    description Enlace—>A403-A
    switchport mode trunk
    !
    interface GigabitEthernet0/2
    description Enlace—>Sw_Dlink
    switchport access vlan 902
    switchport mode access
    !
    interface Vlan1
    no ip address
    no ip route-cache
    shutdown
    !
    interface Vlan901
    ip address 172.19.1.12 255.255.255.0
    no ip route-cache
    !
    interface Vlan902
    no ip address
    no ip route-cache
    !
    ip default-gateway 172.19.1.254
    ip http server
    ip http secure-server
    snmp-server community public RO
    snmp-server community private RW
    !
    control-plane
    !
    !
    line con 0
    password 7 XX
    logging synchronous
    login
    line vty 0 4
    password 7 XX
    logging synchronous
    login
    line vty 5 15
    password 7 XX
    login
    !
    end


  • Moderator

    @Erik-Rafael Which router/switch you use ?


  • Moderator

    @george1421 said:

    Your router between the vlans needs to allow the multicast traffic to cross.

    Specifically, broadcast forwarding.


  • Moderator

    Just so I understand, within the same broadcast domain (vlan) multicasting works as intended, but in a different vlan multicasting fails?

    If this is the case I can understand. Your router between the vlans needs to allow the multicast traffic to cross. This is because multicasts only work within the same broadcast domain. To get this to work you will need the setup multicast routing.


Log in to reply
 

443
Online

38941
Users

10697
Topics

101497
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.