php5-gettext



  • php5-gettext is no longer in Ubuntu repository…
    I can’t install fog because that


  • Senior Developer

    Added checking code to remove any package that can no longer be found.


  • Moderator

    Another thing to try is the -X installer argument, to continue if that package fails.

    Of course, after the installation gets done, I’d edit /opt/fog/.fogsettings in order to remove the php5-gettext package and then re-run the installer proper.

    ./installfog.sh --help
    
    
    
       +------------------------------------------+
       |     ..#######:.    ..,#,..     .::##::.  |
       |.:######          .:;####:......;#;..     |
       |...##...        ...##;,;##::::.##...      |
       |   ,#          ...##.....##:::##     ..:: |
       |   ##    .::###,,##.   . ##.::#.:######::.|
       |...##:::###::....#. ..  .#...#. #...#:::. |
       |..:####:..    ..##......##::##  ..  #     |
       |    #  .      ...##:,;##;:::#: ... ##..   |
       |   .#  .       .:;####;::::.##:::;#:..    |
       |    #                     ..:;###..       |
       |                                          |
       +------------------------------------------+
       |      Free Computer Imaging Solution      |
       +------------------------------------------+
       |  Credits: http://fogproject.org/Credits  |
       |       http://fogproject.org/Credits      |
       |       Released under GPL Version 3       |
       +------------------------------------------+
    
    
       Version: 6455 Installer/Updater
    
    
     * Found FOG Settings from previous install at: /opt/fog/.fogsettings
     * Performing upgrade using these settings
    
    
      Starting Redhat based Installation
    
    
    Usage: ./installfog.sh [-h?dEUuHSCKYXT] [-f <filename>]
    		[-D </directory/to/document/root/>] [-c <sslPath>]
    		[-W <webroot/to/fog/after/docroot/>] [-B </backup/path/>]
    		[-s <192.168.1.10>] [-e <192.168.1.254>] [-b <undionly.kpxe>]
    	-h -? --help			Display this info
    	-d    --no-defaults		Don't guess defaults
    	-U    --no-upgrade		Don't attempt to upgrade
    	-H    --no-htmldoc		No htmldoc, means no PDFs
    	-S    --force-https		Force HTTPS redirect
    	-C    --recreate-CA		Recreate the CA Keys
    	-K    --recreate-keys		Recreate the SSL Keys
    	-Y -y --autoaccept		Auto accept defaults and install
    	-f    --file			Use different update file
    	-c    --ssl-file		Specify the ssl path
    	               				defaults to /opt/fog/snapins/ssl
    	-D    --docroot			Specify the Apache Docroot for fog
    	               				defaults to OS DocumentRoot
    	-W    --webroot			Specify the web root url want fog to use
    	            				(E.G. http://127.0.0.1/fog,
    	            				      http://127.0.0.1/)
    	            				Defaults to /fog/
    	-B    --backuppath		Specify the backup path
    	      --uninstall		Uninstall FOG
    	-s    --startrange		DHCP Start range
    	-e    --endrange		DHCP End range
    	-b    --bootfile		DHCP Boot file
    	-E    --no-exportbuild		Skip building nfs file
    	-X    --exitFail		Do not exit if item fails
    	-T    --no-tftpbuild		Do not rebuild the tftpd config file
    	-P    --no-pxedefault		Do not overwrite pxe default file
    

  • Moderator

    @Tom-Elliott And for new installations where it’s never even written in /opt/fog/.fogsettings to begin with?


  • Senior Developer

    @danilopinotti why do people insist this is a bug? I didn’t remove php5-get text from the repository nor do I know why it was removed to begin with.

    Furthermore, remove the get text info from the packages Line in /opt/fog/.fogsettings and it will be fixed.


  • Moderator

    Try to install it manually.
    https://launchpad.net/php-gettext/trunk/1.0.12

    And then remove it from FOG’s install list.

    lib/ubuntu/config.sh

    Remove this:

    0_1456445305952_Screenshot from 2016-02-25 18:06:03.png

    Let us know how it goes.


Log in to reply
 

449
Online

38927
Users

10692
Topics

101463
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.